Mail IMAP Account: Will not store SENT messages on server !

Discussion in 'Mac Apps and Mac App Store' started by saoir, Dec 17, 2007.

  1. saoir macrumors member

    Joined:
    Dec 8, 2007
    Location:
    Dublin
    #1
    Hi all ! - New iMac in small office.

    I have just discovered that my IMAP email account is not saving any of my outgoing SENT emails on the server ! I have checked the settings and the option to store on the server is ticked.

    I spoke to my ISP guy just now and he confirmed that there is nothing in the sent folder despite the fact that I sent three important emails today.
    He suggested I 'untick' the option and save sent emails on my local iMac - and I did - and it works.....

    But what is the point of an IMAP account ?? I need to work at two locations and synch the accounts ...

    I found mention of this elsewhere on Google... but cannot see any fix.

    (I have all updates downloaded and installed on the iMac as of this afternoon)

    Anyone ?

    Tks

    Saoir
     
  2. saoir thread starter macrumors member

    Joined:
    Dec 8, 2007
    Location:
    Dublin
    #2
    ok.... I may have solved it. Typical - an hour spent pointlessly, then I post a help post and then I find the solution :)

    Anyway... it seems Mail does not automatically know where on the server to save Sent messages. If this happens than you have to select the 'sent' or 'sent messages' folder listed on the left hand side under the IMAP account in question . . . ten go to MAILBOX/USETHISMAILBOXFOR and chose 'Sent'.

    The 'sent' or 'sent messages' folder under the IMAP account then disappears and reappears under the normal local Sent mailbox.

    I sent test messages and checked with the ISP and they are indeed now being stored on the server.

    Hope this helps someone !


    Saoir
     
  3. teriny macrumors newbie

    Joined:
    Mar 13, 2008
    #3
    but where is the 'sent' /'sent messages' folder?

    i am having exactly the same problem with my IMAP account neglecting to sync my sent mail, but i didn't quite follow your solution:

    "If this happens than you have to select the 'sent' or 'sent messages' folder listed on the left hand side under the IMAP account in question . . . ten go to MAILBOX/USETHISMAILBOXFOR and chose 'Sent'."

    When I look at the IMAP account in my macmail (macmail-preferences-accounts), i don't see a 'sent' or 'sent messages' folder....?
     
  4. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #4
    You need to do this for Junk and Drafts too if you want those available on multiple servers.
     
  5. teriny macrumors newbie

    Joined:
    Mar 13, 2008
  6. teriny macrumors newbie

    Joined:
    Mar 13, 2008
    #6
    never mind

    I see now...you have to quit and reopen mac mail after setting up the account, and then the IMAP account appears to the left of the mailbox (you don't have to go back into preferences) at the bottom of all the mail folders (so you may not see it at first if you have a lot of folders--you have to scroll down)....click on 'sent' inside that folder. Then, inside the mailbox drop-down at the top of the screen, click on 'use this mailbox for' and choose 'sent'.
     
  7. ubercool macrumors 6502a

    ubercool

    Joined:
    Jan 31, 2008
    Location:
    Las Vegas
    #7
    I have the opposite input/result:

    1. If I check "Store sent messages on the server," Mail will store sent items in the IMAP account's "Sent" folder.

    2. If I *uncheck* it, Mail will actually store them on the IMAP server, which can be accessed on the iPhone, etc.

    Anyone care to shed some light here? :confused:
     
  8. Dagon macrumors newbie

    Joined:
    Jul 7, 2003
    #8
    This has been a mild annoyance to me for a long time. Thanks for the tip.
     
  9. mbuensalido macrumors newbie

    Joined:
    Jul 12, 2008
    #9
    I just got this to work!

    @teriny

    Thanks for this tip. I finally got this to work by selecting the IMAP\FolderName and clicking the "Use this Mailbox for".
     

Share This Page