Mail - Incorrect password message with POP

Discussion in 'iPhone Tips, Help and Troubleshooting' started by buzzert, Jul 1, 2007.

  1. buzzert macrumors newbie

    Joined:
    Nov 10, 2006
    #1
    Hey all!

    I am using my iPhone's mail client with one of my POP accounts. For some reason, it often gives an error message saying "Incorrect username or password given for..." where I indeed did provide a correct password. The strangest part, however, is that this only happens sometimes, and more often on the EDGE network.

    Anyone else experiencing this problem?

    Thanks!
     
  2. kmstrs macrumors newbie

    Joined:
    Jul 1, 2007
    #2
    Same error here

    My wife and I also have this problem. Additionally, her iPhone will frequently say that she has 2.1 million unread messages. We use a POP server running on a linux box for our email.

    I have a suspicion that this is a "generic" error message and that the real problem is something else. After getting mail on the iPhone, if I try to get mail from a desktop, I get an error message that the mailbox is in use- it is almost as if the iPhone does not properly close things down, and I have to wait a few minutes before things work again.
     
  3. kdbdallas macrumors newbie

    Joined:
    Apr 9, 2007
    #3
    Mine happens will Mail.app

    I got the 2 million message once, and now it all seems fine on the iPhone, but I have the problem where Mail.app keeps giving me the wrong password message. If I click cancel and then do Get Mail again, it works. Something is up... One thing to note, the Password errors only happen on the mail accounts running on IIS for me. My account that is on Linux doesn't get the error.
     
  4. tritip macrumors newbie

    Joined:
    Jun 10, 2004
    #4
    Is this a mailbox locking issue?

    I was getting the same error message. I telnetted in on port 25 from my desktop mac and got a "Mailbox Locked" message. Unix's Mail Service has this very simplistic lock mechanism that prevents two mail clients from polling the same mail file simultaneously.

    I'm guessing the iPhone pop3 client doesn't properly clean up the mailbox lock. Yeesh. This is very basic stuff. We shouldn't have to deal with it.

    Perhaps using port 587 may solve the problem? Anyone?
     
  5. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #5
    "Unix's Mail Service has this very simplistic lock mechanism that prevents two mail clients from polling the same mail file simultaneously."

    Your right. Two clients can not access a box at the same time and it takes a second for it to close after checking, in some clients double-clicking the "get new mail" icon can trigger a locked mail box error.

    If your computer is checking every 5 minutes, there is a good chance the phone will grab at the same time.

    If thats not the problem then it may also be the mail server or port used. The former SBC had this problem for a month or so with mail accounts. I had SEVERAL clients saying they were being asked for a password - if they canceled, and checked again all was well. In this case only one client was checking and it was a server issue.
     
  6. tritip macrumors newbie

    Joined:
    Jun 10, 2004
    #6
    I don't think it's the server

    I've been polling for mail from two different computers for months now. I only started to have problems when I used the iPhone.
     
  7. somecows macrumors member

    Joined:
    May 6, 2003
    Location:
    Charlottesville, VA
    #7
    I'm trying to figure out if I am having the same problem you guys are. I have 3 POP accounts each on a differnet server. 2 of them work fine, the 3rd one keeps giving me the password error message. However, it doens't go away if I hit the cancel button. I just keep getting it.

    Is there some way to configure the server NOT to lock the mailbox? Since my two accounts on other servers are not having this problem, I assume there must be something different about the way they are configured...
     
  8. somecows macrumors member

    Joined:
    May 6, 2003
    Location:
    Charlottesville, VA
    #8
    It does seem strange that the iphone and desktop would happen to check mail at *exactly* the same moment, resulting in the lock.

    I can see it happening from time to time, but not consistently, without fail...
     
  9. julieann123 macrumors newbie

    Joined:
    Jul 2, 2007
    #9
    Pop3 Errors

    I am also getting "cannot send email The connection to the server mail.west.cbeyond.com failed".

    I am also having issues receiving emails..some come through but most say "This mesage has no content" or "This message has not been downloaded from the server"...all of my emails on gmail come through ok.

    Any ideas?
     
  10. skinnylegs macrumors 65816

    skinnylegs

    Joined:
    May 8, 2006
    Location:
    San Diego
    #10
    I think that part of the problem may be that many incoming and outgoing servers are passworded (is that a word? LOL). Anyway, make sure you know your password then enter it in both the incoming and outgoing server boxes and see if that works.

    I too get occasional messages with a message stating something to the effect of "Not all content downloaded" but there is a button I can click to dl the rest of the content. For instance, I get a local weather report emailed to me daily and the email comes but I have to choose to dl the rest of the content in the email.

    Hope this is helpful.
     
  11. julieann123 macrumors newbie

    Joined:
    Jul 2, 2007
    #11
    Pop3 Issues

    My password is correct...An Apple Genious couldn't figure it out either, He said it was my server....I set up the email the same way as it is on my outlook pc.

    Thank you
     
  12. z400central macrumors regular

    Joined:
    Nov 8, 2006
    #12
    I am getting the same problem. I pretty much have to FULL power off my iPhone, and THEN the Mail APP on my MBP can login without the password coming up.

    Strange!
     
  13. BobbyDigital macrumors member

    Joined:
    Sep 13, 2006
    #13
    I get the same exact problem as you... if I shut my phone off, Mail.app on my Mac works fine. But if my iPhone is on, i consistently get a pop up asking for me to enter the password... no matter what.

    I REALLY hope this gets fixed soon, because if it doesn't, I will be forced to not use mail on my iPhone... these prompts are disrupting my workflow on my desktop.

    :mad:
     
  14. julieann123 macrumors newbie

    Joined:
    Jul 2, 2007
    #14
    Pop3 Emails

    I spoke to Apple tech. The problem is that it is inconsistant. Some emails I receive fine...most say "this image has not been downloaded" and I get the password error. The apple tech asked me to journal when this happens and try different ports.
    I think anyone and everyone who has a Pop3 issue should call tech support and log the issue.
     
  15. asthukral macrumors newbie

    Joined:
    Jul 2, 2007
    #15
    POP 3 Mail Issue

    I have not been able to get the POP3 to work to begin with. THe POP3 account is verified in the mail setting. However when I access the mail it shows 'Load 50 more messages'. Further the SMTP (outbound) works but only to recepients that are on my exchange server and not outside the my exchange domain.

    any help will be appreciated.
     
  16. uberfoto macrumors member

    Joined:
    Apr 24, 2006
    #16
    I am getting the same thing. I guessed it was because both my laptop and phone were trying to access the account at the same time. Surprisingly it only happens on one of my two pop3 accounts. By changing the iPhone to "manually check" email and exiting [iPhone] Mail while I work on my computer, I have made it work. When I leave my desk I exit Mail on my laptop and check messages on the phone.

    There has to be a fix for this. It seems pretty simple and from the posts above, it is pretty common.
     
  17. jrudmin macrumors newbie

    Joined:
    Jul 3, 2007
    #17
    POP implementation is bad

    The POP3 standard specifies that only a single connection can be made to the mailbox at a time. Apple's implementation is bad as it keeps hitting it to download preview lines and made delete as it is loading from it. I'm sure they'll fix it soon.

    Also POP3 connections need to be terminated as soon as possible. It looks like the iPhone holds on to it every once in a while (for a short while) which makes other mail apps not work if you've just used your iPhone.

    Of course if your POP3 implementation does allow multiple connections (which it shouldn't and isn't safe due to design of how messages are numbered & deleted) then you'll never notice these issues. But you'll be at risk when it comes to deleting stuff.
     
  18. ScottW-CO macrumors newbie

    Joined:
    Jun 29, 2007
    #18
    I'm having similar problems with mailbox locking. My old Treo 600, I had set up for a pair of email accounts, on a 15-min timer. My main email client on my PC (Thunderbird), on a 5-min timer.

    Every once in a while, there'd be a conflict and I'd have to tell Thunderbird to go ahead and use the pw it has. Usually the lock would clear up right away and Thunderbird could do its check.

    Not so with the iPhone's mail client - if it checks these addresses, it can take quite a while for Thunderbird to be allowed in.

    I ended up turning off the auto-check on the iPhone and just set it to "manual". I figure, it's a 1.0 version - there'll be tweaks.

    On a completely unrelated note - some of you need to learn the difference between "your" and "you're". :D
     
  19. uberfoto macrumors member

    Joined:
    Apr 24, 2006
    #19
    That is one of my biggest annoyances on the net! It is so simple, yet most people are ignorant to it. Proper English and correct grammar/spelling are meaningless to a lot of people. They just don't care.

    I've pointed it out to some friends but I get called names. "What are you, some English spelling and grammar Nazi?" :rolleyes:

    Come on people this is third grade English stuff!

    :D
     
  20. prutherford macrumors newbie

    Joined:
    Jul 3, 2007
    #20
    Incorrect password message

    I had this problem too, until I realized that non-alphanumeric characters (specifically the pound sign #) was not allowed in the password field (iPhone). Yahoo accepted it just fine, but...

    I changed my password to contain only alpha and numeric and all is good again...go figure.
     
  21. alecstory555 macrumors newbie

    Joined:
    Sep 18, 2009
    #21
    I fixed my problem.

    I was getting the wrong user name password error and because I had two other email accounts working fine that are on the same server, I couldn't figure out what was happening.

    I then realized that I had setup the new account with the default imap choice, instead of pop.

    When you create an email account on the iphone, you select either imap or pop and you can only make this selection at that time.

    So, I deleted the imap account and created a pop one.

    It works.:D
     
  22. brianinorbit macrumors newbie

    Joined:
    Mar 12, 2010
    #22
    pop mail with mac mail/iphone

    Im having very similar issues!! Annoying....
    I was consistently getting "incorrect password for pop account" message on both my mac mail and iphone..
    After reading this blog I changed mac mail to retrieve mail every 30 minutes...
    so far so good. hope this has solved my problem and helps y'all out.
     
  23. mrwaffleman97 macrumors newbie

    Joined:
    Jan 1, 2011
    #23
    I found a solution!!

    Hi. I had the same problem as you guys. I am using hotmail for my email and when I tried to send a letter to my dad, it says "The username or password for...@hotmail.com@smtp.live.com is incorrect" so what I did is I went to Settings>Mail, Contacts, Calenders>under accounts, choose the one that is having the problem>under incoming mail server, re-enter the password>outgoing mail server>primary server>under outgoing mail server, re-enter your password and make sure that the server is on. After doing all that, I noticed that the message that I was trying to send was sent automatically. Hope this helped!
     
  24. Bizzielizzie23 macrumors newbie

    Joined:
    Jan 4, 2012
    #24
    Yay.....it worked!

    Thanks a million MrWaffleman97. I have not been able to send emails for weeks now and was receiving the same message as you when I attempted to send an email. It all went wrong when I received a new phone as my previous was faulty. I did exactly as you said and hey presto it now works!!!!
     
  25. CdnMacJen macrumors member

    Joined:
    Oct 7, 2011
    #25
    the username or password for "Hotmail" is incorrect.

    So I've had my iPhone 4s for almost 4 months now, and suddenly this morning I'm getting the "the username or password for "Hotmail" is incorrect" message when I try to access my e-mail.

    The above advice about re-entering the password for both incoming and outgoing isn't an option...when you go into the account settings, there is only one place to type in the password.

    So I've re-entered my password, and no luck.:confused:
    I've also turned my phone off and restarted it, and no luck.:mad:

    What gives? How do I get my email working again?
     

Share This Page