Mail is not working with iCloud account

Discussion in 'OS X El Capitan (10.11)' started by calleq, Jun 9, 2015.

  1. calleq macrumors newbie

    Joined:
    Jun 12, 2012
    #1
    Anyone else experiencing that mail won't connect to iCloud email account?

    All other iCloud services seems to be working just fine..
     
  2. RunningOne macrumors member

    Joined:
    Apr 19, 2015
    Location:
    MN
    #2
    iCloud was showing offline. In accounts, none of the features i.e. mail, iCloud drive, etc were selected, nor would they select.

    When I deleted the xxx.me.com account and left the xxx.icloud.com account mail came online immediately and I was able to select the features I wanted.
     
  3. z06gal macrumors 6502

    Joined:
    Aug 30, 2011
    #3

    Thank you for this. Finally working now after removing the me.com account ;)
     
  4. grinny11 macrumors regular

    Joined:
    Aug 12, 2008
    #4
    I tried signing out but it says

    "Your iCloud account couldn't be removed at this time. Turn off all iCloud services and try again."

    I try manually disabling mail, contacts, calendars, reminders, and notes (other are disconnected already) but the button clicks it back on right away. Not sure what else to do to turn off my iCloud account.
     
  5. z06gal macrumors 6502

    Joined:
    Aug 30, 2011
    #5

    Did you try going to ~/Library and deleting mail? I removed me.com and then did that to make sure. It is working great now
     
  6. grinny11 macrumors regular

    Joined:
    Aug 12, 2008
    #6

    Removed the mail folder. Still wouldn't let me disable or uncheck any iCloud options. Mail was rebuilt. Still can't send from iCloud account.
     
  7. z06gal macrumors 6502

    Joined:
    Aug 30, 2011
    #7

    Can you delete your iCloud account from system prefs > internet accounts?
     
  8. grinny11 macrumors regular

    Joined:
    Aug 12, 2008
    #8
    Neither the internet accounts or the iCloud section. I get the same response from both places.
     
  9. writevli macrumors newbie

    writevli

    Joined:
    Jul 7, 2013
    Location:
    Brussels, Belgium
    #9
    @me.com address in iCloud in System Preferences doesn't sign in, so Messages, Mail, etc don't work. Any solution? I've tried deleting it, restarting the mac… not resolution :/
     
  10. TrueBlou macrumors demi-god

    TrueBlou

    Joined:
    Sep 16, 2014
    Location:
    Scotland
    #10
    Make sure that under Mail -> Preferences -> Accounts -> Advanced your port is set to 993 and the Use SSL box is checked.

    When I installed El Capitan for some reason my port was set to 0.
     
  11. rmcinnes macrumors newbie

    rmcinnes

    Joined:
    Dec 3, 2011
    Location:
    Perth Australia
    #11
    In my case, Mail, Accounts, Advanced, the "automatically detect and maintain settings" setting was Off.
    But after I toggled the setting On/Off on both my iCloud Mail Accounts, the accounts both cleared and Mail works fine now...

    I have left "automatically detect and maintain settings" setting to Off.
    Maybe it should be On; any opinions on this, please?
     
  12. djamesslattery macrumors newbie

    Joined:
    Jun 10, 2016
    #12
    I am experiencing the same issue but with explorer only. It works with Edge and my outlook app
     
  13. Traveling_Donkey macrumors newbie

    Traveling_Donkey

    Joined:
    Oct 8, 2016
    #13
    I went to ~/Library and looked around but I'm not sure where to go from there. Can you help me with a little bit more direction? Thanks
     
  14. TrueBlou macrumors demi-god

    TrueBlou

    Joined:
    Sep 16, 2014
    Location:
    Scotland
    #14
    Maybe a reference to ~/Library/Mail/V2
    Used to be you would go there and then delete the folder that matched the email account which you removed in the settings. That would permanently get rid of all the cache and downloads which were used for the account.

    Normally you would do it to free up space and to help with issues related to the email account when you either wanted to stop using it. Or remove it and re-add it if you were having issues.

    I could be out of date with that, not done it for a while.
     

Share This Page