Mail is replying from the wrong email account

Discussion in 'Mac Apps and Mac App Store' started by dfran, Feb 12, 2009.

  1. dfran macrumors newbie

    Joined:
    Feb 12, 2009
    Location:
    London
    #1
    MBP, OS X 10.4.11, Mail v2.1.3.

    I have more than one email account set up on Mail and the strangest thing happens and I can't find out how to stop it.

    Here is the problem:

    - I have 2 accounts, 'Account A' is for my partner & 'Account B' is for me.
    - Someone sends an email to 'Account A' (my partner) and CCs 'Account B' (me) into the same eMail.
    - If I click reply from 'Account B' it sends the eMail from 'Account A' which is my partner, when it should be from me.

    I have worked out that this is because 'Account A' was originally sent the eMail in The 'To' field as opposed to the 'CC' field in composing the reply eMail. I know that I can manually change the 'From' field every time when replying to an eMail but it becomes an nuisance. I forget to do it when quickly replying as I consider Mail to reply from the account that I'm reading the email from.

    I have gone to the compose section in the preferences and there is an option for changing this when composing a new email but nothing when replying.
    Can you PLEASE HELP ME!!
     
  2. Henri Gaudier macrumors 6502a

    Henri Gaudier

    Joined:
    May 4, 2005
    Location:
    France
    #2
    Come on ...

    ... there must be someone to help dfran out!
     
  3. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #3
    Use the drop down menu pointed too with the arrow to select which account to send from (click on the image to see a larger version).
     

    Attached Files:

  4. dfran thread starter macrumors newbie

    Joined:
    Feb 12, 2009
    Location:
    London
    #4
    Thanks for the reply. I knew this way but I just thought there might be a way of doing it automatically. Even though I know this, I still sometimes send it from the wrong account. It looks like I need get it into my brain.

    Thanks agin. Anyone else please answer if you have any ideas.
     
  5. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #5
    There is just select the correct mailbox for the account you want to send from before you click new message.
     
  6. Dedonut macrumors newbie

    Joined:
    Aug 12, 2007
    Location:
    No. CA
    #6
    Same problem - reply is from the wrong account/sender

    Same thing here ... drives us both nuts. If we don't check the From box, I may be sending my message from the other User's Account and visa versa. It doesn't matter who sent a message last, or who received one ... or any other variation. It seems random.

    We know to check the From box but that's a nuisance that sometimes gets overlooked and causes confusion when we don't catch it.

    Is there nothing in Settings or ??? to stop this?
     
  7. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #7
    It sounds as though you are sharing one MacOS X account between two users. This is very bad practice. Each user should have and use his/her own separate account. In fact, it is recommended that administrators use at least two--one administrator account for administrative purposes and a standard account for non-administrative tasks.
     
  8. shaunvis macrumors member

    Joined:
    May 26, 2009
    #8
    I'm having this same issue. It's pretty odd...

    I have:
    - personal email
    - work email

    I was setting up a new mail server & sent a mail to my personal email & cc'd my work email. If I reply from my personal it sends from personal by default.

    If I reply from my work email, it defaults to sending from my personal email account.

    This is very odd. Why wouldn't it default to replying from the account you are in at the time? I have preferences set to "send new mail from selected account" but there's nothing about replies.

    Anyone figure out a fix yet? I know this thread is old, but it's one of the first things I found doing a search
     

Share This Page