Mail Issues (Double notifications, no sender emails)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mikelong622, Mar 11, 2011.

  1. mikelong622 macrumors 6502

    Joined:
    Sep 29, 2006
    Location:
    St. Paul, Minnesota
    #1
    I'm not sure how long this has been happening, but I'm suddenly getting all sorts of strange issues in mail on my iPhone. I'm using Gmail, set up through a Microsoft Exchange server. I followed Google's instructions, and have had no issues up until now.

    First issue is that I get two notifications for each email that arrives. When I get an email, I hear the "New Mail Sound," but the mail icon shows no new messages. Shortly after (sometimes a few seconds, sometimes just a split second) a new notification sound will ring, and then the icon will show the new message. I've tried restoring my phone, I upgraded the iOS, I've removed the gmail account and re-added it. Nothing seems to work.

    The second issue I get are the "No sender, no subject" emails that are dated at 12/31/1969. I've found that a reboot fixes this, but that is awfully annoying.

    Does anyone have any suggestions? It's a pain to have to deal with this when it used to run so smoothly.
     
  2. JSingr macrumors member

    Joined:
    Apr 23, 2010
    #2

    The phone is stock and not jailbroken? What happens when you go to a different folder on gmail and return top the inbox..Does it resolve the 1969 issue?
     
  3. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #3
    I am not having those exact problems but I am having Exchange (Google Exchange) issues. My problem is that I am not recieving push notifications immediately. After an email lands in Gmail I might not get it for up to an hour (but the time period seems very random). If I see an email land in gmail on my PC but it hasn't triggered an alert in iOS (4.3), if I reboot my iP4 then as soon as it's done rebooting the email lands. This makes me think that iOS is having problems with Exchange. This ugly problem popped up previously in 4.2 (if I remember correctly but seemed to resolve itself somehow. I wish I could pinpoint what was happening a little more closely.
     
  4. mikelong622 thread starter macrumors 6502

    Joined:
    Sep 29, 2006
    Location:
    St. Paul, Minnesota
    #4
    Initially when the problem arose I was running a jailbroken iPhone, but I restored it and set it up from scratch and still have the same issue. I started a posting on the official Apple support forums, and am getting tons of people chiming in with the same issue. The double notifications seem to have stopped, but I am still getting extremely delayed notification on new emails.

    It's been a few days since I got the "No Sender No Subject" emails, but it seems like they come mainly as messages with multiple threads in them. I keep threaded conversations on in my iPhone's email settings. I'm wondering if it has something to do with the way gmail on my phone handles deleting messages, perhaps some sort of remnant of a deleted threaded conversation.

    Thanks for the feedback. If anyone else has any, it'd be appreciated!
     
  5. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #5
    Never had the "No Sender No Subject" emails. Had the double notifications one time. Still have the delayed push as I stated above. Never had it jailbroken.
     
  6. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #6
    I found a wrokaround. In your exchange settings (for Gmail at least) set your push folder to also look at All Mail. If this doesn't work initially then delete your account, reboot the phone, create the exchange account again and add all mail to push folder.
     
  7. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #7
    Seems as though everything is back to normal for me and a few others.
     

Share This Page