Mail keeps asking about SMTP servers

billyb

macrumors member
Original poster
Apr 26, 2003
54
0
I'm using a 12" PB 1 Ghz with Tiger, everything updated. My settings in Mail are to use my ISP's SMTP server as the outgoing server, which works great at home. When I connect at work and try to send something, I get the dropdown box asking me to pick a different SMTP server. It tells me that it will use this new one until my network changes.

This is fine, it's how it's always been. But the problem is that it DOESN'T use the new one thereafter...it gives me the same message every time i send a message, as if it's forgotten I told it to use a different SMTP. THis was never a problem in Panther.

Any suggestions? Thanks very much in advance,

-bb
 

MisterMe

macrumors G4
Jul 17, 2002
10,648
29
USA
billyb said:
I'm using a 12" PB 1 Ghz with Tiger, everything updated. My settings in Mail are to use my ISP's SMTP server as the outgoing server, which works great at home. When I connect at work and try to send something, I get the dropdown box asking me to pick a different SMTP server. It tells me that it will use this new one until my network changes.

This is fine, it's how it's always been. But the problem is that it DOESN'T use the new one thereafter...it gives me the same message every time i send a message, as if it's forgotten I told it to use a different SMTP. THis was never a problem in Panther.

Any suggestions? Thanks very much in advance,

-bb
You should be thanking your lucky stars rather than complaining. Not everyone is able to use their commercial ISP's SMTP server when connected to a different provider. But somewhat more to the point, this may be an extra layer of security introduced in Tiger. Back in the days of MacOS X 10.0, you didn't need an SMTP server. Alas, those days are long gone.
 

billyb

macrumors member
Original poster
Apr 26, 2003
54
0
not whining

MisterMe said:
Not everyone is able to use their commercial ISP's SMTP server when connected to a different provider.
Maybe I wasn't clear. In my Mail settings, the outgoing SMTP is the one for Comcast, who I'm referring to as my ISP. When I'm at work, the message states that it cannot use the Comcast server, which makes sense to me...I'm not complaining! I'm complaining that I tell it to use the server at work, which it happily does...but then I have to tell it each time to do so, despite it telling me that it will remember the new SMTP server until further notice. Since it tells me it's going to do something and then doesnt' do it, I suspect it's not a new security feature.

Hope that clarifies things.

bb
 

Mitthrawnuruodo

Moderator emeritus
Mar 10, 2004
13,817
186
Bergen, Norway
Make a new mail account (dummy, secondary or even your real work), called work or something, which uses your works SMTP to send. Then you'll be able to choose that account when composing new messages (at work) and it will use the correct SMTP every time... ;)

Now... to get Mail to chose the right account based on where it is... that would be nice... :cool:
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.