Mail keeps asking for a new gmail app specific password

Discussion in 'OS X Mavericks (10.9)' started by whitedragon101, Mar 2, 2014.

  1. whitedragon101 macrumors 6502a

    Joined:
    Sep 11, 2008
    #1
    I have a gmail account that uses 2 step verification and has an app specific password and IMAP is enabled. I check it using Apple mail. This was working fine until a few months ago when Mail started asking for a password. I generate one (app specific) paste it in and it works. Then a few minutes later it asks for a password again.

    Any ideas how to fix this? I'm not sure if the fault is gmail or mail.

    (incidentally my iphone 4 IOS7 has an app specific password for the same account and it is still working fine)
     
  2. adamneer macrumors 6502

    Joined:
    Apr 18, 2013
    Location:
    Chicago, IL
    #2
    did you deactivate the previous app specific key after assigning a new one? this happens to me occasionally, but not nearly as often as you describe. id say maybe once a year. i recently had to reassign an app specific password for mail and after doing so, i deleted the one that was previously generated, and haven't had an issue since. one thing you might try is to deactivate the gmail account in mail and then set it up as new. i know its not ideal, but its difficult to assign blame to either Apple or Google for this sort of problem and its a lot less hassle than constantly regenerating passwords and having to relearn Googles latest "interface optimization" in order to find the security preferences.
     
  3. whitedragon101 thread starter macrumors 6502a

    Joined:
    Sep 11, 2008
    #3
    Thanks for the response.

    Yes I have been deleting/deactivating the previous password before generating a new one.

    I will try your suggestion of deleting the gmail account from mail and setting it up from scratch (in mail).
     
  4. whitedragon101 thread starter macrumors 6502a

    Joined:
    Sep 11, 2008
    #4
    Thanks for the help.

    Completely deleting the mail account and setting it up through the central "Internet Accounts" interface worked :) . Its been a couple of days and it hasn't asked for a new password.
     
  5. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #5
    I had the same problem with my Gmail and aol accounts under Apple Mail 10.9 and 10.91. Somehow 10.92 fixed it. It's been two weeks or so and not a single request for PW. Before 10.92 it basically happened all day...
     
  6. oldhifi macrumors 6502a

    oldhifi

    Joined:
    Jan 12, 2013
    Location:
    USA
  7. DramaLLama macrumors 6502

    Joined:
    Feb 6, 2011
    #7
    Alright I searched and found this thread. I'm having the same issue.. any resolution? I see someone talking about 'app specific' passwords... I've looked everywhere and can't find this in my Google Accounts settings. The only thing I see is that my iPhone is allowed access to the account but no settings to create an "app specific password" or anything.
     
  8. amie17 macrumors newbie

    Joined:
    Jan 4, 2009
    #8
    I've come across this. Need to remember to update the password in these three places below if using 2-step.

    Apple system preferences >> Internet Accounts >> Update password for the gmail account in here with the app specific one you have been given for you mail

    Mail >> Preferences >> Select google account >> Outgoing mail server - click drop down menu and select "Edit SMPT Server List" >> update password with the app specific password.

    Mail >> Preferences >> Select Google account >> Enter password

    did the trick for me. :)
     
  9. agentx macrumors member

    Joined:
    Jul 20, 2009
    #9
    As a side note i often delete references to email passwords from Keychain access manually, then add new password form within Mail Accounts setup. It has a habit of not playing ball.
     

Share This Page