Mail Keeps Asking for my Yahoo password?

Discussion in 'Mac Apps and Mac App Store' started by RadDave, Apr 7, 2013.

  1. RadDave macrumors regular

    RadDave

    Joined:
    Apr 6, 2013
    Location:
    North Carolina
    #1
    Hello all - new to this forum - I've had my new rMBP for nearly 2 weeks - Mail was setup to my Yahoo account and has been working fine until today; the Mail icon in the dock keeps bouncing and a dialog box appears asking for my password (which is already highlighted) - I have confirmed the password and have also retyped it in - opened my email account via Yahoo on the browser and easily got in w/ the same password. Found a few threads in this forum which seem to indicate that this can occur - the main recommendation has been to delete the account and then setup a new one.

    Not sure if the problem may be @ Yahoo, i.e. rejecting the PW request or a problem w/ Mail, or both? I'll keep a watch over the next day or so, but any comments would be appreciated. Thanks. :)
     
  2. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #2
    As mine started doing the same thing yesterday (and was not doing it at all before then), I suspect a Yahoo issue not a Mail issue. Just too coincidental that we are both having the exact same problem, with the same service and starting at the same time. Also, when I put in the password, emails get retrieved normally. Sometimes it will choke at the next automatic email check, sometimes it will go for a couple hours not having a problem (email checks about every 10 minutes). It's got to be on Yahoo's end.
     
  3. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #3
    Gmail will do this now and then. If it persists, I usually just remove the mailbox and re-add it. I think it is Yahoo (or in my case Gmail) and not Mail.
     
  4. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #4
    I'm glad you posted. I was thinking of moving to Gmail to avoid Yahoo issues.
     
  5. RadDave thread starter macrumors regular

    RadDave

    Joined:
    Apr 6, 2013
    Location:
    North Carolina
    #5
    Thanks for all of your responses & reassurance - :)

    I suspected Yahoo was the problem - this morning at least, the notifications for mail are arriving as before - Dave
     
  6. Lightning Bolt macrumors member

    Joined:
    Feb 15, 2013
    Location:
    Windy City Suburb
    #6
    Yep, me too. I've only had this Macbook Pro for a little over a week. I was thinking it was some setting in mail that got messed up.

    I guess I'l ignore it for now.
     
  7. mic j macrumors 68030

    Joined:
    Mar 15, 2012
  8. bringel macrumors newbie

    bringel

    Joined:
    Oct 10, 2011
    #8
    Problem With Yahoo Mail

    I too started having the same email issue around the same time frame. One symptom that convinces me the problem lies with Yahoo is that my iPad is doing the same as my MBP. My wife's mail account (on both machines) continues to work.
    After much fiddling with mail settings, it started working intermittently and still is intermittent.
    I am getting to the point where I am ready to ditch AT&T including their lousy Yahoo mail service. The only other broadband provider we have in this remote area is Charter though.
     
  9. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #9
    It's interesting, I have 2 email accounts with Yahoo Mail. One is POP and the other IMAP. Only the IMAP account was continually asking for my password. :confused:
     
  10. Tulani macrumors 6502a

    Tulani

    Joined:
    Dec 6, 2012
  11. James Craner macrumors 68000

    James Craner

    Joined:
    Sep 13, 2002
    Location:
    Bristol, UK
    #11
    The problem with Yahoo is it does not like multiple devices communicating with the mail database at the same time, it is partly a security measure if it detects multiple devices trying access the same account at once, and will reject your password. So if you have your Yahoo Account on multiple devices (iPhone / iPad / Mac) then you may trip the security from time to time.
     
  12. trigonometry macrumors 6502

    trigonometry

    Joined:
    Jun 19, 2010
    Location:
    South Carolina
    #12
    Me too! I'm ready to delete my Yahoo account from Mail and just use the web interface. Really, I don't which is more annoying.
     
  13. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #13
    I have the issue maybe once every 6 months. It never causes me much headache.
     
  14. RadDave thread starter macrumors regular

    RadDave

    Joined:
    Apr 6, 2013
    Location:
    North Carolina
    #14
    Well, nearly 2 months since my OP - Mail on the MBP seemed to be acting well most of the time until today - just could not get that bouncing icon to stop except by setting the mail check to manual & quitting the program - will check later.

    What is most curious is that I have an iPad w/ the same mail setup (of course, the OS is different); I've had absolutely no problem on that device - OS X vs. iOS? Don't know, but I still suspect Yahoo is the issue. :)
     
  15. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #15
    I ended up moving to Gmail. Mine Yahoo/Mail combo started acting up again and I just could not find a solution. Since moving to Gmail, everything has been great. I have kept the Yahoo mail account that was the source of the problem. I just keep it off-line. Once a day I take it online and it works fine (no password request). I agree with you, I think the source of the problem is with Yahoo. I keep the Yahoo account to have an email address I use for online purchases, website account initiation, etc. The garbage stuff. New system has been working great.
     
  16. ramz67 macrumors newbie

    Joined:
    Jul 4, 2013
    Location:
    Georgia
    #16
    Apple Mail rejecting Yahoo PW

    I have been having this same problem for eons. I've removed and re-added my Yahoo account so many times I've lost count. I've tried multiple ports and THEN I found out I had to have Yahoo! Plus, so I signed up and made my new connections and everything seemed to be fine.....for about an hour!! What I've discovered is that I have to go into my Account Info page on Yahoo!, which requires an authentication sign in and then go back to Apple Mail and fetch or send my email. Every time the Yahoo! Account info page automatically logs me out, I get logged out of Apple Mail.....why is that!!! There's obviously a problem on Yahoo's end. I've deactivated my Mobile account, just to see if I have too many devices trying to access Yahoo at the same time, we'll see if that works, but that's not a permanent fix because I need mail on my phone. I consistently had the same problem with Outlook Mail, which is why I transfered over to Apple Mail in the first place.....now it seems that that was all for naught!! Ugh. I'm running a Mac desktop as well as an iPhone 5 and iPad 2...not problems on my mobile devices, just the Mac.
     
  17. Windowsrefugee macrumors regular

    Joined:
    Mar 14, 2011
    Location:
    Microsoft Land
    #17
    It was good to see this thread. I have been having a similar problem just with my iOS devices for the past week. My MBA and Blackberry get my Yahoo! Business account email perfectly and reliably, BUT I get those same #%~|%>#! error messages on my iPad and iPhone for hours at a time almost every day. As another poster stated, Yahoo! Has told me in the past that the problem relates to multiple devices accessing the same email account. But why now after it worked fine for over a year?

    Hmmm, doesn't Yahoo! know that multiple devices use is the new normal in the 21st Century? Since this is my business account, this level of dysfunction is just unacceptable. Are there other ISPs that I can use my domain name that are affordable and work more reliably?:mad:
     
  18. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #18
    I've switched away from Yahoo mail several years ago... although my wife still uses one as her "junk" email account. She uses that one for stores and places... and does not have it linked to her Mail.app program.

    I still use some google mail... but I have my domain name registered and hosted by godaddy.com. I've had that for about a decade with no problems so far.

    /Jim
     
  19. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #19
    You got garbage info from Yahoo. I have had this issue since last January and have never been able to solve it...and I only have 1 device, my MBP. It's some sort of automatic authentication communication problem, because since I have taken my Yahoo account "off-line" in Mail and just bring it on-line once a day to download all the accumulated spam, it works fine. Connects without a problem every time. I now just use my Yahoo mail as the mail account I use with websites/purchases that require an email address. Since moving to Gmail, Mac Mail works just fine.

    Yahoo should just hang it up and turn off the lights. They're pretty much irrelevant at this point anyway.
     
  20. jazzer15 macrumors 6502

    Joined:
    Oct 8, 2010
    #20
    After using Yahoo Mail for ages this issue just started for me a couple of weeks ago ... and it doesn't happen all the time, but often enough to drive me crazy. I have about had it with Yahoo. Is there a service to have all of my mails sent to another address so I can start to try to get rid of them already?
     
  21. v2club macrumors regular

    Joined:
    Apr 13, 2011
    #21
    It’s not only Yahoo, I have Hotmail account (@live.com one) and I have the same problem every now and then. It starts bouncing and asks for the password, sometimes every 5 minutes, sometimes just once is enough to keep it for a month or 2.
     
  22. c-Row macrumors 65816

    c-Row

    Joined:
    Jan 10, 2006
    Location:
    Germany
    #22
    My mail account started a similar behaviour some years ago which apparently was caused by my provider only allowing one remote login every 15 minutes unless you paid for premium service. I got around that restriction by switching from POP3 to IMAP, so if your provider offers that option (I don't have a Yahoo account myself, but I am sure they do) you could try and set up your account as IMAP in Mail.
     
  23. rbrian macrumors 6502a

    rbrian

    Joined:
    Jul 24, 2011
    Location:
    Aberdeen, Scotland
    #23
    My ISP used to use Yahoo for their free, own-branded mail service. They got so many complaints that they're now dumping Yahoo.
     
  24. palmharbor macrumors 6502

    Joined:
    Jul 31, 2007
    #24
    Yahoo worth just what you pay...zero

    I have been having the password problem for months now. I tried to offer a new password so I used the same password that it is rejecting. Its a 17 character password...17! It would not accept it...saying it was too weak?
    Email is basic to all computers, no wonder the stock is doing so poorly.
    You could not buy a decent dinner for the price of one share of this company who still does not get the basics right...YET
     
  25. Bilalo macrumors 6502

    Joined:
    Aug 17, 2012
    Location:
    Oxford, England
    #25
    I have gmail, yahoo and hotmail. Guess what, hotmail is the only perfect one :p get that :) make sure its @hotmail.com
     

Share This Page