Mail keeps popping up in the background

eyeangle

macrumors regular
Original poster
Jan 2, 2014
149
19
Melbourne, Australia
This has been going on far too long but I can't remember when it started. One answer online said to uncheck in Preferences "Prefer opening messages in split view when in full screen" but that didn't help the issue. It pops up maybe once ever half-hour.

Any suggestions to make it stop popping up?
 

allan.nyholm

macrumors 6502a
Nov 22, 2007
965
253
Aalborg, Denmark
Absolutely the same issue with Mojave. 10.14.5

Really annoying - Mail also decided to pop up during a screen recording yesterday to top it all. I don't know what's wrong.
 

allan.nyholm

macrumors 6502a
Nov 22, 2007
965
253
Aalborg, Denmark
It's not that Mail unhides on any new e-mail received. It's that Mail lives its own life and decides to peek in on a fullscreen video from YouTube from any browser as a Split View. Also just decides to a shout out to the user that "I am still here" like it did for me while screenrecording something unrelated to the Mail app. I have since deleted the Gmail account I set up to see if it's the culprit.
 

eyeangle

macrumors regular
Original poster
Jan 2, 2014
149
19
Melbourne, Australia
It's not that Mail unhides on any new e-mail received. It's that Mail lives its own life and decides to peek in on a fullscreen video from YouTube from any browser as a Split View. Also just decides to a shout out to the user that "I am still here" like it did for me while screenrecording something unrelated to the Mail app. I have since deleted the Gmail account I set up to see if it's the culprit.
Cool, keep us posted.
 

Analog Kid

macrumors 601
Mar 4, 2003
4,777
2,797
Got hit with this this morning— hadn’t noticed it before. No idea what triggered it.
 

the Nocturnal Scribe

macrumors newbie
Mar 17, 2019
1
0
This has been going on far too long but I can't remember when it started. One answer online said to uncheck in Preferences "Prefer opening messages in split view when in full screen" but that didn't help the issue. It pops up maybe once ever half-hour.

Any suggestions to make it stop popping up?
[doublepost=1561021668][/doublepost]Just chiming in - Same problem here surfaced over the last few weeks, mail jumps in split view without warning seemingly randomly. Running OS 10.14.5
 

rhett7660

macrumors G5
Jan 9, 2008
12,229
2,249
Sunny, Southern California
It's not that Mail unhides on any new e-mail received. It's that Mail lives its own life and decides to peek in on a fullscreen video from YouTube from any browser as a Split View. Also just decides to a shout out to the user that "I am still here" like it did for me while screenrecording something unrelated to the Mail app. I have since deleted the Gmail account I set up to see if it's the culprit.
Oh... That is strange. I wonder if it has something to do with Mail either looking for new mail or syncing with the mailbox or mailboxes every "X" minutes/seconds.
 

allan.nyholm

macrumors 6502a
Nov 22, 2007
965
253
Aalborg, Denmark
@rhett7660 I think you might be right about the checking Google's mailbox for new mail. I've been using a deactivated Google acocunt inside Mail for the past 10 or so days since my post and your post on the issue. Not once has Mail app interferred with my fullscreen videos nor has Mail suddenly popped open to greet me in the middle of doing whatever. I appreciate leading me in the right direction. The times of me signing "Hello Mail, my only friend. You come here to see me again." is over - as it seems. I hope.
 

Steve_C

macrumors newbie
Jul 21, 2019
3
0
I am having the same issue and it's become really annoying. Mail is in the background and when I'm working in another application, Mail pops up in front of my other active app windows for no apparent reason. No new mail, no notifications, etc. It just pops up in front of my current app window. I've never encountered this problem before and realize it only started occurring after I added a Gmail account to my Mail app, so I'm guessing it has something to do with the Gmail account. But it's only a guess. I have no idea why this started happening.
 

allan.nyholm

macrumors 6502a
Nov 22, 2007
965
253
Aalborg, Denmark
I am having the same issue and it's become really annoying. Mail is in the background and when I'm working in another application, Mail pops up in front of my other active app windows for no apparent reason. No new mail, no notifications, etc. It just pops up in front of my current app window. I've never encountered this problem before and realize it only started occurring after I added a Gmail account to my Mail app, so I'm guessing it has something to do with the Gmail account. But it's only a guess. I have no idea why this started happening.
It's because you added a Gmail account to Mail. Since this is in your reasoning I just thought that I should share what I have experienced since adding and then removing my Gmail account in Mail; Mail is quiet as in behaving without showing up time and time again.
 
Last edited:

Steve_C

macrumors newbie
Jul 21, 2019
3
0
It's because you added a Gmail account to Mail.
Thanks, Allan. I guess I'll have to live with it or delete the Gmail account from Mail and access that particular Gmail account via a browser, which is not what I prefer to do since I never have a browser open on my desktop unless I need access to a website.
 

allan.nyholm

macrumors 6502a
Nov 22, 2007
965
253
Aalborg, Denmark
Thanks, Allan. I guess I'll have to live with it or delete the Gmail account from Mail and access that particular Gmail account via a browser, which is not what I prefer to do since I never have a browser open on my desktop unless I need access to a website.
I did read a suggestion in a related thread(or perhaps it was this one); add an e-mail account outside of the regular Gmail account from within System Preferences/Internet Accounts. Instead of choosing the Google portion of the selections available - try adding it as a single e-mail account.
 

Steve_C

macrumors newbie
Jul 21, 2019
3
0
I did read a suggestion in a related thread(or perhaps it was this one); add an e-mail account outside of the regular Gmail account from within System Preferences/Internet Accounts. Instead of choosing the Google portion of the selections available - try adding it as a single e-mail account.
Thanks for the suggestion, Allan. I will look into it and see if that will fix it. Thanks!
 

star-affinity

macrumors 65816
Nov 14, 2007
1,036
386
So this is happening in Apple's Mail.app too? I thought it was only a thing with Microsoft Outlook.
 

chikorita157

macrumors newbie
Mar 8, 2019
27
35
Caldwell, NJ, USA
I have the same issue and of course, this even happens in High Sierra. I ended up dumping Mail.app for Outlook 2016 for Mac. I plan on dumping GMail/GApps in the future since it doesn’t really play nice with Mail.app and I’m not keen in having Google have control of everything and privacy concerns. After removing the accounts, Mail.app didn’t randomly pop up. In short, it may be just a GMail issue. Still, I’m surprised that Apple still haven’t found a solution to this yet.
 

metalsquid

macrumors member
Jul 2, 2008
37
9
This issue drove me nuts as well. No one had a good solution when I google'd for one but I DID find a suggestion that works! Instead of closing the window with the red button just click the yellow one to minimise it to the dock. For some reason this makes Mail happy and it stays out of the way like it should. No more popping up unsolicited or forcing split-view when you're in fullscreen. Compared to complex, hacky solutions involving the command line I found this to be the simple workaround I was looking for until Apple fixes this.
 

allan.nyholm

macrumors 6502a
Nov 22, 2007
965
253
Aalborg, Denmark
This issue drove me nuts as well. No one had a good solution when I google'd for one but I DID find a suggestion that works! Instead of closing the window with the red button just click the yellow one to minimise it to the dock. For some reason this makes Mail happy and it stays out of the way like it should. No more popping up unsolicited or forcing split-view when you're in fullscreen. Compared to complex, hacky solutions involving the command line I found this to be the simple workaround I was looking for until Apple fixes this.
Great tip! CMD+H that hides Mail doesn't keep Mail.app happy so this is one to try when it's that time again.. The most straightforward solutions often wins. I don't have much connection to Gmail - but it sure is nice to have a direct line to the Google Mail account within Mail.app.
 

28Gauge

macrumors 6502
Sep 4, 2011
479
71
DFW
I have been having this problem as well. My new 2019 iMac (2 weeks old) has been plagued by this phenomena. However, with the old 2011 iMac running High Sierra, I never had this happen. At first, I thought that I was causing this problem somehow, but it appears that there is a bug somewhere in the mix.