Mail Never Responding

Discussion in 'Mac Apps and Mac App Store' started by n-abounds, Apr 9, 2007.

  1. n-abounds macrumors 6502a

    n-abounds

    Joined:
    Mar 6, 2006
    #1
    My Apple Mail program loads, but then stalls. Finder then says the application is not responding, and Mail shows one new message in my inbox (not that I can get into it).

    Any ideas what I should do to fix it? Will the OS discs allow me to repair just "Mail"?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Have you recently been sent an attachment that may be corrupt? If you have webmail access, try deleting some of the attachments that you've received since this started.

    If that doesn't help, then find a file named com.apple.mail.plist in your Preferences folder and drag it to the Desktop. Can Mail open now? :)
     
  3. breathofwater macrumors newbie

    Joined:
    Jul 4, 2007
    #3
    Hi I am a new mac user and have learned a lot of the ins and outs pretty quickly I would say. I have had a few questions but usually found answers online very quick and overcome any hurdles so far. This is the one exception! I have the same problem as was listed in this topic. As soon as I load mail **EVERY TIME!** it opens and half a second later the endless beachball appears beings. I have to force quit because my mail never loads and the program is "not responding". I've read various threads on similar issues but mine unlike other people's is only with the mail application no others. I've repaired permissions, moved that preference file to my desktop deleted all mail from my gmail account that could have been inflicting this. PLEASE HELP!!! I really want to start using this application again :( :(

    If it matters I'm running a macbook which i got in late june so it should be the latest that I know of.
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Are you running any theme changers or system hacks? Try creating a new user account in System Preferences and check if the problem happens in that version of Mail. If the new version of Mail opens properly then the problem is within your original account's Home folder? :)
     
  5. n-abounds thread starter macrumors 6502a

    n-abounds

    Joined:
    Mar 6, 2006
    #5
    Ah yea well I'll post the fix that helped me if this thread is resurrected again:

    Find you Mail program in your applications folder. Click it once, and go to "File" in the menu bar, and click "Get Info". In the window that pops up, make sure "Open using Rosetta" is NOT checked.

    Nice work actually taking the time to search for old threads, breathofwater. And on your first post, no less!
     
  6. breathofwater macrumors newbie

    Joined:
    Jul 4, 2007
    #6
    Fixed it

    Hey guys thanks for the replies. I managed to fix the problem after some tinkering around and desperate attempts. I expect that the problem might have had something to do with the fact my account was linked with Gmail but I really have no idea what went wrong. What I did was find the preference file named at the beginning of this thread. After moving it to the desktop and having nothing happen I had the ballsy Idea of deleting it. Somehow this worked and my account was back to normal minus the Gmail account I had linked to.
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7
    Unless Mail was still running when you removed it, you shouldn't have had to delete it. It is quite likely that Mail or a Mail-related process was still running though, if the thing wasn't responding. Congratulations on getting it fixed mate. :)
     

Share This Page