Mail not auto checking

Discussion in 'iPhone' started by skeen, Nov 25, 2007.

  1. skeen macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    London, England
    #1
    I have Mail to auto check every 15 mins, but it's not doing it at all. Anyone know what's up with this? I have 4 IMAP accounts.
     
  2. matthewHUB macrumors 6502

    Joined:
    Nov 29, 2005
    #2
    I have 3 accounts.

    The same thing is happening to me. Just woke up - no emails. Set to check every 15 mins. Went into Mail, clicked get mail, and i had 6. Why didn't these come through?

    these people have the same problems it seems:

    http://discussions.apple.com/thread.jspa?messageID=5930875
     
  3. TurboSC macrumors 65816

    TurboSC

    Joined:
    Aug 4, 2007
    Location:
    California
    #3
    yea it used to be fine with mine as well, get e-mails throughout the night...

    But it seems only when you're using your iPhone does it start checking... or sometimes when you go into the mail app.
     
  4. skeen thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    London, England
    #4
    Yeh, I guess it's the case it only checks when you're using the iPhone - which doesn't make much sense to me at all.
     
  5. BuxtonUK macrumors member

    Joined:
    Oct 15, 2007
    #5
    Not true at all, I've had mine on sleep and it notifies me of new mail when it does it's 15 minute check if there's mail there.

    Even over night when when it hasn't been touched for hours on end.
     
  6. cyberbolt macrumors member

    Joined:
    Nov 10, 2007
    #6
    Mine doesn't check for mail either :(

    A lot of people have said it doesn't happen when it's on WiFi/not on WiFi/on EDGE, etc, but mine just doesn't do it period. I am just using a .Mac account.

    When I tried Yahoo! push IMAP it worked perfectly. Now if only Y! had IMAP for Mail.app, then we'd be sorted.
     
  7. plumbingandtech macrumors 68000

    Joined:
    Jun 20, 2007
    #7
    Turn off and on your phone.

    It is a bug. Since 1.1.1 I believe.
     
  8. skeen thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    London, England
    #8
    This seems to have worked (for now, but I've turned my phone off before..), however it is now not alerting me properly to new mail; no sound, no vibrate, and I have both of these set.

    Hmm..
     
  9. e²Studios macrumors 68020

    e²Studios

    Joined:
    Apr 12, 2005
    #9
    Or just press and hold the home button while in mail to make the mail app restart (when you return to the main menu you can let go of the button). Much shorter then power cycling and just as effective of a solution when mail fails to autocheck.
     
  10. matthewHUB macrumors 6502

    Joined:
    Nov 29, 2005
    #10
    This needs serious attention. I mean, firmware builds are supposed to get stronger, more secure, and better. Not introduce bugs that weren't there before.

    If an SDK is going to introduce more and more bugs like this... it can go to hell. I choose functionality and reliability over a friggin voice recorder.
     
  11. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #11
    Sadly, the reality of life is often different in my experience. You just have to hope that any new bug is not as much of a problem as the one it replaces.

    I have 4 email accounts (2 IMAP and 2 POP) and all seem to function flawlessly, at the moment.
     
  12. matthewHUB macrumors 6502

    Joined:
    Nov 29, 2005
    #12
    that's weird. how come there are many of us using 1.1.2 and having problems and you're not??
     
  13. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #13
    It is strange, but I'm sure I can't be the only one.
     
  14. Ninja Dom macrumors 6502

    Ninja Dom

    Joined:
    Feb 12, 2007
    #14
    I've noticed Mail stops auto checking and a reboot fixed it.

    This tends to start happening after the iPhone has been on solidly for a few days, maybe a couple of weeks.
     
  15. tonywob, Nov 27, 2007
    Last edited: Nov 6, 2011
  16. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #16
    The default setting for this is off to avoid the heavy cost of data roaming. This setting has no effect on mail collection unless you are abroad.
     
  17. tonywob, Nov 27, 2007
    Last edited: Nov 6, 2011
  18. plumbingandtech macrumors 68000

    Joined:
    Jun 20, 2007
    #18
    Thank you!
     
  19. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #19
    Do you mean switched on as opposed to being in sleep mode? Nothing is going to get your mail if it's switched off.

    I may be wrong because this appears to be a little ambiguous, but to me this reads that to enable email etc whilst abroad turn roaming on. Do you have a link to the original script?

    I always have the setting switched off yet my email collection works flawlessly.
     
  20. tonywob, Nov 27, 2007
    Last edited: Nov 6, 2011
  21. Shoesy macrumors 6502a

    Shoesy

    Joined:
    Jun 21, 2007
    Location:
    Colchester, UK.
    #21
    Sounds expensive to me.
     
  22. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #22
    Sorry I misunderstood, but you did say:

     
  23. tonywob, Nov 27, 2007
    Last edited: Nov 6, 2011
  24. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #24
    No problem. However this is a curious and intriguing situation because several people seem to have difficulties with email collection. We need to keep an eye on it.
     

Share This Page