mail not pushing fetching on the 4s?

Discussion in 'iOS 5 and earlier' started by starstreak, Oct 16, 2011.

  1. starstreak macrumors 6502

    Joined:
    Dec 5, 2004
    #1
    I had did a restore from my 4 (4.3.3) to my 4s (5.0) when I got it. I have a @me.com,@gmail.com,@something.com accounts. The me and gmail accounts are push (they were set before on my iphone 4), the something.com doesn't get mail. I have it there so I can SEND mail from that account.

    If I send an email to all 3 accounts, I won't get mail untill I open the mail icon. Then I get all my mail.
    I tried shutting off my phone and starting it back up. I sent email to all 3 accounts, then I got push mail within 10-20 seconds.
    But I noticed now a few hours later, I havn't seen any mail. I go into mail and now all my mail comes in. The Push and Fetch(every 30mins) doesn't work.
     
  2. starstreak thread starter macrumors 6502

    Joined:
    Dec 5, 2004
    #2
    Hmm seems to be only the me.com that is not pushing to the phone unless I launch the mail program...
    I tried sending an email to my gmail and it came in under 30seconds. But it's been over 5mins and still no email notification from my me.com. I don't want to open mail yet, just in case its taking its time.
     
  3. starstreak thread starter macrumors 6502

    Joined:
    Dec 5, 2004
    #3
    Ok, getting closer...

    If I have the mail app running in background, then my emails will come in. If I closed the mail app, then mail from me.com (push) will not come in.

    Can someone verify this?
     
  4. 78-bit macrumors newbie

    Joined:
    Sep 29, 2011
    #4
    Same behavior here.
     
  5. JamesM macrumors regular

    Joined:
    Jan 27, 2007
    #5
    Same here, iCloud not pushing but my exchange account is.
     
  6. Bethany Smith macrumors member

    Bethany Smith

    Joined:
    Oct 11, 2011
    #6
    Same here on my iPhones and iPad. When the Mail app is closed, no pushes. When it's open and running in the App Tray, they are pushed.

    Surely they are aware of it by now and hopefully are working on a solution/update.
     
  7. benmrii macrumors 65816

    benmrii

    Joined:
    Nov 14, 2007
    Location:
    NC
    #7
    I'm having the same issue, but I'm fairly certain it isn't iCloud but the iPhone. My iPad is receiving the push, as is my computer. Only my iPhone - app open and running in the background or not - is not receiving it. If I figure out what's up I'll post here.
     
  8. dfeigenbaum1 macrumors member

    Joined:
    Jan 27, 2010
    #8
    push for gmail

    just got off the phone with senior advisor, about gmail not pushing, said that it it does not do that anymore, he is wrong, if mail app is in tray it does push, thanks to prior post that if mail app is in tray it will push and it did!!;):
     
  9. sparkstsa macrumors regular

    Joined:
    Mar 12, 2010
    #9
  10. starstreak thread starter macrumors 6502

    Joined:
    Dec 5, 2004
    #10
    I have three accounts, but only me.com and gmail.com can push. Both are set to push already. The 3rd account doesn't actually get emails. I have it inputed just so I can send email using that one account. So setting everything to push like you did, I already did that. Still only get mail as long as I keep the mail app running. Once I close it, no more mail pushing to me.com Only my gmail.com gets mail.
     
  11. Rob.S macrumors newbie

    Joined:
    Jun 5, 2009
    Location:
    Poconos, Pennsylvania
    #11
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    My Yahoo mail push stops working on its own; can't figure out why. A reset of the phone gets it working, albeit only temporarily. I have 5 email accounts configured - iCloud, Yahoo, Ymail, Gmail, & my ISP)... Yahoo (default) & iCloud are set to push and the others are set to fetch manually. I removed and re-added them on two separate occasions... that's a pain, and also only a temporary fix. I configured my 4S as a new phone, btw, so as to avoid any confusion should problems arise...
     
  12. nwmtnbiker macrumors 68000

    nwmtnbiker

    Joined:
    Apr 5, 2011
    Location:
    Fidalgo Island
    #12
    My 4s is the same. Set up as new, added yahoo account, cloud account and the mail pushes for awhile then stops. I can't figure it out. It also does it when iCloud isn't installed. Maybe a yahoo problem?
     
  13. Rob.S macrumors newbie

    Joined:
    Jun 5, 2009
    Location:
    Poconos, Pennsylvania
    #13
    I think this also happened when I upgraded my 3GS to iOS 4, although it didn't cease to work as consistently as this does. That one eventually straightened itself out although I don't know how or why, and became totally reliable after awhile. I hope the same happens for the 4S, or that the issue gets identified and fixed!
     

Share This Page