Mail not remembering account passwords?

Discussion in 'macOS' started by mashinhead, Oct 26, 2008.

  1. mashinhead macrumors 68020

    Joined:
    Oct 7, 2003
    #1
    I just got a new macbook, and I migrated my mail settings using Mobile me, but the problem is mail doesn't remember any of my passwords. Everytime i open Mail it asks me for the passwords of all of the accounts, except mobile me. I will literally go into the account settings, enter it save and go down the next entry and the previous password will be gone. If i save to keychain it doesn't work either.
     
  2. Lurchdubious macrumors 65816

    Lurchdubious

    Joined:
    Oct 15, 2008
    Location:
    Texas
    #2
    I don't have this exact problem, but I do find that on at least one of my accounts Mail seems to "forget" the password about every other day, sometimes every 3 days. It's seriously annoying. In my case, since it's only one account, I'm thinking it's just a problem with that account.

    I'd love to hear if there's any way to fix this.
     
  3. eluk macrumors 6502a

    eluk

    Joined:
    Dec 14, 2006
    Location:
    East London, UK
    #3
    If it is like mine, it's not forgetting the password but merely not checking for it.

    If you click cancel when asked for a password, providing you've previously putting it in, yo can then go to the mailbox and 'check for new mail'. It may well check without asking for a password.
     
  4. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #4
    I think this often happens with secure emails where you are previously logged into your account elsewhere and it won't let you access it.

    It happens with my med school email where I want to access my schedule first then try to check my email and it can't or vice-versa.
     
  5. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #5
    I'm not positive, but this sounds familiar. I think I may have fixed this or a similar problem by creating a new mail config manually and deleting the old one.
     
  6. mashinhead thread starter macrumors 68020

    Joined:
    Oct 7, 2003
    #6
    yea i did that too with just one of the accounts because they are all imap and same thing.

    this is also happening with ichat, and is obviously some sort of keychain issue.
     

Share This Page