mail not sending Japanese text properly

Discussion in 'Mac Apps and Mac App Store' started by mrklaw, Feb 12, 2008.

  1. mrklaw macrumors 65816

    Joined:
    Jan 29, 2008
    #1
    hi

    Moved to an imac late last year, and my wife is having problems sending emails in Japanese. Some of her friends receive them fine, others receive garbage. I remember we had problems in XP with this as well, but eventually solved it by preselecting the text format to use.

    is there any way to do this in mail? I think you can go to mail properties and change the text manually but she won't want to do that for every mail. It'd be simpler to change it globally if possible.

    Also, what format do you recommend? I think on the PC we settled on JIS.



    oh, and we also have a problem where - if my wife has previously selected Japanese input method, then switched back to British English, it sometimes doesn't stick, and when you launch Safari its back to Japanese. Any ideas on that one?
     
  2. GavinT macrumors member

    #2
    Are you using the computer with a single user account... or do you have seperate user accounts? ]
    On my machine, I have my log in (which defaults to British English, with Japanese (then Welsh!) as my secondary languages).
    My wife has a different user account, which defaults to Japanese, with British English has the secondary language option.
    Now, as far as I know, she's never had any problems getting Mail to work with other people. It just worked. (Which OS X version are you using... we started with Tiger, now on Leopard).
    I presume... Mail is defaulting to using Unicode with my wife. It could also be an issue with your mail provider???? (Wife uses Yahoo Japan for her POP account).

    Regarding selected input option not sticking... I think the 'selected' keyboard can be application specific rather than system wide (I think Windows IME does the same thing as well actually).
     
  3. mrklaw thread starter macrumors 65816

    Joined:
    Jan 29, 2008
    #3
    mail provider should be fine, we've been ok with it on our old PC.

    trawling around a bit, it seems that OSX 'intelligently' adjusts the outgoing message format based on the language order. As it is a single log-in, thats English first, then Japanese, so it uses UTF-8. It should be ISO-2202-JP (or something like that)

    there appears to be a terminal fix that forces mail to use ISO-2202-JP which I'll try later.


    I was considering multiple accounts but didn't bother in the end. if the missus just wants to check email it seems a faff to switch around. How do you organise it?
     
  4. GavinT macrumors member

    #4
    ISO-2202-JP is the older JIS standard, which should be readable everywhere, which is why it's used for mail. It shouldn't affect you, UNLESS you also happen to need to send emails that use other language sets (like Arabic for example).

    Regarding multiple accounts. I find it just easier to have it setup up that way, even though it uses more space on the disk. She can set up the computer her way with desktop pics, safari shortcuts etc etc. If the missues needs to check email, I just log off, because in the end, I'm usually the one hogging the machine. Of course, I could always just get another Mac!
     
  5. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #5
    This is an excellent, regularly-updated resource for Mac users who need to be able to use Japanese as well:

    http://redcocoon.org/cab/mysoft.html

    I send equal amounts of Japanese and English e-mail and very, very occasionally get complaints of garbled (mojibake) text, usually from recipients using cellphones.

    I have Kotoeri Japanese input enabled of course and usually switch back and forth from English to Japanese using the default cmd-2 and cmd-1 keyboard shortcuts. I also check the box in International settings to display the flag for the current input method in the menu bar. This is a helpful reminder in case I've forgotten to switch it back from one mode to the other.
     
  6. Chromako macrumors member

    Joined:
    Apr 8, 2007
    Location:
    The Wired
    #6
    As best as I recall, OS X remembers the settings for each application, so that's why it can sometimes act weird. I'm not sure how to change it. sorry.

    And regarding sending Japanese text, I have never had a problem unless I sent it to people who couldn't read the text to begin with because they didn't have the language packs installed, and then it became garbled. But I assume you already knew that. erm... now that I think of it, my response was completely pointless. sorry.
     

Share This Page