Mail not sending, Possible AppleSpell issues?

Discussion in 'Mac Apps and Mac App Store' started by clevervaughn, Jan 14, 2007.

  1. clevervaughn macrumors newbie

    Jan 12, 2007
    Ok this is an insane situation so I will try and explain it as clearly as possible.

    Situation Problem:

    This problem started out with my mail not allowing me to send an email. Mail is accepting and checking mail, but it will not allow me to type more than 4-5 letters before giving me the "unable to type BONK sound" or then after that sound I re-click on the window and it will not let me send the e-mail.

    After doing some research about this problem I decided to check Ichat

    I then found I was having troubles with Ichat. I found that It would allow me to type one word and then it would proceed to give me an error message and ask me to quit.

    I then decided to check TextEdit to see if it would check my misspelled words. I found that it didn't.

    So I thought we might be having issues with AppleSpell since that is what all the programs have in common

    The attempts to fix:

    So the IT person at my office and I decided to mess with the library on my account and delete it entirely and have it rebuild. That didn't work. We then did a backup of my user account and created a whole new account. My account then worked on my co-workers machine but not my Dual Intel MacBook Pro and my G5 which are all running on 10.4.8. (my co-worker's included). So here is where it gets crazy! I log in as my co-worker on my G5 and his e-mail works fine. I set up my account on his e-mail system and it works fine, I can type and send e-mails. I then log in as me after just making sure that my account is working on my co-workers machine, I find that I can not type or send an e-mail on my new account on my G5 or my MacBook Pro.

    So we have tried to pin it down as a software problem, but we can't pin it on that cause we used my co-workers account on my G5 and the mail on this sytem worked fine. But I log in as me and it doesn't work.

    We then thought it was something with settings in my user account, but my account works fine on my co-workers G5 computer running the exact same OSX which is 10.4.8.

    So we are at our wits end! The IT guy has tried some things that are way over my head in computers and IT and none of the attempts have worked.

    The problem I think originated on my Dual Intel MacBook Pro. It was set up to sync to my User account on our company server. I was logged in as me on both my MacBook and my G5 when I thinked this problem occured

    If you have any idea why the two computers (MacBook Pro and G5) will not allow me to send mail, use IChat, or check spelling in TextEdit please drop a line and I will give it a try. We are stumped! I still have a feeling it has something to do with AppleSpell.
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Weird. To test your theory, have you tried quitting the AppleSpell process in Activity Monitor on one of the accounts/machines that isn't working? :)
  3. clevervaughn thread starter macrumors newbie

    Jan 12, 2007
    Apple Spell Problem

    We looked at the Activity Monitor while Mail was opened and tried to compose a new email to see if we could see a problem and we couldn't even find the application AppleSpell on the list! We even went into Terminal and couldn't see it running...So AppleSpell is not even opening and running. So we have started attacking this problem from a few more angles, but so far no dice.

    Is this a wipe it clean and re-install OS 10.4.8 problem? Seems weired that AppleSpell still won't open on just my user account? Odd! Very Odd! And no matter if I delete the account and start a new one AppleSpell still won't open, for that new user.

    Any ideas of what to attack next to get this AppleSpell going? Sorry for the delay reply, but wanted to thank you for all your suggestions! This is by far the hardest and weirdest problem I have ever encountered on an Apple.
  4. rrr macrumors member

    Jan 17, 2004
    I ran into the EXACT same problem on a client's recently purchased MacBook today.

    So, you are not alone.

    Unfortunately, I wasn't able to pinpoint a specific corrupted file or easy fix.

    However, here is what I did discover, and here's how I fixed the issue for this user:

    It seems that the problem was linked to the specific UID (501) of the user. As root, I created a new account (UID 502) with a new username, and replaced the home directory of the new account (UID 502) with a copy of the home directory from the original account (UID 501). Then I changed the ownership on the new home directory to UID 502, and logged into the Mac under the new (502) account. Sure enough, the problem was gone.

  5. johnsawyercjs macrumors member


    Feb 27, 2007
    A couple other things to try

    A couple other things worth trying:

    - Use a utility like iRepair to change permissions on your user folder, and all items inside it, to Owner: you, read/write/execute, and Group: you, read/write/execute. Then run Keychain Access's "Keychain First Aid" option to fix some keychain file permissions that get messed up when you do this.

    - Run the OS 10.4.8 Combo updater again--this can replace or fix some files that get messed up.

Share This Page