Mail not working after ios4 update on 3gs

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ashVID, Jun 22, 2010.

  1. ashVID macrumors regular

    Jun 30, 2007
    Weird problem. Updated fine but won't refresh email. Have to restart the phone to get new emails to load. Restore does not fix it. I don't do fetch, is that the issue? I just manually check as needed.

  2. Trejodaniel macrumors newbie

    Oct 15, 2007
    Same issue here

    I am having similar issues after 3GS iOS 4 upgrade....... The phone ans SMS work properly, but none of my internet apps works and this includes: Mail, Safari, Facebook, App Store and any internet connected app. They just try to load for hours with no success.

    The only way to fix it, is to do a complete restore (Wipe iPhone), but after a day the same problem comes back......Any ideas?
  3. LAS.mac macrumors 6502

    May 6, 2009
    Is this happening with wifi and/or 3G? Because mine (3G) works with 3G, but does not connect to wifi after upgrading to iOS 4...
  4. Trejodaniel macrumors newbie

    Oct 15, 2007
    So far it happends with 3G and EDGE, haven't checked WIFI
  5. Trejodaniel macrumors newbie

    Oct 15, 2007
    Solved! I have completely fixed this problem without losing any data (not that i've noticed yet anyway).

    First, let me summarize the problem and briefly address the known solutions. There are multiple issues people are having with the update that -HAVE NOTHING TO DO WITH OUR PROBLEM-. Some people had theirs in airplane mode which apparently gives them a "no sim card" after update. not our problem. Some people can reset settings not our problem.

    Our problem is corrupt APN settings after an upgrade, which can be worked around by installing mobileconfig updates or using the "iPhone Configuration Utility" to temporarily overwrite our APN settings. This is a temp fix that only makes 3g work, no MMS or Visual Voicemail.

    We know that completely restoring the phone and setting it up as new resolves the problem. A lot of us are unable to restore any backups without re-introducing the bug. A lot of us do not want to lose our app data so setting up as new phone is out of the question. Some people have figured out how to set up as new phone and import SMS messages from corrupt backup to new backup. This is a good solution if SMS is the only thing you want…However, some of us want ALL our app data.

    Now for the solution! First, go in to settings on your phone and uninstall any custom profile you may have installed to temporarily fix the APN.

    Now, perform a full backup of your phone (you may want to delete your previous backups or move them out of the directory so that you're not confused with multiple backup files in your backup directory.

    Go to your backup directory ~/Library/Application\ Support/MobileSync/Backup/random-backup-name-here/ and delete this file 8218978e4ab0a48035bb92653145a6be872ea858
    That file contains our corrupted APN information.

    Now RESTORE YOUR PHONE and restore the backup. It will fully restore and then give you an error, ignore the error, it worked. Sync your phone to get all your apps back. 3g works, visual voicemail works, mms works, and i have ALL of my app data! all my contacts, all my photos, all my sms messages! BAM! I RULE!
    If for some reason you don't have that file in your backup directory (i have no idea, maybe they are named differently with different backups) you can find it by entering the backup directory in the terminal and running the following
  6. ashVID thread starter macrumors regular

    Jun 30, 2007
    Different issue. Wifi and 3G work for ALL apps but mail is sparse. This morning, I checked my mail, worked fine. Hasn't worked since, says I last checked 5 hours ago even though I have checked many times since. Very odd that it is so sporadic. This is on ALL accounts so it's an iPhone problem.

    ash =o)
  7. ashVID thread starter macrumors regular

    Jun 30, 2007
    Here is another tidbit. I cannot construct a new email either when this is happening but... if I re-start... the phone shows all the emails that were not there before. Clueless here... only option is to restart after every fetch, not very convenient.

    ash =o)
  8. mikejfrd macrumors regular

    Jun 8, 2009
    I'm having the same issue when I'm on wifi. Mail works fine on 3g but can not connect while on wifi. Hope this gets fixed soon.
  9. GeekAhead macrumors member


    Sep 9, 2007
    BK NY


  10. mdntcallr macrumors 65816


    Aug 1, 2000
    i had this problem on my iphone 3gs.

    after installing iOS 4, it had problems connecting to the internet, and my visual voicemail did not work.

    after calling ATT, and wading through their tech support, they brought in Apple tech support.

    This is a KNOWN ISSUE for apple. they just upgraded it to that.

    My solution was to:
    backup my iphone.
    restore it in itunes to factory settings (yes it stays the updated iOS 4) but without anything loaded
    Restore last phone settings, this will reinstall all my app's, music and more. (i am waiting for all of it to reload right now)

    the phone now should work, with internet, visual voicemail and more.

    Crossing my fingers it works.
  11. Mac C macrumors newbie

    Jun 24, 2010
    The frequent problem I am having since moving to iOS4 on my 3GS is email messages not appearing, only "This message has not been downloaded from the server." Then when I hit the "download remainder of message" button, nothing downloads. This is happening to about 50% of my email. Wasn't an issue before iOS4.
  12. Texan78 macrumors member

    Jun 23, 2010
    My 3G is working with both Wi-Fi and 3G service. The only problem I have come across so far is with the email. Sometimes I can not do a manual refresh. Though as of late it seems to be working but that is on Wi-Fi, haven't tested with 3G. The main problem with the mail is I am getting email that has NO content and can not be deleted. The emails that are showing up on my phone and not on my gmail so I am not sure where these are coming from, why it is happening or how I can delete them. Not strange issue with the emails is the dates are sometimes 12/00/69 or 12/31/00 like it is a Y2K bug showing up in 2010...LoL
  13. mammachubba macrumors newbie

    Jun 25, 2010
    Trejodaniel - You Rock, You Rule...You are Awesome

    After spending hours looking for a solution and missing several important calls and texts, I came across your posting. It was very well written and easy to follow. I can't thank you enough -- I had no desire to try to call or go to an Apple store for support on the day of the iPhone4 launch!! You rock -- thank you so much for posting!!
  14. goodday macrumors newbie

    Jun 28, 2010
    Thank you Trejodaniel! Thank you!

    I was thinking exactly the same as you did, but was not sure which file contains the APN settings.

    Looking it up led me to your post and basically gave me the confidence to go ahead.

    You are the first one on all the forums and blogs who came with right description of our problem and simple solution to it too!

    Now I'm back in business.

    Thanks! I can finally go to sleep;) You rock m8!
  15. TehWez macrumors newbie

    Jul 3, 2010
    My MMS still does not work, although visual voicemail and data works. Any suggestions? please, I do not want to lose my texts or contacts, anyway to avoid a restore w/o backup?
  16. dotyzpa macrumors newbie

    Jul 12, 2010
    Thank you Trejodaniel!!

    Didn't notice until about 12 hours after the update that I didn't have a data connectioni (was on wi-fi until then). A tense little time of googling finally turned up your fix.

    Exactly what I needed! I can't tell you how much I appreciate this. BTW, I know this is a Mac forum, but I am running Win7 and the same fix applied. I just needed to find the proper folder to delete the key from.

    You are great! :D

  17. jac- macrumors newbie

    Jul 12, 2010
    Hi! I'm having the same problem, and want to avoid my phone company's solution (restore the phone as a new device and lose everything), but I don't have the problem file identified below in my backup folder, and a full search of my computer (which worked for someone else on the forum) didn't turn it up either.

    Trejodaniel, your post unfortunately got cut off at the end, right where you suggested what to run to find it if it has a different name (your post ends with "run the following" and then there's nothing after). Can you please let us know what you suggested there, in order to find the problem file? Or if anyone else has found it had a different name, can you let me know how you found it?

    thanks! This has been the most ridiculously frustrating problem!

  18. hedonics macrumors newbie

    Aug 12, 2010


    This is great! :D I signed up just to post my thanks! - I just got an iPhone 4, and I'm bummed I can't use 3G or Edge data. Att and Apple were useless at resolving the problem.

    I also wanted to ask about the end of your post, where it ends I get the impression there is one more step to do. What is it? =) Thanks again for paying it forward with some technical expertise!:D

    "you can find it by entering the backup directory in the terminal and running the following" .....:confused:
  19. ehych macrumors newbie

    Jun 9, 2008

    OMG it worked!! thank you very much!!!! you sir have been a real help, hope you find lots of beautiful women coming your way
  20. mboogman macrumors newbie

    Aug 31, 2010
    I don't have a file with that name. What is the following, in "running the following?"
  21. kokoui macrumors member

    Sep 15, 2008
    yep i want to know the alternative solution as well
  22. kokoui macrumors member

    Sep 15, 2008
    Found it

    If for some reason you don't have that file in your backup directory (i have no idea, maybe they are named differently with different backups) you can find it by entering the backup directory in the terminal and running the following

    for i in * ; do echo "checking $i" ; strings $i | grep -i ; done >> output.txt

    open output.txt and search for CommCenter you'll see something like
    checking 8218978e4ab0a48035bb92653145a6be872ea858

    The file above "" is the file you want to delete
  23. kokoui macrumors member

    Sep 15, 2008
  24. LastZion macrumors 6502a

    Apr 13, 2006
    Sorry a little confused on how I open output.txt and search for CommCenter....

Share This Page