Mail not working in 2.0

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iranintoavan, Jul 10, 2008.

  1. iranintoavan macrumors regular

    iranintoavan

    Joined:
    May 3, 2005
    #1
    I have 2.0 on my iPhone and everything works except Mail.

    You open mail, and it shows a blank screen and frezzes and goes back to the home screen. I tried restarting and re-syncing. Also the settings for mail don't do anything. When you select delete account, or turn account on or anything none of the changes stick.

    Anyone else have this happen?
     
  2. ViperX macrumors newbie

    Joined:
    Apr 12, 2007
    #2
    I've been having problems with my e-mail too...

    The phone doesn't seem to want to remember any of my passwords (Voicemail, E-mail, etc) whenever I restart the phone.

    Plus, it won't let me re-enter my passwords for my e-mail accounts, so I keep getting an "Invalid Password" whenever the phone tries to check my mail.
     
  3. RealaT macrumors regular

    Joined:
    Jan 6, 2008
    #3
    I've got the exact same problem as the OP since I upgraded to 2.0

    Hopefully there's a simple fix because I could do with being able to pick up my emails this weekend.
     
  4. baxtr macrumors newbie

    Joined:
    Mar 21, 2008
    #4
    I'm having the exact same problem, does anyone know of a fix. I can't even delete the account and recreate it.
     
  5. CarlmUK macrumors newbie

    Joined:
    Jul 11, 2008
    #5
    I registered just to add a "Me 2" message.

    I finally got it activated arouind 8:30ish and choose to restore my old 2g iphone image to my new 16gb 3g

    Mail doesnt work, open it and it crash's back to the icons.
    3G isnt working ( I have the 3G icon at the top )
    Locate me on google maps isnt working - maybe cus im indoors?

    I've had my o2 txt message. Calling and txt-ing works fine even have all my old text messages which is good.

    Some one must have an idea, all i can think to do is wipe it and start again.
     
  6. ZeromanIR macrumors newbie

    Joined:
    Mar 27, 2008
    #6
    Hey all, had the same problem myself. It seems, in my case anyway, to have been caused by restoring from my backup from my 1st Gen iPhone. Just done a full restore and set up as a NEW iPhone (didn't restore the backup) and it works perfectly.

    Not an ideal solution I agree, just letting you know what worked for me.
     
  7. CarlmUK macrumors newbie

    Joined:
    Jul 11, 2008
    #7
    Thanks ZeromanIR,


    I thought that might sort it. I dont really want to do that as I want my txt messages etc.. on my new phone.

    With out SSH access i cant restore the file manually.

    Guess they need to hurry up and relase the v2 jailbreak.
     
  8. CarlmUK macrumors newbie

    Joined:
    Jul 11, 2008
    #8
    Okay i was brave, I hit restore. It downloaded the 220mb firmware reflashed it then restored my settings back. I can now get into the mail client it just cant connect. least it doesnt crash anymore. Getting there!
     
  9. CarlmUK macrumors newbie

    Joined:
    Jul 11, 2008
    #9
    Fixed.

    Somehow the restore mangles the password. I just retyped the password and i was in.
     
  10. peterhenley macrumors member

    Joined:
    Apr 6, 2008
    #10
    I don't see how to do a mass email delete on V2.0, as promised....anyone know how to? I swipe one email ,then go to the next and it removes the red box from the previous. I thought it would retain the red box.....
     
  11. ZeromanIR macrumors newbie

    Joined:
    Mar 27, 2008
    #11
    Sorry CarlmUK, forgot to mention I had to re-enter the passwords too. Yeah, it sucks losing your SMS history but I felt like I had only half an iPhone without my emails.

    @peterhenley
    You don't swipe for a mass delete. click on Edit at the top and then select as many emails as you want to delete/move by tapping the circle to the left of them and delete/move using the button at the bottom.
     
  12. peterhenley macrumors member

    Joined:
    Apr 6, 2008
    #12
     
  13. hogsdill macrumors member

    Joined:
    Oct 22, 2007
    #13
    Any solution for this? I'm having the same issue. I'd rather not start from scratch.
     
  14. CarlmUK macrumors newbie

    Joined:
    Jul 11, 2008
    #14
    The way I did it, i didnt loose a thing.

    1. make sure you have a backup of the 3g phone
    2. press restore
    3. wait ages it downloads firmware and reflash's the phone
    4. it asks if you want to restore a backup. I choose yes again and selected the 3g backup
    5. wait ages
    6. You can now get into mail, but you password gets mangled so go into options and re-enter it

    I have working mail + all my old sms, call history etc...

    Shame my 3G connection doesn't work, im gonna call 02 about that one.
     
  15. ZeromanIR macrumors newbie

    Joined:
    Mar 27, 2008
    #15
    Thanks CarlmUK, wasn't sure if that'd work myself as I assumed restoring from the backup the first time was what caused the problem, and that backing up and restoring again would simply back up the fault too. Obviously not.

    Ah well, I had nothing I was afraid to lose anyway so I'm not too bothered.
     
  16. CarlmUK macrumors newbie

    Joined:
    Jul 11, 2008
    #16
    Yeh I think the thing that fixed it was the firmware update, the shipped version was slightly older than the one it download to restore the phone.

    I called 02 yesterday morning about my 3G not working. Lady on the phone told me to go into settings and choose reset all. I did and 3G started working :)
     
  17. finalcut macrumors 6502

    Joined:
    Oct 9, 2007
    Location:
    Quebec, Canada
    #17
    I did a restore with my touch and my mail still doesnt work at all. Always crash at startup.
    Anyone in the same situation?
     

Share This Page