Resolved Mail not working, permission problem

Discussion in 'OS X Mountain Lion (10.8)' started by zeibarts, Jul 26, 2012.

  1. zeibarts, Jul 26, 2012
    Last edited: Aug 9, 2012

    zeibarts macrumors newbie

    Jul 25, 2012
    After installing Mountain Lion the Mail app is not working anymore. It gives an error message "Mail can’t open because you don’t have the necessary permissions to change the folder where it saves information. Mail stores information in /mail/Mail. If this folder is on your computer, use the Get Info window in the Finder to change your permissions for this folder to “Read & Write.” If this folder is located on a network server, contact the server administrator. After your permissions are changed, open Mail again."

    I store my e-mails in an encrypted file container (encrypted with TrueCrypt). In order to access the e-mails, I need to mount the file container, and it appears as mounted image in the Finder. I have created alias for the folder ~/Library/Mail/ so it refers to the folder /Volumes/mail/Mail/ on the mounted image.

    I checked the permissions of the mounted image and the folder Mail in that image - both have read and write permissions. I have logged in as admin.

    To check if Mail works at all and if I should rebuild the whole local e-mail storage, I copied the Mail folder outside the encrypted image to ~/Downloads/ and then the Mail app works fine and the e-mail storage also seems to be intact. Then when I put the folder back on the mounted image, the same problem returns.

    I have already tried reparing disk permissions and have verified the hard drive and the image with Disk Utility.

    The weird part is that there were no such problems with Lion yesterday. Any ideas what has changed in Mountain Lion vs. Lion to cause this and what might be the solution?

    If it gives any clarity to the situation, I am running late 2011 13"MBA, 1.7 i5, 4GB RAM, 128GB SSD.

    Thanks in advance!
  2. tommiller macrumors newbie

    Jul 26, 2012
    Same issue

    I have the exact same issue. Worked prior to upgrade and fails now. Tried all the same steps listed by you with no success. New configuration of Mail works but the alias just does not. If you come across a solution, please share it.

  3. camelboy129 macrumors newbie

    Jun 30, 2010
    +1, Same issue

    Post mountain lion update, mail will not launch.
  4. Jeff Chen macrumors member

    Jeff Chen

    Jun 16, 2009
    Try to delete and create the alias (or symlink) again. My friend's steam broke after the installation and this fixed the problem.
  5. zeibarts thread starter macrumors newbie

    Jul 25, 2012
    Deleting alias and creating a new one did not solve the problem.
  6. tommiller macrumors newbie

    Jul 26, 2012
    Has any one come across this problem? I would really appreciate any ideas on how to fix this.



    Yes, symlink does not seem to follow it to the final location as well.
  7. valtertoni macrumors newbie

    Jul 28, 2012
    Same problem, no solution.

    I have the same problem using two hard drives inside my Macbook, an SSD and an HDD where is my Mail folder. I used an alias in my Library, but now with Mountain Lion does not work anymore. Apple support has confirmed that Mountain Lion does not get along with alias. :(
  8. youngtt macrumors newbie

    Jul 28, 2012
    Creating a Symlink in place of Alias solved the problem for me

    I had my mail folder on another drive and created an alias (in Finder) to it in ~/Library as well. Mail app didn't work even after changing the folder permission.

    Fixed it by removing the alias and replaced it with a sym link created in Terminal:
    ln -s /Volumes/Work/Mail/ ~/Library/Mail

    note: substitute 'Work' with the name of your drive & change 'Mail' to your folder name

    Hope this works for you as well.
  9. zeibarts thread starter macrumors newbie

    Jul 25, 2012

    Thanks a lot to youngtt!

    The trick with the symlink worked!
    1. Quit Mail.
    2. Make sure the folders "Mail" and "Mail Downloads" are located in the desired location.
    3. Delete folders "Mail" and "Mail Downloads" and their aliases if there are such from the folder ~/Libary/.
    4. Execute the commands in the Terminal "ln -s /Volumes/Work/Mail/ ~/Library/Mail" and "ln -s /Volumes/Work/Mail\ Downloads/ ~/Library/Mail\ Downloads", assuming "Work" is the name of the volume where you want to store your folders.
    5. Now everything works just as it did before the upgrade.

    P.S. Apparently due to my lack of knowledge on how to operate in the Terminal, I had trouble for a while because I entered "~/Library/Mail/" instead of "~/Library/Mail" - that does not work.
  10. Julienao macrumors newbie


    Aug 12, 2012
    somewhere wandering on this Earth
    another guy lost his Mail :)

    Hi guys,

    I am having the same problem, just updated to Mountain Lion. Same style like 'zeibarts'.
    I use a work.sparsebundle volume that is encrypted and shows up as an external drive when I mount it. When is locked is located in Users/Julien/

    I've tried to give the commands in Terminal but no change. Cant open the Mail app. Actually the folders Mail and Mail Downloads are not appearing in my Work (volume)/Library (folder).

    Here is the message that I get:
    " ln -s /Volumes/Work/ ~/Library/Mail ; exit;
    Julien-Ghitescus-MacBook-Pro:~ Julien$ ln -s /Volumes/Work/ ~/Library/Mail ; exit;
    ln: /Users/Julien/Library/Mail/: File exists
    [Process completed] "
    So, when I check the root: "Users/Julien/Library/Mail" I cant find the Library folder.

    Please illuminate me!
  11. Jonesy135 macrumors member


    Jun 3, 2012
    Bedfordshire, UK
    Hi people im in the same boat... my mail has decided to not work any longer.

    i am, however, new to mac (only did the switch 2 months ago)

    so i am still learning all the terminology

    Can someone please explain this again for me, in the same way you would to a 4 year old :D

    much appreciated if you could
  12. AlienSexGod macrumors member


    Mar 18, 2008
    Terminal app > Finder/ Go menu/Utilities/Terminal
    following instructions above ... copy & paste what they have there but edit in the name of the hard drive you have your mail & mail dl folder (ie substitute the name of your hard drive with the name of their hard drive which is "Work"

    for example the name of my hard drive is HD so mine looks like this:
    ln -s /Volumes/HD/Mail/ ~/Library/Mail

    *** Important omission: Make sure your original mail & mail dl folders are on the FIRST level of your secondary hard drive if they are within a folder this is NOT work

    If you are still having issues & you did all this correctly then you have a different issue to the one iin discussion!
  13. Jonesy135 macrumors member


    Jun 3, 2012
    Bedfordshire, UK
    Thanks for your help, this really helped clear it up for me!!
  14. infinitech macrumors member

    Oct 1, 2012
    Going through this issue now. Would like to host mail on a second HDD installed in a macbook pro with a small 120GB SSD. 2nd HDD is internal and always available and named HDD2.

    Tried the following

    -repairing permissions

    -Creating Alias through finder

    -Creating alias with ln -s command in terminal

    Would appreciate some help if anyone is in the same boat.
  15. AlienSexGod macrumors member


    Mar 18, 2008

    Mate if you read the WHOLE of this thread and comprehend it you will see your first two approaches will never work and the third will work 100% if you following the instructions in this thread including my updated clarifications.
    FYi -s is sudo super user overide unix commands which is beyond what a Mac "Genius" can do.

Share This Page