Mail Not Working

Discussion in 'iOS 7' started by Unprocessed1, Jul 3, 2013.

  1. Unprocessed1 macrumors 65816

    Unprocessed1

    Joined:
    Jun 23, 2008
    #1
    I use gmail, and the mail app doesn't seem to want to fetch new emails, even though I have it set to fetch every 15 minutes.

    Last night, I received no emails through Mail. When I manually checked my mail, I had missed several.

    Anyone having issues with Mail simply not automatically fetching?
     
  2. phr0ze macrumors 6502a

    Joined:
    Jun 14, 2012
    Location:
    Columbia, MD
    #2
    I have exact same issue. Was fine in Beta 1. I wonder if deleting/re-adding the account will help, but I'm too lazy.
     
  3. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #3
    What do you have your fetch settings to? It is manual by default.
     
  4. kevroc macrumors 6502

    Joined:
    Oct 15, 2011
    #4
    Same thing with me. I deleted and re-added my account and it seemed to fix it.
     
  5. ominx macrumors 6502

    Joined:
    Jun 23, 2010
    #5
    Had the same exact issue. I think it's the auto setup when you select Gmail when you add the account. So the way I fixed it is to setup Gmail using the "Other" option in Settings ---> Mail ---> Add Account

    Then use the following:

    Incoming Mail Server:
    Host: imap.gmail.com
    User Name: your gmail.com email address
    Password: Your password

    Outgoing Mail Server
    Host: smtp.gmail.com
    User Name: your gmail.com email address
    Password: Your password

    You can do the same for any non-exchange supported Google Apps account, ie. free ones.

    Remember to double check your fetch and notification center settings as they default to manual and off.
     
  6. typecase macrumors 6502

    typecase

    Joined:
    Feb 2, 2005
    #6
    This happened to me. Cannot get it to fetch new email from the server. Worked and then stopped working in beta 2, same in Beta 3. Is there a quick fix for this?
     
  7. It Is James macrumors member

    Joined:
    Jul 9, 2013
    Location:
    Washington
    #7
    Try these things -


    • Kill mail process and relaunch
      Reboot device
      Disconnect and reconnect to your data network
      Resetup your account
      Check the mail servers to see if they're correct
     
  8. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #8
    Mail is goofy on Beta 3. Even my push exchange e-mails sometimes won't come through until I open the mail app.
     

Share This Page