Mail Notifications, turn some off??

Discussion in 'OS X Mountain Lion (10.8)' started by Jazwire, Jul 19, 2012.

  1. Jazwire macrumors 6502a


    Jun 20, 2009
    I have a few email accounts on my mail program.

    2 for work.
    1 personal.
    1 general personal (The one i "give out" publicly)

    Here is what I am wanting to do, not have the "general personal" pop up notifications. Since 90% of the time its junk, (even if not "junk" standards) mail I don't really need to know about right away.

    I just want to be notified for my 2 work and 1 personal email and not the other.
  2. ps3zocker macrumors regular

    May 3, 2012
    When you go to Settings -> Notifications -> Mail, you can select what email accounts should be in Notification Center and should show notifications.
  3. Jazwire thread starter macrumors 6502a


    Jun 20, 2009
    You mean system preferences >notifications > mail ?

    I don't see anything in there.


    Alert Style

    and 3 check boxes.

    Show in Notification Center
    Badge app icon
    Play Sound when receiving notification
  4. BlueGummiBear macrumors 6502a


    Same here. There isn't anything in there except what you mentioned. I'd like to have more granular control as well.
  5. ixodes macrumors 601


    Jan 11, 2012
    Pacific Coast, USA
    I find the notification system on the desktop incredibly annoying. Therefore mine is OFF. My iPhone sits on my desk when I'm at the computer, the last thing I need is more annoying iOS crap on my MBP.
  6. rorschach macrumors 68020


    Jul 27, 2003
    In Mail:

    1. Go to Mailbox > New Smart Mailbox...

    2. Set a new rule to "Message Is Not In Inbox" and choose the Inbox you DON'T want to receive notifications for. This smart mailbox will include all accounts but the one you've selected. (You could also do the opposite and set multiple "Message Is In Inbox" rules and achieve the same thing.)


    3. In Mail > Preferences, go to the General tab, and set "New message notifications" to to smart mailbox you just created.


Share This Page