Mail Numbers Double

Discussion in 'iPhone Tips, Help and Troubleshooting' started by warburg, Jan 20, 2011.

  1. warburg macrumors 6502

    Joined:
    Jul 27, 2008
    #1
    I have an iphone 4 and only one mail account:yahoo. When I receive Email messages, the number shown on the Mail icon in the dock is always double the number of messages I received. In other words,if I receive one message, the number 2 appears on the icon. If I receive two messages, the number 4 appears, etc. The same thing happens on the "Mailboxes" screen. What is causing this, and how can I correct it :confused:
     
  2. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    If you have your mail account set up as Imap, open your mail settings select your account, select advanced, look at where your account is storing various messages. Usually if you select store on my phone, that will stop the dups. I'm not familar with Yahoo, but Gmail will do that if you set it to store a copy on the server. Since it already has a copy on the server, choosing server instead of phone gets you two copies.
     
  3. warburg thread starter macrumors 6502

    Joined:
    Jul 27, 2008
    #3
    Thank you very much. The Yahoo setup was a little different, but your advice guided me into solving my problem. Under "Accounts," I had two active settings. One was my Email address and the second was simply "Yahoo." I deleted "Yahoo" and now I get the correct number of Emails on my iphone. :p
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas

Share This Page