Mail problem (no window)

Discussion in 'Mac OS X Lion (10.7)' started by waterskier2007, Jun 22, 2011.

  1. waterskier2007 macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    Novi, MI
    #1
    I went to launch mail today (OS 10.7 DP 4) and the window simply does not show up. The menubar for mail shows up, it has my unread count in the dock, but there is no window. I can even pull up the windows for photo browser, fonts, etc. but I cannot see the main window. I have tried going to File>New Viewer Window. I also tried deleting the plist to no avail. Anyone experience anything similar/figure it out? Thanks
     
  2. phpmaven macrumors 68040

    phpmaven

    Joined:
    Jun 12, 2009
    Location:
    San Clemente, CA USA
    #2
    I'm assuming you tried rebooting?
     
  3. waterskier2007 thread starter macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    Novi, MI
    #3
    yeah rebooted, didn't help. kinda sucks because i was looking forward to trying out mail and used it once, so i know it worked then it just stopped working the next time i launched it
     
  4. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    Does Window, Bring All To Front command do anything?
     
  5. waterskier2007 thread starter macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    Novi, MI
    #5
    nope, tried that. also tried click/hold in the dock and going to show all windows, but that just goes into "expose" showing nothing
     
  6. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #6
    Strange. As a test, rename or move the Mail folder in ~/Library to the desktop and start mail, see if it starts normally.
     
  7. waterskier2007 thread starter macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    Novi, MI
    #7
    that worked. thanks so much, what should i do with that mail folder now because it made a new one when it relaunched
     
  8. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #8
    Are your accounts IMAP or POP? IMAP will re-import, POP will just get new mail when it arrives.

    It might have been a corrupt message, I'm not sure. Now that it works, experiment by bringing the "OLD" Mail folder back, open mail and see what happens.
    Maybe try Mailbox , Rebuild command with the Old mail folder.
     

Share This Page