Mail problem - pasting hyperlinks

Discussion in 'Mac Basics and Help' started by Mikawa, Mar 30, 2011.

  1. Mikawa macrumors newbie

    Joined:
    Feb 17, 2008
    Location:
    Melbourne, Australia
    #1
    Hi all,
    I've seen one question on this topic, but it was not answered to my satisfaction.

    I have tried Cmd-C (on the link in Safari) then Cmd-V to paste the link into my mail doc. The text address pastes just fine, but I can't then click on it and check the link. The link isn't there from my end. My recipients seem to get a working link.

    I want to paste weblinks into my emails so I can see and access the links. The only way I can currently find to do this is to Edit>Add link>paste link into "Add Link" dialogue box and click OK.

    This is cumbersome. Why can't I paste links normally, like I can in Word. In Word, you paste the link, add a space and voila! The link is there, underlined and ready-to-go.

    Any useful suggestions?
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    How is you sent mail formatted? Rich Text or Plain Text?
     
  3. Mikawa thread starter macrumors newbie

    Joined:
    Feb 17, 2008
    Location:
    Melbourne, Australia
    #3
    I have the mail preferences set to 'rich text' format.

    I know from my recipients that the URLs are hyperlinks when they receive the message - I just want to know why they are not hyperlinked when I create the message in the first place.
     
  4. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #4
    Not really, but FWIW its the same with Thunderbird, when you are composing a message, links you create aren't clickable in the composing window, but are fine for the recipients. Must be something to do with the way the html editor works in both cases. Once you have sent the message , you can see the link in your copy of that message in the "sent" folder or wherever you put it.
     

Share This Page