Mail Problem with iOS 4?

Discussion in 'iPhone' started by khollister, Jun 23, 2010.

  1. khollister macrumors 6502a

    khollister

    Joined:
    Feb 1, 2003
    Location:
    Orlando, FL
    #1
    Upgraded my 3GS to 4.0 and I have some frustrating Mail behavior.

    First the background facts:
    * single email account with MobileMe
    * do not recall seeing problem on previous firmware versions
    * web based MobileMe mail works fine

    The problem:
    * new message indicator shows on Mail icon in dock
    * audio alert sounds for new mail
    * Inbox folder icon in mail account screen shows new message indicator
    * New message is not visible in Inbox message list
    * New message(s) only visible after I navigate to a different mailbox folder (like Trash) and then back ti the Inbox.
    * and, yes, the indicator shows that the phone is synchronizing with MobileMe the first time I look in the Inbox.


    Anybody else getting this?
     
  2. tkljr macrumors newbie

    Joined:
    Jun 17, 2009
    #2
    I noticed the same thing after upgrading. I went in the settings for MobileMe and toggled the mail off and back on and it's been working properly ever since.
     
  3. khollister thread starter macrumors 6502a

    khollister

    Joined:
    Feb 1, 2003
    Location:
    Orlando, FL
  4. khollister thread starter macrumors 6502a

    khollister

    Joined:
    Feb 1, 2003
    Location:
    Orlando, FL
    #4
    Woohoo! Seems to have worked for me as well. Thanks again
     

Share This Page