Mail Problems..Need Help..

Discussion in 'Mac Apps and Mac App Store' started by RWil85, Sep 2, 2010.

  1. RWil85 macrumors 6502

    Joined:
    Aug 2, 2010
    #1
    I recently installed a new hard drive; thus, I had to restore my system using a backup via Time Machine..

    for whatever reason, upon opening mail the first time - I had to re-enter my credentials as if it were the first time I had ever opened Mail.app.

    That was several days ago and I have been receiving mail on my MBP just fine; however, I just went to send my first email from my MBP this morning and I was asked to enter my password b/c of a "SMTP server error"..

    I entered my MBP password, my email account password, etc. and NOTHING works...seemingly, until this is resolved - I will not be able to send mail, which will be an issue..

    Does anybody have any advice as to what I should do?

    Thanks in advance!
     
  2. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    Mail-->Preferences-->Accounts.

    In the Accounts list select the account that is problematic, and then

    Account Information

    Is Outgoing Mail Server (SMTP) set to the server you want? In that menu, choose Edit SMTP Server List.

    Highlight the one you want and click Advanced. Are the settings here what your mail provider (ISP) requires?

    If all these settings are correct and the problem continues, then maybe the SMTP server password key is broken in your keychain. But try the above first and see what happens.
     
  3. RWil85 thread starter macrumors 6502

    Joined:
    Aug 2, 2010
    #3
    Thank you..But, yes, I had checked that several times and all is correct. I even removed the account and added it again using the proper credential to no avail (which has become an extreme annoyance, because I had over 2000 hotmail emails in my Mail client - and now only 29 messages import over?? Did Hotmail archive messages or something?).

    I'll check my keychain settings now..
     
  4. RWil85 thread starter macrumors 6502

    Joined:
    Aug 2, 2010
    #4
    Thanks!

    I deleted both my incoming and outgoing server entries in Keychain and then started Mail up again.

    I put in my credentials and it went through..I cannot imagine for the life of me why that would've happened..

    anyway, thanks for your time and helpful advice.
     
  5. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #5
    You're welcome.
     
  6. Brinkman macrumors 6502

    Brinkman

    Joined:
    Jul 26, 2010
    #6
    This is my one gripe about Time Machine. Macmail does not backup properly. You must set it up first, then copy down your emails manually.
     
  7. wfturnerm4 macrumors newbie

    Joined:
    Oct 24, 2010
    Location:
    Reno
    #7
    SMTP question

    I hope I'm in the right forum?
    My G4 powerbook recently lost some of its preferences and one was the outgoing mail preference (SMTP for out going mail server).
    I was able to send out e-mails using Mac mail and I had the correct SMTP for Charter cable, here in Nevada, my ISP and it worked for other ISP's.

    Now after the computer fix I don't have this particular SMTP.
    Can some one tell me what it might be.
    Like many others, I need this SMTP to send Mac mail e-mails from other ISP's
    when I'm on the road
    Thanks in advance for your help
     

Share This Page