Mail push notifications?

Discussion in 'iOS 8' started by Southernboyj, Mar 13, 2015.

  1. Southernboyj macrumors 68000

    Southernboyj

    Joined:
    Mar 8, 2012
    Location:
    Mobile, AL
    #1
    I've never really used the iPhones mail app.. I've always used third party apps. I'm wanting to give it a try. I just set up Gmail on it but whenever I receive an email, there's no push notification.. But if I open the app.. The email is there.

    Any help?
     
  2. poorcody macrumors 6502

    poorcody

    Joined:
    Jul 23, 2013
    #2
    Google discontinued offering push notifications for iOS mail a few years ago (unless you get their paid service). You can only receive free Gmail push notifications using their Gmail app now.
     
  3. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #3
    He should still receive a notification when an email arrives, even if it is fetch.

    Check your settings > Notifications > Mail > gmail account
     
  4. Southernboyj thread starter macrumors 68000

    Southernboyj

    Joined:
    Mar 8, 2012
    Location:
    Mobile, AL
    #4
    I have it set to fetch at 15 minutes. No dice. No notifications ever.
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    What actual notifications do you have enabled for the mail app and the account? Do the new emails show up in inbox or another folder in case filtering is used?
     
  6. Badrottie Suspended

    Badrottie

    Joined:
    May 8, 2011
    Location:
    Los Angeles
    #6
    I had same problems but I think Mail app is full of buggy/problems. I wish I could bring Steve Jobs back to alive again he would look into Mail app... He will do something with his lazy employees. :apple:
     
  7. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #7
    I use the mail app for my gmail account (since gmail stopped support active sync) and have it set to fetch every hour. Notifications work prefect. I see it on the lockscreen and as a banner while I'm using my phone. Make sure you have notifications set in settings>notifications.
     

Share This Page