Mail reporting 1 unread message

TyShawn

macrumors 6502
Original poster
Jul 17, 2010
257
7
Does anyone know why and how to fix this annoying bug with iOS 9 that keeps happening to me? Ever so often mail wants to tell me I have 1 unread message but there is one. I verify on the mail server and multiple PCs that there isn't a hidden message somewhere that is causing mail to think there is one but nothing is found.

In the past I am forced to remove the accounts then set them back up again the set folder notifications on the different accounts. Does anyone have a different fix? Also if it happened once it wouldn't be that big a deal 5-6 times is starting to get old.
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,654
9,179
Ventura County
Restart your phone or force quit mail? And as in force quit mail, I don't mean close the app out of multitasking, I mean open mail, hold the lock button for ten seconds till you get the slide to power off, then hold the home button until it takes you back to home screen. This completely purges mail from memory. There-open mail and let it connect to the server again.
 

TyShawn

macrumors 6502
Original poster
Jul 17, 2010
257
7
Restart your phone or force quit mail? And as in force quit mail, I don't mean close the app out of multitasking, I mean open mail, hold the lock button for ten seconds till you get the slide to power off, then hold the home button until it takes you back to home screen. This completely purges mail from memory. There-open mail and let it connect to the server again.
Thanks for that tip I didn't know about the force quit. Sadly neither helped :(
 

Shirasaki

macrumors G4
May 16, 2015
10,267
4,103
This is an old issue bothered me just so long until I buy a new iPhone. :confused:
That doesn't mean buying a new iPhone could solve the problem. :p
I think this is an iOS bug. Even though not a good number of user report this bug, it does exist. Re-adding account doesn't help. Restart iPhone doesn't help. Restore? Don't know.
 

dwfaust

macrumors 604
Jul 3, 2011
6,577
7,415
I see the same thing about once every 2-3 months. It's a PITA, but just closing Mail and re-launching it fixes it up. i first saw it with a beta of Yosemite, which I reported to Apple, but so far, no response.
 

jr866gooner

macrumors 68000
Aug 24, 2013
1,662
433
Happened to a colleague, I helped by removing and re adding the account and all ok now.
 

DJLAXL

macrumors 6502a
Jun 3, 2014
520
396
UT
Spark has been doing that to me since Monday. Driving me nuts. Lol. Always shows 1 unread badge.
 

bluedukies8

macrumors 6502
Jun 30, 2009
267
12
Iowa
I've noticed this with co-workers phones. The two that have had the issues are on Sprint (could just be coincidence).

You don't have to completely remove the account....at least for me I have not had to do that.

Go to Settings -> Mail, Contacts, & Calendars
Select the account with the issue
Turn off Mail
Go back to home screen & open Mail so it shows as removed
Now go back into Settings and turn Mail back on
When you go back into Mail it will update and the "rogue" unread mail message(s) should be gone.

Hope this helps.
 
  • Like
Reactions: TyShawn

Crzyrio

macrumors 65832
Jul 6, 2010
1,500
895
ha! I thought I was the only one with this problem. I assume a reinstall would work but have not had the time to do that.

I've noticed this with co-workers phones. The two that have had the issues are on Sprint (could just be coincidence).

You don't have to completely remove the account....at least for me I have not had to do that.

Go to Settings -> Mail, Contacts, & Calendars
Select the account with the issue
Turn off Mail
Go back to home screen & open Mail so it shows as removed
Now go back into Settings and turn Mail back on
When you go back into Mail it will update and the "rogue" unread mail message(s) should be gone.

Hope this helps.
Thanks!

Turned it off, restarted phone and rogue mail is gone :)
 

TyShawn

macrumors 6502
Original poster
Jul 17, 2010
257
7
I've noticed this with co-workers phones. The two that have had the issues are on Sprint (could just be coincidence).

You don't have to completely remove the account....at least for me I have not had to do that.

Go to Settings -> Mail, Contacts, & Calendars
Select the account with the issue
Turn off Mail
Go back to home screen & open Mail so it shows as removed
Now go back into Settings and turn Mail back on
When you go back into Mail it will update and the "rogue" unread mail message(s) should be gone.

Hope this helps.
That is the easy for for me. Thank you the 1 is now gone and my 1st world problem is gone.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.