Mail "rich" notification - taking up half screen for one message

Discussion in 'iOS 10' started by btownguy, Sep 15, 2016.

  1. btownguy macrumors 6502a

    Jun 18, 2009
    With the upgrade to iOS 10, I really am not liking how the notifications for Mail are working. Each time I get a message the notification takes up half of my screen. I believe previously all that was shown was the sender and the subject. That's all I need. If I turn off "Show Previews", all I get is the sender which isn't helpful as I would also like to see the subject. Any way to change this?
  2. torontoapple macrumors member


    Mar 24, 2015
    I also notice that as well, Kind of gets in the way I agree.
  3. sammy2066 macrumors 6502a

    Oct 3, 2007
    Yep, those rich notifications are a pretty spectacular waste of space - you're not the only one.
  4. whsbuss macrumors 68040


    May 4, 2010
    SE Penna.
    Aren't the notifications supposed to go away when you open its app? I see notifications still there that need to be cleared manually/
  5. immx macrumors member


    Sep 12, 2016
    Has anyone figured out a fix yet? I'm assuming not and we'll have to wait for a sender/subject like we use to have.
  6. stooovie macrumors 6502a

    Nov 21, 2010
    Many notifications stick on screen, it's clearly a bug.
  7. GreyOS, Sep 21, 2016
    Last edited: Sep 21, 2016

    GreyOS macrumors 68030


    Apr 12, 2012
    rich notifications are only visible when you 3d touch on regular notifications, or swipe and view on older devices.

    are you saying rich notifications are large (because yes they are, but that's almost the point of them) or are you saying the regular notifications are also large?

    op, some screenshots would be useful
  8. The Mad Hatter macrumors 6502a

    The Mad Hatter

    Oct 12, 2004
    There are 2 types of notifications...

    Banners: They drop down, then go away.
    Alerts: They drop down and stay. Also, they look like banners now. Not like the windows that used to just pop up in the middle of your screen.

    You might want to check which you have checked for each app.

  9. Ritsuka macrumors 6502a

    Sep 3, 2006
    There is an option to only show one or two lines somewhere in Settings.
  10. GreyOS macrumors 68030


    Apr 12, 2012
    i believe that only applies to the mail app itself
  11. Brownbox88 macrumors newbie


    Sep 21, 2012
    I have it set to show preview in notifications, then to show one line in the mail settings. With that, it then only shows the sender, subject and one line of the email. Nothing else.

    Attached Files:

  12. DomC macrumors 6502


    Jul 28, 2010
    I wish there was a requirement for all developers to offer the option of no notification previews.
  13. immx macrumors member


    Sep 12, 2016
    This is not a perfect fix, but it is better!

    Switch preview on in Settings>Notifications

    Go to Steeings>Mail>Preview and change to 1 Line.

    That will then display the sender, the subject and just the first line of the email.

    As I said, not a fix, but better than all or nothing!
  14. stooovie macrumors 6502a

    Nov 21, 2010
    I know. It's set correctly.

Share This Page