Mail rules creating endless loop of forwards

Discussion in 'OS X Mavericks (10.9)' started by Kevin L., Oct 8, 2014.

  1. Kevin L., Oct 8, 2014
    Last edited: Oct 8, 2014

    Kevin L. macrumors member

    Joined:
    Jan 17, 2008
    #1
    I have custom rules setup to forward all eBay responses to another email account of mine, but lately, the forward gets stuck in an endless loop. I thought it was getting stuck in my mail server, but the messages keep getting additional "FW:" indicators attached to the subject line which makes me think Mail is causing the issue. Problem is I'm having trouble figuring out how to stop it. (Currently, we're talking about thousands of transmitted messages!) Anyone know how to stop Mail from these forwards, especially since it's in the background and doesn't show up in my Sent or Outgoing folder? (I already turned off the rule, but that apparently doesn't stop the ones that are stuck in the queue.)

    SEE UPDATED POST BELOW.
     
  2. Kevin L., Oct 8, 2014
    Last edited: Oct 8, 2014

    Kevin L. thread starter macrumors member

    Joined:
    Jan 17, 2008
    #2
    I tried to delete this thread, but couldn't figure out how, so I'll post my findings here.

    Turns out, my macbook was actually reforwarding the emails. They had only been sent once from the sending computer, but the custom rules I use were somehow transferred to my macbook and engaged without my knowledge. I suspect this may be an iCloud setting (?). It happened to me before and I thought it was a fluke, but the same thing happened today; custom rules on my home computer are mysteriously re-appearing on my macbook and being engaged, so when an email is forwarded with a rule to my macbook's email account, the macbook then reforwards the email to itself, then reforwards that email, and so on.

    I'm trying to figure out why Mail rules are mysteriously doing this. I never had the same rules on both machines, but one day the home computer rules quietly appeared on my macbook. I deleted them, but then again today the same thing happened. Something seems to be syncing rules across my machines with the same Apple ID.
     
  3. snorkelman, Oct 11, 2014
    Last edited: Oct 11, 2014

    snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #3
    if I remember correctly checking "Documents and Data" in Preferences/iCloud results in syncing of mail rules (although it isnt listed as a sub option of iCloud/Documents and Data)

    the trouble is that unchecking iCloud Documents and Data disables syncing of all the sub options of Documents and Data at the same time (Automator, Preview, AppleScript Editor, text Edit and Keynote)

    so if you need any of those to sync via iCloud, you need to check Documents and Data and are then stuck with syncing mail rules

    Only other thing I can think of is to expand your current rule so that it also checks that the subject of the message does not contain FW:
     
  4. Kevin L. thread starter macrumors member

    Joined:
    Jan 17, 2008
    #4
    Yes, I had a running thread in the Apple community as well, and the Documents & Data all-or-nothing was the conclusion as well. Your idea of including the subject line check is genius; thanks! I just wish I had control to turn this off. Am I the only person that wants to use iCloud, but has different email accounts setup on different computers (and thus require different rules)?
     
  5. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #5
    Mail is wrong tool for the job, imo.

    Similar situation, but I handle it via mail provider's settings & tools. Work account #2 has forwarding enabled to work account #1. Work account #1 has filtering rules set on the provider's side. Ditto on personal account. So, my Mail app has zero rules, and should I want to change mail tools on Mac or iOS, my filtering and sorting remains the same no matter tool or if I use host's web interface or iOS apps.
     
  6. snorkelman, Oct 12, 2014
    Last edited: Oct 12, 2014

    snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #6
    yep it's annoying in the extreme. Under Yosemite the Documents and Data option is removed from iCloud settings completely

    I presume its somehow tied to iCloud Drive feature instead in 10.10 (well either that or there's no work around at all in 10.10, and creating multistage rules that check for presence of FW is going to be the only option from then onwards).

    Would be easier if they just provided a tick box in the rule creation dialog to set whether a rule is local or spans multiple devices.

    edit - rather than deleting them on the macbook each time they show up via the cloud rules sync, have you tried just unchecking the ones you don't want to use on the macbook?

    I'm wondering if they're being enabled by default each time they're 'found' again, whereas if they were left in place on the macbooks rules list (but unchecked) they might remain inactive.

    If that did work reliably then the long term approach would be to give new rules names that indicate what machine they're intended for (01_MacPro_ruleX, 02_MacBook_RuleY) so its easier to see which ones should be set active on each machine.

    Ultimately NoBoMacs suggestion might be your best option, though it depends on what your mail rules do e.g. I've a couple that launch applescripts to automate certain tasks that would still require local mail.app rules regardless.
     

Share This Page