Mail saving draft for every message; feature or bug?

Discussion in 'OS X Yosemite (10.10)' started by paulsdenton, Oct 19, 2014.

  1. paulsdenton macrumors 6502

    paulsdenton

    Joined:
    Oct 9, 2010
    Location:
    Barton, Vermont USA
    #1
    Mail in Yosemite is saving a draft of every message I write, without any prompting from me. I can't find a place to turn this off. Is it a new feature or a bug?
     
  2. dam006 macrumors newbie

    Joined:
    Jul 18, 2010
    Location:
    Chicago, IL
    #2
    Are you using iCloud, gmail, yahoo or exchange? That might help as each service works different.
     
  3. Pyrone89 macrumors member

    Joined:
    Oct 18, 2014
    #3
    Has always been there and frankly highly annoying. Especially as it does not delete the concept after you send, making you to manually delete the concepts over and over again (I say over and over because the concepts seem to ignore the delete command: after a few minutes they pop back up and it often takes multiple delete attempts to get rid of them).
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    i've seen this with a co-worker, using gmail. check the variables on the web; go to gmail, check settings. SOMETHING can be changed there (don't remember what it was).

    try googling the issue as well...
     
  5. coldwaves macrumors regular

    Joined:
    May 30, 2011
    #5
    I have a university email set up as POP and I do not have this problem. Mail will save a draft if I write an email but do not send the email out. But if the email got sent out, Mail does not save a draft. Maybe your situation is different if you use different type of Mail setup. But setting the mailbox as POP does not have this problem in my experience.
     
  6. Beavix macrumors 6502a

    Beavix

    Joined:
    Dec 1, 2010
    Location:
    Romania
    #6
    Just disable the "save drafts on server" option for each email account you're using and it'll fix your problem.
     
  7. paulsdenton thread starter macrumors 6502

    paulsdenton

    Joined:
    Oct 9, 2010
    Location:
    Barton, Vermont USA
    #7
    Sounds like the answer, but...

    I can't find this option-where is it?

    ----------

    I am using iCloud; can't find an option to disable this action.
     
  8. Beavix macrumors 6502a

    Beavix

    Joined:
    Dec 1, 2010
    Location:
    Romania
    #8
    Mail Preferences > Accounts > click on any account > Mailbox Behaviors > uncheck "Store draft messages on server"
     

Share This Page