Mail Search STILL not working!?!

Discussion in 'macOS' started by futureswitcher, Jun 10, 2009.

  1. futureswitcher macrumors member

    futureswitcher

    Joined:
    Jan 12, 2008
    #1
    I just started using Apple mail to read my gmail accounts, and I'm pretty happy with it other than the fact that the search "entire message" function simply does not work!

    I googled this and I came up with a ton of year+ old unresolved threads on a bunch of different websites - and none of them seemed to have a real solution.

    Is anyone still having this problem? I'm assuming that a fix has been found because I haven't found any newer threads on the subject.

    I have the latest version of both OS X 10.5 and Mail
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Several things to try:

    1. The Mail.app speedup trick, here - just to rule out a corrupted Mail database.
    2. Check your Spotlight exclusions - is Mail's folder in your user library, or any subfolders therein, on the exclude list?
    3. Are you searching in the right place? This has tripped me up many times - Mail.app won't find stuff if you don't choose the right search parameters.
     
  3. Ice-Cube macrumors 6502a

    Ice-Cube

    Joined:
    Jul 27, 2006
    Location:
    Somewhere over the rainbow
    #3
    Try rebuilding your spotlight index:

    Go to System Preferences and select Spotlight and then Privacy. Add your hard drive (Drag the Macintosh HD Icon from the desktop in there) and quit the preferences. Wait 3-6 mins. Now go back in and delete the hard drive (from the Privacy list). Spotlight will recreate its index and "missing" items will sometimes then show up.
     
  4. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #4
    Save local copies "On My [Your] Mac." Spotlight will definitely find them then.
     
  5. futureswitcher thread starter macrumors member

    futureswitcher

    Joined:
    Jan 12, 2008
    #5
    Thanks everyone for your replies!

    I rebuilt my mail database and then rebuilt my spotlight database...and It worked!

    Thanks! I'm not sure which helped, but it wasn't because I had the privacy settings incorrect - I kept those the same.

    There must have been some file corruption or something somewhere along the lines.
     
  6. mfearon macrumors newbie

    Joined:
    Sep 24, 2008
    #6
    Fixed mail search problem with OnyX permission repair

    Recently I got mac mail and spotlight working when moving to a new mac.
    Downloaded Eudora Mailbox Cleaner 4.9
    I didn't realize at first that it migrated to eudora to mac mail, not eudora!
    It also moved eudora nicknames to address book!

    But searching "Entire Meaage" didn't work- cuz spotlight was dead.
    tried several fixes- like using terminal -- command to rebuild the index
    sudo mdutil -E -i on /
    always gave "no index" as error

    Loaded OnyX- tried several things to fix-
    what finally did it was an OnyX fix permissions command AND reboot!
    (why fixing permissions from disk utility didn't do it I can't say).
    At boot the mds & mdworker processes started indexing and
    have run for hours-
    and searching "All Mailboxes" and "Entire Message" now works(!)
     

Share This Page