Mail: Send button greyed out

Discussion in 'Mac Apps and Mac App Store' started by velocityg4, Sep 17, 2009.

  1. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #1
    For some blasted reason the send button on Mail keeps getting greyed out. I try resetting from time machine backups. It will work for a few messages then become greyed out again.

    When I used the Connection Doctor everything checks out as fine. My SMTP information is correct. As it has always worked in the past, works in Outlook, works in Entourage and cross checks as correct by multiple online sources and the ISP's customer service.

    I have also repaired permissions.

    Why would this button ever be designed to grey out in the first place? An error message after clicking would be better then a button that give no information at all.

    Unfortunately this is a customers computer so I can't just swing by to check some more. The above listed steps are ones I went through before performing a time machine restore. Which worked for a while then the same problem occurred. Another Time Machine restore fixed it. Now the customer is having the same problem so I am trying to find another solution.
     
  2. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #2
    The send button will gray out when mail detects that the settings to / from the mail server are incorrect or it cannot communicate to the mail server. You may start up mail and "send" out a few messages but they are most likely just getting queued up to be sent. Then when it tries to send them it detects that it cannot communicate to the mail server and prevents you from writing more.

    Check the settings of mail and make sure your settings for the mail server are correct. This happened to me one time and I found that I had accidently changed one of the settings.

    It could also be the mail server, if IT changed or is flaky then you'll be in the same boat.

    Good Luck
     
  3. velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #3
    Actually when sending the customers test messages. I sent them to my email address and they showed up correctly with attachments. They also duplicated to the BCC set up.

    Connection doctor said the outgoing smtp server is OK. The e-mail account also works through MS Outlook using Parallels. Both Mail and Outlook have exactly the same SMTP settings.
    mail.bellsouth.net, port 25, no authentication, no SSL. Which is the only setting that works will with Bellouth. The other AT&T/Yahoo SMTP alternatives using authentication, SSL and port 465 or 567 do not work for him with any email client.

    My customer only uses Mail for sending pictures as Picasa for Mac is not compatible with Entourage.
     
  4. devburke Guest

    Joined:
    Oct 16, 2008
    #4
    Well it’s grayed out when you don’t have anything in the To: field, but I didn’t wanna ask that because I’m sure you’re not that absent-minded.
     
  5. velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #5
    :p No this is with the fields filled in.

    I was thinking of another possibility.
    - The account is setup so that the inbox is through GMail. While the SMTP (outgoing address) is through Bellsouth.

    He only wants Mail to receive GMail not be able to send and Bellsouth to send not receive. As Outlook is used for all receiving and sending except for photos. GMail can not be used for sending so that people do not accidentally reply and send non picture emails to GMail.

    However, this was never a problem when it was possible to use the other smtp servers.
    smtp.att.yahoo.com, SSL, Authentication, Port 465
    smtp.mail.yahoo.com, SSL, Authentication, Port 465

    Those servers stopped working for his outgoing in Mail, Outlook, and Entourage. The ports are not blocked by the Firewall and the router has been reset so there are no problems there.

    Even when they were not working the Send button was still available. It would just through up an error message to try another SMTP server.

    I have been reading though that during the AT&T and Yahoo email merger that their system has been experiencing a lot of problems for existing AT&T customers.

    If anyone is wondering fmailhost.isp.att.com has never worked.
     
  6. zonairish macrumors newbie

    Joined:
    Sep 17, 2009
    #6
    Apple mail send function

    This has to be a bug. I only have this grey out issue when I hit reply or reply all to an email. The send function buttons appear on a newly created email or a forwarded email
     
  7. velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #7
    I found the solution for this. It was caused by a design flaw in Yahoo's email system.

    My customers email address is aliased. So when someone receives and email the From address will say like joe@jblow.com. Though it is sent through say joe@bellsouth.net.

    However, Yahoo SMTP server has a lot of problems with this. The SMTP account address must match the From address. Which was never a problem before the AT&T Yahoo mail merger.

    No matter what the incoming, outgoing or from settings are mail.bellsouth.net no longer will work with Apple Mail. Neither with smtp.mail.yahoo.com (at least as far as AT&T email is concerned).

    Only smtp.att.yahoo.com will work with AT&T or it's subsidiaries email, with Mail. The from email address must also match the authenticated address (likely an attempt by yahoo to curb spam with no concern for legitimate businesses).

    So for you Bellsouth, AT&T, PacBell, SBCGlobal or other AT&T subsidiary subscribers whom have done the Yahoo transfer (which I think is required now). The current outgoing settings for Mail are.

    SMTP Server: smtp.att.yahoo.com
    Port: 465
    SSL: Use Secure Sockets Layer
    Authentication: Password
    Username: full email address (must be the same as Mail's account information page)
    Password: email's password

    These settings will likely be good for the next week or so. Until Yahoo/AT&T decide to f*** with everyone's email some more:rolleyes:.
     

Share This Page