Mail sends emails slowly

Discussion in 'Mac Apps and Mac App Store' started by AzureCloud, Oct 27, 2009.

  1. AzureCloud macrumors member

    Joined:
    Jun 20, 2009
    #1
    Hello all,

    I have been suffering from this issue with Mail for a long time, and I have finally decided to attempt to seek out a resolution. I have noticed that since I began using MobileMe, Mail has taken an extraordinarily long time to send emails. It takes at least a minute to send around 5 lines of text, which seems rather excessive. I have noticed this on Leopard (10.5.8) and Snow Leopard (10.6.1). When I send emails from my MobileMe account on my iPhone, it takes seconds, so I haven't noticed any similar issues there. I opened up the connection doctor in Mail and found that it took a long time to report a successful connection to both MobileMe and the MobileMe smtp server. I allowed Snow Leopard to automatically set up my mail account, so I don't believe that it is an issue with settings. Has anyone experienced something similar, and is there a fix I could try?
     
  2. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #2
    First guess: Lower the MTU on your Built-in Ethernet (System Preferences->Network->Built-in Ethernet->Advanced->Ethernet)to 1400 and see if the problem goes away.
     
  3. AzureCloud thread starter macrumors member

    Joined:
    Jun 20, 2009
    #3
    Thanks for the suggestion, Amdahl, but it still hasn't made a difference. I tried sending a test email and it took as long as before...
     
  4. pasipple macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #4
    I just migrated to Mac from a PC three months ago...and I would say I have experienced the same issue. I just thought that maybe "that's the way it was" with Mac and "Mail".

    Just plain text messages (short ones) take 15-20 seconds to send...whereas...with a PC and Outlook they would go instantaneously.

    Don't know if this is the norm or not! I tried the suggestion to lower my MTU to 1400 and I see no difference.
     
  5. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #5
    Put your MTU back to normal, if you changed it and it didn't fix the problem.

    If you go to this address, http://www.whatsmyip.us/reversedns.php do you get a result that indicates your ISP, or just an IP number? If just an IP number, that could be the problem. ISP issue.
     
  6. AzureCloud thread starter macrumors member

    Joined:
    Jun 20, 2009
    #6
    I have found the solution to my problem after a bit of checking on Apple's support site. They mention that the port used for the SMTP server for MobileMe can be 25 or 587. I checked the setting on Mail and it was set to "Use Default Ports" or something similar, which meant it defaulted to using 25. I set it to use 587 as a custom port, and emails send instantaneously now. I suppose it had to do with the ISP blocking or throttling port 25? Anyway, thanks for the help Amdahl, I'm glad to finally have normal mail behavior.
     
  7. southerndoc macrumors 65816

    southerndoc

    Joined:
    May 15, 2006
    Location:
    USA
    #7
    Just changed mine to 587. It's pretty fast now. Thanks!
     

Share This Page