Mail sends from @me.com instead of @icloud.com

Discussion in 'Mac Basics and Help' started by GDL8, Oct 4, 2016.

  1. GDL8 macrumors newbie

    Joined:
    Sep 16, 2016
    Location:
    Los Angeles, CA
    #1
    So on all of my devices, my email sends from @icloud.com, except I noticed that my MacBook Air sends from @me.com. I migrated to iCloud when the switch happened and have never had this issue.

    The Mail settings wont let me change anything, and the dropdown menu when I'm composing a message doesn't have @iCloud.com for me to select. Anybody know what's going on? I'd really rather not have to log out of iCloud on my computer since I use iCloud Drive extensively.
     
  2. dwfaust macrumors 68040

    dwfaust

    Joined:
    Jul 3, 2011
    Location:
    I am here => [•]
    #2
    Delete the @me.com address from your Mac (System Preferences > Internet Accounts)... then re-add it using the @icloud.com account.

    That should do it.
     

Share This Page