"mail sent" sound bug

Discussion in 'iOS 6' started by chenks, Sep 23, 2012.

  1. chenks macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #1
    i've noticed that the issue of the "mail sent" sound playing before the email has actually sent is still present in the GM/final release.

    this "bug" was present in the previous beta and doesn't appear to have been fixed.
     
  2. J.C macrumors 6502

    Joined:
    Nov 12, 2008
  3. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #3
    for me it is a bug
    the sound is playing at the start of the send process rather than at the end.
     
  4. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #4
    They need to sort this out!

    It is ridiculous to have an audible 'email sent' notification before the email has gone. It actually makes the notification meaningless.
     
  5. cbronfman macrumors 6502

    Joined:
    Feb 24, 2008
    Location:
    Washington DC
    #5
    Actually a big issue

    I have one account that has to use the CWMX server for outgoing mail. Last night, I heard the swoosh and assume a reply I had typed was sent. In fact, It wasn't and when I shut the mail app after (to test something else), the email vanished and this was 25 minutes after I hit sent and heard the swoosh.

    There is anywhere between a 20 second and many minutes lag between the swoosh and the time the email is sent.
     
  6. macuser1232 macrumors 6502a

    macuser1232

    Joined:
    Jan 20, 2012
  7. yalag macrumors 65816

    Joined:
    Nov 18, 2007
    #8
    No OSX always sound when actually sent
     
  8. Sammio2 macrumors regular

    Sammio2

    Joined:
    Aug 16, 2008
    Location:
    Basingstoke, UK
    #9
    Yeah, this is annoying... and wrong in my opinion... I've filed a bug report with Apple.
     
  9. i-John macrumors 6502a

    i-John

    Joined:
    Jul 14, 2008
    Location:
    The Republic of Texas
    #10
    It's not a bug if they designed it that way. It's on purpose.
     
  10. macuser1232 macrumors 6502a

    macuser1232

    Joined:
    Jan 20, 2012
    #11
    Not for me. Actually I may have it backwards. The little red "1" shows before the sound.
     
  11. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #12
    you're assuming that it has been designed that way.
    this is a change from how it worked in all previous versions of iOS.
    the swoosh also only plays AFTER the email has sent in all versions of OSX.

    this suggests it's NOT by design and is actually a bug.

    ----------

    that not sent email, that's incoming email
     
  12. macuser1232 macrumors 6502a

    macuser1232

    Joined:
    Jan 20, 2012
    #13
    Yeah. So do you also see the red "1" before you here the noise for incoming mail?
     
  13. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #14
    no idea, i don't sit and watch for incoming mail coming in.
    that's no so much of an issue though as either way you get the incoming email

    outgoing email sound is more of an issue as your phone suggests that the email has been sent, when in fact it hasn't and is still in the process of sending - it might fail sending but because it played the sound you assume that it actually has sent.
     
  14. cbronfman macrumors 6502

    Joined:
    Feb 24, 2008
    Location:
    Washington DC
    #15
    Done

    I just did in addition to my postings to http://www.apple.com/feedback/iphone. Both this issue and the lack of traffic data in the heart of Washington DC are big issues. There are workarounds, but those shouldn't be necessary.
     
  15. NedBookPro macrumors 6502

    Joined:
    Feb 13, 2011
    #16
    Agree,

    It is a bug, because I had mail sitting in the outbox for over a day, despite the sent sound being played.

    As you say, the sound should play when the mail has successfully been accepted by the smtp server - as was the case before.

    APPLE - can you hear us?

    .

    ----------

    I sent bug report on this also. I just hope they act on these things.

    .
     

Share This Page