Mail showing new items count that's not there

Discussion in 'iOS 9' started by vexorg, Oct 22, 2015.

  1. vexorg macrumors 6502a

    Joined:
    Aug 4, 2009
    #1
    I've had this bug before, the mail unread count for the email account inboxes is wrong, stuck at +1 for one of may email accounts. The badge is not showing.

    I've had this before and changed the number of sync period to days or 1 month to fix it. Has;t worked this time on IOS9, nor has a reboot or switch off.

    Still stuck with showing 1 unread email in the account list. It's a live (hotmail) account, and on the web mail it shows the same emails, and none unread.
     
  2. vexorg thread starter macrumors 6502a

    Joined:
    Aug 4, 2009
  3. Peter-Gee macrumors newbie

    Joined:
    Aug 13, 2010
    #3
    I had it happen to me this am. Tried to fiddle with settings, opening/closing app, but nothing worked. I ended up deleting the entire mail account and added it back. Fixed now.... :)
     
  4. gixxerfool macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #4
    I had this with iOS 7 I believe. It took a couple of updates to get resolved. Was not present at all in 8. Now it's back.
     
  5. iphonedude2008 macrumors 65816

    iphonedude2008

    Joined:
    Nov 7, 2009
    Location:
    Irvine, CA
    #5
    Yeah I resolve it by deleting the account and readding it. It's an annoying bug.
     
  6. vexorg thread starter macrumors 6502a

    Joined:
    Aug 4, 2009
    #6
    Have managed a half way fix, I disabled the mail for that account (under mail, calendar, etc), then re enabled it. The count has gone from the top level summary inbox, but still there if I go into the detailed folder view of the account.

    I can live with that as I only look at my inbox on my phone.
     
  7. anjitago macrumors newbie

    Joined:
    Apr 24, 2015
    Location:
    Victor Harbor
    #7
    I found a really simple fix.
    in search box (top right) do a search for "a" then select all the messages (Command A) right click and select "mark all as read"

    If all counts are not gone, repeat the above searching through the alphabet "b", "c" etc.

    Hope this helps
     
  8. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #8
    Where would you be doing this (seems like not in iOS)?
     
  9. anjitago macrumors newbie

    Joined:
    Apr 24, 2015
    Location:
    Victor Harbor
    #9
    sorry just replied to the thread that looked like it was OS X
     
  10. Altis macrumors 68020

    Joined:
    Sep 10, 2013
    #10
    Tap "Edit", select one of your emails, then "Mark" (bottom left), "Mark as Unread".

    Then, Edit, Mark All, Mark as Read.

    Should clear it up.
     

Share This Page