Mail STILL broken for Gmail?

palebluedot

macrumors 6502a
Original poster
Jun 29, 2008
716
77
I have 10.9.1 with all updates installed and for me Mail.app is still broken in many ways with Gmail. The most annoying is the failure for messages deleted in iOS to delete on Mail.app. Moreover, messages read in iOS do not show as read (or moved to a different folder/tag) on OS X.

Is anyone else still experiencing issues with Mail.app? I am so tired of waiting for simple functionality to be fixed. I don't care to hear "it is Google's fault"... only interested in seeing if other folks are still impacted or if it is just me*

*I use Google Apps now, but up until a few weeks ago was using Gmail and was impacted in the same way.
 

Shrink

macrumors G3
Feb 26, 2011
8,931
1,604
New England, USA
I have 10.9.1 with all updates installed and for me Mail.app is still broken in many ways with Gmail. The most annoying is the failure for messages deleted in iOS to delete on Mail.app. Moreover, messages read in iOS do not show as read (or moved to a different folder/tag) on OS X.

Is anyone else still experiencing issues with Mail.app? I am so tired of waiting for simple functionality to be fixed. I don't care to hear "it is Google's fault"... only interested in seeing if other folks are still impacted or if it is just me*

*I use Google Apps now, but up until a few weeks ago was using Gmail and was impacted in the same way.
I haven't experienced the problems you describe in Mail app using gmail. Deletions on Mail are replicated on my iOS devices, and read emails show as read, also.

I wish I could offer some suggestions as to why you are experiencing these problems...but all I can do is say it's not happening to me.

Sorry not to be of more help...
 
Comment

palebluedot

macrumors 6502a
Original poster
Jun 29, 2008
716
77
I haven't experienced the problems you describe in Mail app using gmail. Deletions on Mail are replicated on my iOS devices, and read emails show as read, also.

I wish I could offer some suggestions as to why you are experiencing these problems...but all I can do is say it's not happening to me.

Sorry not to be of more help...
Appreciate the response! Do deletions follow from iOS to Mail.app? When I delete something on Mail.app, it usually is deleted on iOS. But not the other way around.
 
Comment

nparmelee

macrumors 6502
Jan 23, 2008
296
0
First, make sure you have set up the email account as an IMAP account on both systems. If it is set up as POP3 on one, they you could see this.

I have not had the problem you described either. Best suggestion might be to delete and recreate the gmail account on both systems and double check that it's set up as IMAP.
 
Comment

Shrink

macrumors G3
Feb 26, 2011
8,931
1,604
New England, USA
Appreciate the response! Do deletions follow from iOS to Mail.app? When I delete something on Mail.app, it usually is deleted on iOS. But not the other way around.
It's working both ways for me.

If it works one way for you, I can't imagine why you are having problems the other way.

The only thing you might do, which I'm sure you have already done, is to check your mobile device settings, unless it's some glitch with your mail server.
 
Comment

palebluedot

macrumors 6502a
Original poster
Jun 29, 2008
716
77
It is getting worse for me now. When I read and delete (or move) a message on iOS, the message stays unread and unmoved/deleted on OS X. This is causing a huge headache as I get a ton of mail.
 
Comment

Hookemfins

macrumors 6502
Jan 13, 2013
324
21
Florida
It is getting worse for me now. When I read and delete (or move) a message on iOS, the message stays unread and unmoved/deleted on OS X. This is causing a huge headache as I get a ton of mail.

If I delete from iOS 7 or the web it updates almost instantly on OSX. Mark read is the problem.

For deleting go into gmail settings and make sure you have:

When I mark a message in IMAP as deleted:
Auto-Expunge on - Immediately update the server.
 
Comment

palebluedot

macrumors 6502a
Original poster
Jun 29, 2008
716
77
If I delete from iOS 7 or the web it updates almost instantly on OSX. Mark read is the problem.

For deleting go into gmail settings and make sure you have:

When I mark a message in IMAP as deleted:
Auto-Expunge on - Immediately update the server.
Yep, I have auto-expunge on. Still having mark read problems and deletion problems. So strange.
 
Comment

robgendreau

macrumors 68040
Jul 13, 2008
3,337
252
Do you have the "idle" command checked on Mac OS? That basically will allow push to Mail so changes should show up. They do with my Mail and gmail.

Going the other way, however, I have to fetch. Gmail doesn't support push on the iPhone (well, new ones anyway, or unless you have a paid account). So I have to manually refresh.

If even doing it manually doesn't work, you might try another client on either the iPhone or Mac. That could isolate the problem to the server side at gmail; what are your settings there?
 
Comment

Hookemfins

macrumors 6502
Jan 13, 2013
324
21
Florida
Do you have the "idle" command checked on Mac OS? That basically will allow push to Mail so changes should show up. They do with my Mail and gmail........If even doing it manually doesn't work, you might try another client on either the iPhone or Mac. That could isolate the problem to the server side at gmail; what are your settings there?
What is the idle command and where do you find it?

This is 100% Apple Mail problem. I fired up Outlook 2011 and OL marked as read within a few seconds. I also tried on OL 2013 on my windows machine and it also marked as read w/o a hitch.

This all started when I upgraded to Mavericks in the past 3 weeks. There seems to be an inconsistent communication problem between Mail.app and Gmail servers.

Otherwise Mavericks seems to be working well.
 
Comment

nebo1ss

macrumors 68030
Jun 2, 2010
2,765
1,334
Not seeing any similar problems on Gmail between Maverick and IOS. I get messages marked both ways for messages read and messages deleted.

What may or may not be different is that I run Entourage as my mail client on Maverick.
 
Comment

palebluedot

macrumors 6502a
Original poster
Jun 29, 2008
716
77
I have the IDLE command and enabled and all that.

To be clear, here are the issues:
  • When a message is read on iOS, it does not show as read on either my mac laptop or desktop
  • If a message is deleted on any device, it does not update on the laptop or desktop
  • If a message is moved on any device, it does not update and show as moved on the laptop or desktop
  • This is even the case if you press fetch new mail or close and reopen the program on laptop or desktop
 
Comment

twintin

macrumors 6502
Aug 10, 2012
498
50
Sweden
I have the IDLE command and enabled and all that.

To be clear, here are the issues:
  • When a message is read on iOS, it does not show as read on either my mac laptop or desktop
  • If a message is deleted on any device, it does not update on the laptop or desktop
  • If a message is moved on any device, it does not update and show as moved on the laptop or desktop
  • This is even the case if you press fetch new mail or close and reopen the program on laptop or desktop
I only have one gmail account, one MBA and one iOS device and as far as I can tell they sync i.e. reading a mail one one device is marked as read on the other, deleting a message from one of the devices removes the message from the other device. Granted there is a slight delay.
 
Comment

palebluedot

macrumors 6502a
Original poster
Jun 29, 2008
716
77
I only have one gmail account, one MBA and one iOS device and as far as I can tell they sync i.e. reading a mail one one device is marked as read on the other, deleting a message from one of the devices removes the message from the other device. Granted there is a slight delay.
Have you tried deleting from iOS and checking Mavericks Mail?
 
Comment

twintin

macrumors 6502
Aug 10, 2012
498
50
Sweden
Have you tried deleting from iOS and checking Mavericks Mail?
Yes, I tried to delete one message from iOS. At first, nothing happened in Mavericks, so I pressed the get messages button, still nothing. But a couple of seconds later the message disappeared from Mavericks too.
 
Comment

palebluedot

macrumors 6502a
Original poster
Jun 29, 2008
716
77
Yes, I tried to delete one message from iOS. At first, nothing happened in Mavericks, so I pressed the get messages button, still nothing. But a couple of seconds later the message disappeared from Mavericks too.
Strange that yours is working. I have tried it on multiple Macs to no avail. I wonder if it is because I am using Google Apps for Domains (I just switched to that from my personal gmail, although I had the same issue with my personal Gmail).
 
Comment

major77

macrumors newbie
Oct 29, 2003
9
2
The most annoying is the failure for messages deleted in iOS to delete on Mail.app. Moreover, messages read in iOS do not show as read (or moved to a different folder/tag) on OS X.
I had this exact problem until just last week and it was driving me nuts. I think I've finally fixed it though. I can't tell you exactly what did it, but I can tell you the sequence of what I did:

  1. Close Mail.
  2. Go to System Preferences -> Internet Accounts and delete your Gmail account.
  3. Open up your Gmail inbox in Safari, click on the gear icon and select "Settings".
  4. Select the "Labels" tab. Make sure "Show in IMAP" is checked for Sent Mail, All Mail, Spam and Trash. I also have it checked for Starred, but NOT for Important, Chats or Drafts - I'm not sure if these matter, but maybe try setting it up my way first to see if it fixes your issue.
  5. Close Gmail in Safari, open Mail and add your Gmail account. Then go into Mail->Preferences->Accounts->Gmail->Mailbox Behaviours. Make sure "Store sent messages on the server" and "Store junk messages on the server" are both checked, but "Store draft messages on the server" is NOT checked. Note that this doesn't entirely agree with Google's own instructions for setting up Gmail in Mac Mail (which worked perfectly for me in Mountain Lion, but not in Mavericks).

That's all I did, and since then Mail seems to be syncing perfectly.
 
Comment

Hookemfins

macrumors 6502
Jan 13, 2013
324
21
Florida
For anyone having the problem be sure to report it at feedback.apple.com. If it shown to be an issue than it get the engineers working the problem.

I just came back front the genius bar with my Mac Mini. Of course messages got marked read from my iPhone. However I also brought along my MBPr. When I read messages on my MBP it failed to mark read on my Mac Mini. Of course he the genius didn't have an answer but I had him note it on my account since I've been working with a senior tech at AppleCare. She recommended I take it to the Apple Store.

I have another account that I can setup my gmail accounts on and see if I can duplicate the problem.

Marking read seems to be the only issue as deleting works great and instantly.

The suggestion to delete all the accounts doesn't work. I had all mail enabled and marking read still happens.
 
Comment

palebluedot

macrumors 6502a
Original poster
Jun 29, 2008
716
77
For anyone having the problem be sure to report it at feedback.apple.com. If it shown to be an issue than it get the engineers working the problem.

I just came back front the genius bar with my Mac Mini. Of course messages got marked read from my iPhone. However I also brought along my MBPr. When I read messages on my MBP it failed to mark read on my Mac Mini. Of course he the genius didn't have an answer but I had him note it on my account since I've been working with a senior tech at AppleCare. She recommended I take it to the Apple Store.

I have another account that I can setup my gmail accounts on and see if I can duplicate the problem.

Marking read seems to be the only issue as deleting works great and instantly.

The suggestion to delete all the accounts doesn't work. I had all mail enabled and marking read still happens.
It is so strange that this is happening to some of us, but not all of us. Unless other people aren't noticing the issue we are talking about. It's very frustrating that this has been well documented from the release of Mavericks and is still broken. Email is sort of a core competency/essential function of an OS. It used to work fine, then it was broken. I prefer how ML poorly handled email over this alternative.
 
Comment

mikeyb99

macrumors newbie
Jan 10, 2014
10
4
It is so strange that this is happening to some of us, but not all of us. Unless other people aren't noticing the issue we are talking about. It's very frustrating that this has been well documented from the release of Mavericks and is still broken. Email is sort of a core competency/essential function of an OS. It used to work fine, then it was broken. I prefer how ML poorly handled email over this alternative.
I get exactly the problem you've described with the Mail app. There are quite a few threads about this and similar issues around. In the end, nothing worked so I switched to Thunderbird instead which works fine, and I'll try mail again when 10.9.2 comes out.
 
Comment

Similar threads

  • buttongerald
19
Replies
19
Views
3K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.