Mail: Stop checking one account

Discussion in 'Mac Apps and Mac App Store' started by Nermal, Aug 30, 2015.

  1. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #1
    Hi all,

    I have three accounts set up in Mail and one is being overrun with spam (and the built-in spam filter is proving utterly ineffective). I've provided a newer address to the few legitimate senders and I no longer want to check this mailbox for any new messages.

    In Preferences > Accounts > Advanced tab, I've deselected "Include when automatically checking for new messages" but I still get a notification and badge when a new message comes in. What am I missing here?

    I've also tried turning off "Enable this account" in the Account Information tab, but that makes the mailbox disappear entirely; I'd like to still be able to read existing messages but just don't want to receive new ones.

    Help! :)
     
  2. rottnjohn macrumors newbie

    rottnjohn

    Joined:
    May 22, 2011
    Location:
    silly valley
    #2
    Mark the account "offline" (Mailbox -> Online Status -> Take xxx offline)
     
  3. Nermal, Aug 30, 2015
    Last edited: Aug 30, 2015

    Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    Thanks! That appears to work (although I can't say for sure until I actually get another message) but it puts three "zap" icons in the sidebar; is there any way to hide those?
     
  4. Nermal, Sep 1, 2015
    Last edited: Sep 2, 2015

    Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    Well, that worked for a couple of days, but I just opened up Mail and got 20 new spams because Mail had decided to bring the account online again. Argh!

    Edit: Here we are, the following morning, and the account's enabled itself again.
     
  5. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    For what it's worth, I updated to 10.11 yesterday and deselecting "Include when automatically checking for new messages" still does nothing, and the account still brings itself back online without instruction to do so.
     

Share This Page