Mail - Strange Characters in Mail Header and Body

Discussion in 'Mac Apps and Mac App Store' started by macmantha, May 23, 2007.

  1. macmantha macrumors newbie

    Joined:
    May 23, 2007
    #1
    After a doing some system optimization yesterday, today my mail is amuck.

    Mail version 2.1.1
    OS x 10.4.9

    Here are some samples...

    This the Mail Header that should have From, To, Date, Subject, etc..

    [​IMG]

    Here's some body text. All past message, my text only has changed. Did a test send to myslef and checked some new messages and all are affected in the same manner.

    [​IMG]

    Any expert help will be appreciated.

    Best regards,
    Marc
     
  2. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #2
    Exactly what did you do...?

    Did you disable (or install any new) fonts?

    Either way: The first thing I would try is to use Font Book to resolve duplicates and validate fonts and files, and then clear the font cache and restart...
     
  3. macmantha thread starter macrumors newbie

    Joined:
    May 23, 2007
    #3
    I did add fonts yesterday.

    I went to the Font Book,
    Resolved Dups,
    Validated,
    Removed problem fonts and noted by red X.

    Just need to know how to clear the font cache.

    Almost there....

    :)
     
  4. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #4
    If a restart doesn't help, use something like OnyX or MainMenu, and then restart... ;)
     
  5. macmantha thread starter macrumors newbie

    Joined:
    May 23, 2007
    #5
    Restart didn't work.

    I downloaded MainMenu and cleared the Font Cache with a restart.

    I went through the entire process from beginning to end a second time. Still odd characters in Mail.

    I checked fonts in Word and my docs are fine, it's only in my email.

    InDesign shows the Arial font and name in square brackets, and the description bold in square brackets also...substitute?

    If there a way to undo that font installation from yesterday. I'd forgo the extra fonts to be able to reply to my email anytime.

    Which ever we go, I still here willing to try.:)
     
  6. macmantha thread starter macrumors newbie

    Joined:
    May 23, 2007
    #6
    I just notice that the fonts in my browser look just slightly different also, but the text in Mail is really strange and remains as noted in initial post.
     
  7. macmantha thread starter macrumors newbie

    Joined:
    May 23, 2007
    #7
    Update...

    I cleaned up the font book from A to Z. All font issues in other programs so far appear to normal. The internet browser, InDesign files, Word, text layers in PhotoShop are all fine.

    Now it's only the Mail text. It appears to be numbers in lieu of alpha.

    What's next?
     
  8. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
  9. macmantha thread starter macrumors newbie

    Joined:
    May 23, 2007
    #9
    Almost there!:)

    Very close...first, thanks a bunch for the initial tips. That got me started.

    UPDATE....

    The message body in Mail messages text is fine, and displays in Rich or Plain text. All other apps also fine.

    The last issue in the Mail header tittles.

    Here's what is looks like...

    [​IMG]

    Something deeper in Mail app? It just won't correct the headers - From, Subject, Date, To.

    So close...:confused:

    Was there something really specific you wanted to see Wild Cowboy? or does this update change that?

    Best regards,
    Marc
     
  10. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #10
    I still think that one of the new fonts you installed are the culprit. Check out those fonts with names "close" to Arial and Helvetica and see if you can find a Mathematical font there and disable that...
     
  11. Belly-laughs macrumors 6502a

    Belly-laughs

    Joined:
    Jun 8, 2003
    Location:
    you wish
    #11
    I´ve had that exact same issue earlier. It´s a font conflict. Mine was with several auto-activated instances Helvetica. It affected all Apple apps (iCal, Safari, etc.)

    Even though I resolved the conflicts, recipients of my e-mails often complained about strange symbols in my messages. Someone suggested it had to do with the use of Helvetica in my signatures and body text.

    Turning to Geneva/Arial in Mail.app sorted it.
     
  12. macmantha thread starter macrumors newbie

    Joined:
    May 23, 2007
    #12
    Arial and Helvetica have been cleaned out and reduced to one font family, and eliminated a number of other non mainstream fonts and font families.

    The Mail font is Arial.

    Thanks for the the additional pointers and tips.

    UPDATE...

    Fonts in all apps including Mac apps are fine.

    Fonts in Mail message body are fine.

    Fonts in Mail Header are fine EXCEPT for the header tittles FROM, SUBJECT, DATE, TO. (As noted in image below)

    [​IMG]

    The good news is that I sent some test messages to outside recipients. My emails including the Header Tittles look just fine. The header tittles only look bizarre on my computer. So other than a personal visual annoyance, everything works and appears correctly to my email recipients.

    Strange isn't it? Problem in now only the Mail Header Tittles FROM, SUBJECT, DATE, TO on my computer only and nothing else.

    We're so close.:confused: :)

    Whoever nails this one is a genius!
     
  13. Mindplunge macrumors newbie

    Joined:
    Jan 16, 2008
    #13
    You might have solved it already but maybe for future references:

    Delete the font: Helvetica Fraction.
    Library > Fonts

    This should solve the problem
     
  14. tbazani macrumors newbie

    tbazani

    Joined:
    Nov 8, 2006
    #14

    thanks so much!! i had the same problem and i fixed it with this.
     

Share This Page