Mail taking forever to check/send..

Discussion in 'iPhone Tips, Help and Troubleshooting' started by duelingdragons, Jul 22, 2010.

  1. duelingdragons macrumors 65816

    Joined:
    May 13, 2007
    Location:
    Orlando, FL
    #1
    I have five email accounts linked.. 3 Gmail, one MobileMe, and one Live.

    It's taking like 2-3 minutes to send an email (even one with just a few words), and when I open Mail, and hit the refresh button, its taking several minutes for it to go off "Checking for mail".

    Any ideas? I've tried resetting network settings.

    This is an iPhone 4 w/ iOS 4.0
     
  2. watercrawl macrumors newbie

    Joined:
    Jul 1, 2010
    #2
    Mine is doing this too. No idea why, but I'd like to know if it's a problem or what.
     
  3. TimSS macrumors member

    Joined:
    Nov 4, 2009
  4. Apple Corps macrumors 68030

    Joined:
    Apr 26, 2003
    Location:
    California
    #4
    Me too - forgot about that in my other post. Long story made short - iPhone 4 returned and 3Gs re-activated today.
     
  5. ichiban06 macrumors regular

    Joined:
    Jun 20, 2009
  6. duelingdragons thread starter macrumors 65816

    Joined:
    May 13, 2007
    Location:
    Orlando, FL
    #6
    Oh.. well at least I'm not the only one :\

    Weird....
     
  7. watercrawl macrumors newbie

    Joined:
    Jul 1, 2010
    #7
    Yes.
     
  8. jdong macrumors member

    Joined:
    Nov 24, 2008
    #8
    Ugh I wasn't experiencing this before but I am now.
     

Share This Page