Mail taking up 26 Gigs

Discussion in 'Mac Basics and Help' started by Corsig, Sep 29, 2013.

  1. Corsig macrumors member

    Joined:
    Jul 12, 2008
    #1
    Hi there,

    I was advised to download Disk Inventory X to see where all my harddrive space is going.

    I see under "libraries/mail" is a folder called V2 that is really large. Looking at google told me that this should be stored on their servers not my hard drive.

    Can I delete this?

    Thanks
    Cory
     

    Attached Files:

  2. Tavicu macrumors regular

    Tavicu

    Joined:
    Jul 25, 2013
    Location:
    Romania
    #2
    In the mail app settings you have an option to select not to download and store the attachments.

    By default Mail download and store the attachments on the hdd.
     
  3. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #3
    yes in imap google keeps a copy on the cloud, but you can also download the attachments to get faster access to them.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    As others mentioned, Mail app with IMAP will mirror what is on GMail.

    Couple things you can do to minimize this.

    First go to gmail.com and in your setting you can limit the number of messages downloaded to Mail. This is in the IMAP tab.

    [​IMG]

    Now go to the labels tab and UNcheck the All Mail folder where is says "Show in IMAP." This will cut your local Mail app storage space used in half. All Mail in GMail is a duplicate of all the other folder (labels) and there is no need to store those on your Mac.

    [​IMG]

    Also there is a setting in Mail app to not download mail file attachments unless you tell it to.
     
  5. Corsig thread starter macrumors member

    Joined:
    Jul 12, 2008
    #5
    Thank you so much. I recovered another 20 gigs by doing this.

    You guys were really helpful!!

    Cory
     
  6. eleanorb macrumors newbie

    Joined:
    Apr 26, 2015
    #6
    ALL MAIL in IMAP - how to reduce?

    I have unchecked show all mail in the gmail settings, which removed the folder All Mail from my folder list in MacMail, but did not remove those 15,000 message from my hard disk! Do I have to delete those manually? I understand that these are a second copy (the copies in my local subject folders are the main ones) and I don't need them on the local drive.

    ----------

    I am using Mountain Lion, mail v. 6.6.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    How many messages do you have in Gmail? However many you have, that is how many will be stored locally unless you use that limit IMAP folders option I mentioned earlier.
     
  8. eleanorb macrumors newbie

    Joined:
    Apr 26, 2015
    #8
    IMAP storage

    Are you saying that IMAP will continue to download and store the extra copy even though I have unchecked "Show in IMAP" in the gmail Settings/Labels? This seems contrary to a number of recommendations on ways to reduce storage.
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    If you uncheck all mail, it will no longer download the additional copy, but if you have 7,503 gmail messages, it will download all 7,503 to Mail was my point.
     
  10. eleanorb macrumors newbie

    Joined:
    Apr 26, 2015
    #10
    Imap

    I'm sorry, I don't understand what you are saying. You say "it will no longer download the additional copy" and then "it will download all 7,503" — this seems like a contradiction, so I must be missing something.

    <<If you uncheck all mail, it will no longer download the additional copy, but if you have 7,503 gmail messages, it will download all 7,503 to Mail was my point.
     
  11. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #11
    If you have 402 Gmail messages and you leave all mail checked, you will then have 804 message in OS X Mail. If you uncheck all Mail you will have 402, for example.
     
  12. eleanorb, May 9, 2015
    Last edited: May 9, 2015

    eleanorb macrumors newbie

    Joined:
    Apr 26, 2015
    #12
    Imap

    Okay, let me see if I can explain my situation. I have about 15,000 messages in mac mail, from a gmail IMAP account over the years. The messages I care about are stored locally in folders I created and named. But the "extra" copy in All Mail is not needed — I can go to gmail for global searches, etc. So, I unchecked the All Mail "show in IMAP," and now I can't see that folder. But the size of [GMAIL]/AllMail.mbox in V2 is unchanged (96.69 GB). Let's assume that it now will not grow bigger — that is, gmail will stop sending over that additional copy. But apparently it does not delete the accumulated extras. Should I do that myself? Or will that break something?

    Thanks, Eleanor
     
  13. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #13
    Hmmm... that should have gone away on its own. I would not mess around in that folder because you might break things. Try following the steps here to rebuild the Mail folders and see if that gets rid of it.

    I assume you tried restarting Mail?
     
  14. eleanorb macrumors newbie

    Joined:
    Apr 26, 2015
    #14
    Thanks for your suggestion, but the instructions you reference say that Rebuild only works on the selected mailbox (my experience matches this), and since the All Mail mailbox is no longer visible in Mail.app, I cannot select (or rebuild) it.
    Eleanor
     
  15. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #15
    I am talking about the second part of that article where you delete those envelope files. That will force a reindex.
     
  16. eleanorb macrumors newbie

    Joined:
    Apr 26, 2015
    #16
    When I remove the envelope files and restart Mail, I get a big message saying the it is going to import my mail messages — it doesn't say from where! This screen has led to disaster in the past, so I am reluctant to continue.
     

Share This Page