Mail Text and Signature Fonts - Apple Mail

gabe90

macrumors member
Original poster
Oct 15, 2008
31
0
Today, after using a signature in Apple Mail for the past few months, I discovered that my signature is HUGE when read by non Apple Mail users and that the text in my emails is in Times New Roman even though I set it to Helvectia by default.

Turns out this is a problem in Apple Mail, as setting a default font only affects what YOU see, not what the email recipient sees. This seems backwards to me. My emails have apparently been all unorganized for months now. I've sent out job applications thinking I had a sleek format...

Anyways, researching this, I read nearly every post in this google search, but still don't understand how to fix the problem. Apparently there's one "fix" involving stationary, and another fix where you begin typing right at the beginning of the sig...?

Can anyone tell me how to make my emails that I send from Apple Mail show up for my recipients in Helvectia and have the signature be in the same font size and Helvectia as well ? And no, clicking the "always match my default message font" button didn't do this, just in case.

REALLY appreciate the help!
 

miles01110

macrumors Core
Jul 24, 2006
19,264
30
The Ivory Tower (I'm not coming down)
I would suggest not even bothering. While this may seem unhelpful, what people don't seem to accept is that pretty much any formatting with fonts, html, or whatever other superfluous formatting the sender has included in a message can [thankfully] be controlled at the source.

I've sent out job applications thinking I had a sleek format...
You sent out a resume in an e-mail? Ouch. Always use a .doc or .pdf file. If they don't accept it, just send a plaintext e-mail with minimal formatting (no tabs or anything dumb like that).
 

gabe90

macrumors member
Original poster
Oct 15, 2008
31
0
You sent out a resume in an e-mail? Ouch. Always use a .doc or .pdf file.
No no, of course not. Resumes are always attached, but I still send an email containing the attached resume, and I try to make it as well put together as possible. I'm now realizing that Mail decided that mi signature would look good in 18 sized font, and it makes me look unprofessional.

What did you mean by "formatting the sender has included in a message can [thankfully] be controlled at the source"? Sorry, I might be overlooking it, but I don't really get what you mean. If you could reword that it would be helpful.
 

ksmith80209

macrumors 6502a
Aug 15, 2007
801
17
I found that the huge font thing happened whenever I used Rich Text. I switched to plain text and it's not an issue anymore. Not optimal, but there you have it.
 

gabe90

macrumors member
Original poster
Oct 15, 2008
31
0
I found that the huge font thing happened whenever I used Rich Text. I switched to plain text and it's not an issue anymore. Not optimal, but there you have it.
Thanks ksmith. Thing is I have links in my signature that I really can't take out, which is why I don't want to use plain text.
 

miles01110

macrumors Core
Jul 24, 2006
19,264
30
The Ivory Tower (I'm not coming down)
What did you mean by "formatting the sender has included in a message can [thankfully] be controlled at the source"? Sorry, I might be overlooking it, but I don't really get what you mean. If you could reword that it would be helpful.
An example on the more extreme end of the spectrum... my mail client of choice is Pine, which is (for the purpose of this discussion) a command-line mail client. It doesn't have a lot in the way of the bells and whistles one gets in a GUI-oriented client like Mail/Thunderbird/everything else, and displays text. Thus, HTML shows up as the raw HTML (<html><body>...) instead of the rendered "page" that is displayed in a GUI client. If your recipient has Pine for a Mail client or (more likely) is using the option to display all e-mails as plain text, no amount of formatting is going to make it show up how you want...

Thanks ksmith. Thing is I have links in my signature that I really can't take out, which is why I don't want to use plain text.
...thus, you are much better off with a plain text signature, including your hyperlinks. Most mail clients will recognize www.whatever.com as a link and will make it clickable, you start running into formatting issues when you use HTML to form links like this.
 

Viat

macrumors newbie
Jun 23, 2010
2
0
Ok, there no solution to fix annoying 23 font size signature issue in rich text message.. Am i right?)
 

takeoffeh

macrumors newbie
Aug 1, 2010
3
0
I am having this problem too, was recently forced to use MacMail over Entourage and after much reading and experimenting, I cant seem to get my emails to send at a decent size (they are way too big despite preference adjustments).
 

winovermac

macrumors newbie
Aug 16, 2010
1
0
Solution found!

After lot of trial and error with preference settings...I was about to give up on this problem. Just not understand, why Apple doesn't bother provide a WYSIWYG mail client.

Two questions I have for Apple Mail developers:

* Why "display" the font size of signature as same as message text when actually when delivered they are two different sizes? I read quite few hardcore fans arguing that the recipients mail client not correctly displaying the signature

* Why have "Always match my default..." option when it actually doesn't work?

Anyway, enough of bewilderment :confused:

The answer as found by a Microsoft Dev: http://www.sriramkrishnan.com/blog/2009/08/setting-outgoing-font-in-apple-mail.html
 

miles01110

macrumors Core
Jul 24, 2006
19,264
30
The Ivory Tower (I'm not coming down)
Apple doesn't bother provide a WYSIWYG mail client.
Because what you see is not always what the recipient sees. Superfluous formatting often works between people on the same client on the same network (Outlook/Exchange, for example), but not anywhere outside the network. Thus, it is pointless (and somewhat meaningless) to discuss the concept of a true "WYSIWYG" mail client.
 

eugenepark81

macrumors newbie
Aug 17, 2010
1
0
I'm a relatively new Mac user and just discovered this issue as well. It's annoying enough that iCal invites won't work with Outlook, now I'm running into this issue with my signatures. Quite annoyed that I can't find a suitable Outlook replacement...
 

szandbergen

macrumors newbie
Jul 6, 2011
1
0
huge font size in signature

Sorry to bring up an old post from the dead, but I'm experiencing the exact same issue. On my side, the signature looks totally normal, but what the recipient sees is something different.. the font size is bumped up a few sizes. When they respond to me, I can see how crappy it looks. Did anyone find a solution for this?
 

Darcy78

macrumors newbie
Jul 7, 2011
1
0
I have found the solution. Or rather, I have done something that seems to work. This is it:

1. Go to Mail > Preferences
2. Click on Signatures
3. Select the offending signature
4. Highlight the text that is mysteriously enlarged by Mac Mail (ie probably the entire signature)
5. Right-click (bottom-right side of trackpad) and go to Font > Show fonts or select these from the menu bar. (but don't forget to highlight the text)
6. Now set the size to your desired size. Mine was set at 13 but should be 12.
7. When you now open a new mail, NOTHING HAS CHANGED. This is normal.
8. Send a test mail, for instance to your own gmail acccount.

Now the size should have been adjusted. I have found that there is no way to 'apply' or 'confirm' the changes. Just select a new size and close the inspector window. Hope this helps!
 

nanovation

macrumors newbie
Jul 27, 2011
2
0
Problem Fixed in Lion OS

I just upgraded to the Lion OS and I see that they have provided an easy fix to this problem.

1. Go to Mail > Preferences
2. Click on Signatures
3. Select the offending signature
4. Below your signature check the checkbox that says "Always match my default message font"

Problem solved! :)
 

nikkibelshe

macrumors newbie
Aug 22, 2011
1
0
same problem on Lion

Hey guys,

I'm a Mac newbie. I've been researching this issue trying to figure out a fix, and I did try the "always match my defaults message font" thing and it doesn't make a difference. I have Lion as well. When I check my outgoing Gmail messages in a browser the font sizes are still mismatched.

I tried nanovation's suggestion as well as Darcy78's.

Hmmmm.
 

Macsterguy

macrumors 6502a
Jun 5, 2007
700
10
Texas
I just upgraded to the Lion OS and I see that they have provided an easy fix to this problem.

1. Go to Mail > Preferences
2. Click on Signatures
3. Select the offending signature
4. Below your signature check the checkbox that says "Always match my default message font"

Problem solved! :)
Im sorry, but you are wrong... The "Always match my default message font" has ALLWAY'S BEEN THERE and has never helped with this issue...

Also, this issue has been around for EVER and I suggest that EVERYBODY gives up and sends plain text messages.... Take the time that troubleshooting this OLD problem saves you and take the wife on a long weekend getaway...
 

afellowlinguist

macrumors newbie
Mar 10, 2011
29
0
Sorry to necro an old thread, but are there any updates to this? I'm getting the "huge signature" problem as well. It's strange to me because some of my e-mails send out the massive signature, while some of them send out regular sized signatures. Why is there no way to adjust this?
 

vltava

macrumors newbie
Oct 2, 2011
3
0
Hi, don't know if this can help you but there's a plugin (Universal Mailer, http://noware-it.zxq.net) that fixes the problem of outgoing font size. I had a similar problem, my sent emails were rendered with very small font (and always in times new roman), now it seems the problem is solved as I can set a default custom font.
 

mshemy

macrumors newbie
Jun 9, 2009
2
0
Solution

I think i got the solution for this.

just put the signature in your mail then cut it (cmd+x) then from edit - paste and match style that will make the signature with the same font and the email body.

please check and feed me back if it works fine with you.

Regards

Shemy
 

gilbertlau

macrumors newbie
Oct 27, 2011
3
0
i think i solved the problem..here are the steps:

1. create a new signature

2. send out a test email and you should see the problem

3. go to preference, then fonts and colours, under message font, choose a font size that you're not going to use, say 36

4. go back to the signature that you just created, you should see that the font of the signature was automatically changed to 36 too..now select the signature texts, right click and choose font->show fonts, then change the font size to your desired size, say 13

5. send out a test email and the font size of the email content should be 36 while the font size of signature should be 13

6. go to the preference again and change the message font to your desired font size, say 13 as to be the same as signature

7. send out a test email again and now you should see that everything is working perfectly! :)
 

gilbertlau

macrumors newbie
Oct 27, 2011
3
0
i think i solved the problem..here are the steps:

1. create a new signature

2. send out a test email and you should see the problem

3. go to preference, then fonts and colours, under message font, choose a font size that you're not going to use, say 36

4. go back to the signature that you just created, you should see that the font of the signature was automatically changed to 36 too..now select the signature texts, right click and choose font->show fonts, then change the font size to your desired size, say 13

5. send out a test email and the font size of the email content should be 36 while the font size of signature should be 13

6. go to the preference again and change the message font to your desired font size, say 13 as to be the same as signature

7. send out a test email again and now you should see that everything is working perfectly! :)
by the way, do not check the box "always match my default message font"
 

gilbertlau

macrumors newbie
Oct 27, 2011
3
0
however, here comes with another problem...the font type of the email content shown in another email client or on webmail, e.g. gmail always appears as Arial no matter which font type I used. However, the signature is showing exactly what I chose instead of showing arial.
 

christhewiz

macrumors newbie
Jan 8, 2012
1
0
Why isn't Apple reacting to the signaure problem?

This problems exists since years. I don't understand why Apple keeps ignoring this issue. I use my Mac Air for daily business and the oversized email signature (font, size) just looks embarassing.

I'm sick of how some nerds downplay this problem. Find a solution!