Mail "To Do's" + Gmail Imap = Disaster!

Discussion in 'Mac Apps and Mac App Store' started by bobflores, Nov 16, 2007.

  1. bobflores macrumors newbie

    Joined:
    Aug 16, 2007
    Location:
    Boulder, CO
    #1
    After switching to Imap Gmail the day it became available I began using ToDo's in apple mail (by right-clicking on an email)... what a disaster!

    Mail is CONSTANTLY Syncing, giving me the choice to use local or server versions of ToDo's (while I'm still CREATING THEM), and beachballing my mail app at every opportunity.

    I've tried the "tuning" suggested by several sites, by mapping Draft, Sent, Junk and Trash folders to the application, and turned off saving files on the server for Drafts, Sent and Junk.

    Basically, I've tried every combination and permutation of setting up Imap Gmail to no avail.

    Is anyone having any success with Mail ToDo's and Gmail Imap? So far as I can tell, since the app treats the ToDo like a "draft" email, it immediately starts writing it to the server, as soon as you change/add a ToDo, which starts off a cycle of updates that brings the app to its knees.

    I'm starting to think that the only way to solve the problem is to go back to POP Gmail so that the ToDo's are stored locally.


    BTW... I DON"T seem to have the same issue with .Mac ToDo's (which I believe is also IMAP). I've compared all of the settings for the two accounts and can't find anything that would suggest that this would happen. Although I did read somewhere that a Firewall could create this problem. I do have a wireless router and assigned IP's on my side of it. But I'd guess that if that were the issue, then .Mac ToDo's would be affected similarly.

    Any Suggestions out there or has anyone been able to get this to work?
     
  2. neonfox macrumors newbie

    Joined:
    Jan 24, 2007
    Location:
    Cambridge, MA
    #2
    mate i have been having the same problem...

    i don't think that there's any workaround until apple or gmail sort this out. i think we need to submit this bug to the both of them.
     
  3. Aggamemnon macrumors member

    Aggamemnon

    Joined:
    Nov 24, 2005
    Location:
    Bath
    #3
    Still having the same problem when I tried it.
     
  4. thestaton macrumors 6502

    Joined:
    Jan 19, 2006
    #4
    same here. I gave up and changed over to thunderbird for the time being, and it's a nice little program.

    I'm not sure if it can do the to do's though.
     
  5. aaronmclay macrumors newbie

    Joined:
    Feb 26, 2008
    #5

    No kidding. I had the same issue and you'll see 15 different versions in your GMail "All Mail" folder.

    Well, I hope to provide you with a new solution. However, I am a new Mac user and this is my first time posting on a Mac Board. =)

    First, off, I suggest you try this Help link from Google...https://mail.google.com/support/bin/answer.py?answer=78892#

    Now, if you'll go even deeper and click on the "Apple Mail" link and make sure all your settings are the same as they suggest you should be golden. I literally just did this and so far so good. I would love to hear how it's working out for you.

    I tried OmniFocus to manage my tasks but I'm a "widget cranker" so I don't do a lot of bigger task management. I find that the apple todo/ical work great.

    Best of luck to you!
     
  6. ASFx macrumors regular

    Joined:
    Feb 24, 2008
    #6
    I found the best way to get rid of this problem is to simply uncheck the "store notes in inbox" option in the "mailbox behaviors" tab. Once you do that, gmail should work flawlessly using imap and apple mail. I've been using like this with no issues for a few weeks now.
     

Share This Page