Mailbox emptied!

Discussion in 'Mac Apps and Mac App Store' started by cityscape, Aug 21, 2009.

  1. cityscape macrumors newbie

    Joined:
    Jul 1, 2009
    #1
    In trying to rename a folder in Mail, the application can up with a 'can't rename' error. Problem is that is seems to have deleted all the contents of all the sub-folders (except the first few emails of the first folder). How do I get them back!!!??
    (The folder wasn't renamed).
     
  2. omar.kababji macrumors newbie

    omar.kababji

    Joined:
    Aug 21, 2009
    #2
    If you used Time Machine, you can open your Mail and then enter time machine, from there you will be able to restore all your mail boxes, once restored you will get a new mail box containing all your mails, just drag them and drop them in the desired mail box.
     
  3. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #3
    Try selecting the mailbox that's giving you problems, go to the "Mailbox" menu and select "Rebuild". That sometimes fixes empty mailboxes.
     
  4. cityscape thread starter macrumors newbie

    Joined:
    Jul 1, 2009
    #4
    how did it happen?

    Have tried the restore command, but this only works for the inbox, not the emails placed in folders. Any other suggestions?

    Do you have any suggestions as to how it happened in the first place? (Don't want it to happen again!)
     
  5. alanwoollcombe macrumors newbie

    Joined:
    Aug 27, 2009
    #5
    Mailbox emptied and refilled

    Something similar happened to me a couple of days ago. My MacBook runs on Tiger so I don't have Time Machine and I hadn't backed everything up for a few days - in other words, if I couldn't get back to where I was before I tried to rename the mailbox, I would lose a lot of valuable emails.

    What had happened when I tried to rename the critical mailbox was that the mailbox appeared to acquire a greyed-out duplicate. The renamed, active mailbox lost all of its sub-folders (sub-mailboxes?) except the one I was in. That particular sub-folder still showed its message (email) headers, but each email had lost its contents and showed the following error message:

    "The message from ... has not been downloaded from the server. You need to take this account online in order to download it."

    All the missing sub-folders were sitting in the greyed-out phantom mailbox bearing the old name, and they were showing no emails at all.

    To add to the fun, the Undo button in the Edit menu was greyed out too, so I couldn't reverse the process.

    What I did was to rebuild each empty sub-folder (using the Rebuild command in the Mailbox menu). All the missing emails reappeared intact, so I then moved each sub-folder across from the phantom mailbox to the active (renamed) one.

    The one remaining sub-folder that hadn't vanished I moved over to the phantom mailbox, then rebuilt it too and moved it back. I was then able to delete the now empty spare mailbox and back up the whole lot.

    I can't say if that will work on your system, but it did on mine (Mail 2.1.3, OS X 10.4.11)
     

Share This Page