Mailboxes not in Alphabetical Order by Default

Discussion in 'Mac OS X Lion (10.7)' started by currins, Jul 13, 2012.

  1. currins macrumors member

    Dec 24, 2010
    Dumb Question:

    In iCloud, all my mailboxes are organized alphabetically. On my MBP (Lion), they are not - when I add a new mailbox, it just puts it at the bottom.

    I've tried manually synching, removing the iCloud account from my MBP, etc, with no luck.

    This seems silly, but it's annoying. Any ideas?
  2. Rajpdx macrumors regular

    Jun 16, 2012
    Do you mean in Apple Mail? If so you can just drag the mailboxes in the sidebar into whichever order you like.
  3. yusukeaoki macrumors 68030


    Mar 22, 2011
    Tokyo, Japan
    When you open your mail, just click it to sort by date.


    Attached Files:

  4. currins thread starter macrumors member

    Dec 24, 2010
    Apologize for any confusion. Yes, Apple Mail.

    And I'm not talking about mail messages, I'm talking about the Mailboxes (or folders) in the sidebar.

    In the past, when I created a new Mailbox, it automatically showed up in alphabetical order with the rest...very convenient.

    Sure, I could move them manually, but on 4 different devices, it's frustrating.

    The other rub is that on iCloud, they're in alphabetical order. On my iMac, MBP, they're not (all my mailboxes are iCloud versus This Mac).

    Like I said, silly issue, just frustrating. Especially b/c it just started with my migration to iCloud.
  5. rreiser macrumors newbie

    Mar 14, 2013
    How to alphabetize your mailboxes in Apple Mail

    If you want to have your new mailboxes automatically alphabetized when you add them to your existing list of mailboxes in your IMAP folder, make sure that the mailboxes that are already listed there are in alphabetical order. You can do this manually by moving them up and down on the list on the left hand side of your screen. Once you accomplish this task, any new mailboxes you add to IMAP folder will automatically be placed in alphabetical order. I tried this approach and it worked for me.
  6. 2BoyzMom macrumors newbie

    Mar 12, 2015
    Mine was doing the same thing. Finally figured out when I clicked sort by date...I had "All Mailboxes" checked. I had to uncheck that and check Inbox Only. Now it is adding them in ABC order again. Hope this helps. This is on an imac.
  7. eleanorb macrumors newbie

    Apr 26, 2015
    When you say "clicked sort by date" — where did you do that? In mail? In mail preferences? — Eleanorb
  8. redheeler macrumors 604


    Oct 17, 2014
    It's right above the list of messages.
  9. eleanorb, Apr 26, 2015
    Last edited: Apr 26, 2015

    eleanorb macrumors newbie

    Apr 26, 2015
    Yes, I find that I can rearrange my mailbox folders in alphabetical order and they will stay in that order, and a newly created folder will be placed in proper alphabetical sequence. However, if I move a subfolder into the main sequence, it will not automatically be placed in order, I have to move it to the right spot. Is this also your experience?


    To redheeler:

    Hmm. So, are you talking about sorting the messages within a folder, or sorting the folders by name? I thought that this thread was about sorting the folders… Also, I'm using Mail 6.6 — how about you?
  10. 2BoyzMom macrumors newbie

    Mar 12, 2015
    Up at the top click view...then sort by...then date.
  11. PinkyMacGodess macrumors 601


    Mar 7, 2007
    Midwest America.
    FWIW, that only sorts messages.

    I tried the 'disable/close/open/enable' trick, and it didn't work. It is very annoying, not having folders sorted...

    So 'flattening' the OS is more important than sorting the damn folders? Really? o_O

    Outlook can do it...
  12. fwibaux macrumors newbie


    Sep 8, 2016
    I found this that worked perfectly for me :!topic/macvisionaries/UQtzrgiAIrA
    You really need to check all Mailboxes in user/library/Mail/V3(or V2)
  13. PemWeno macrumors newbie


    Jun 19, 2018
    Cairns, FNQ
    OH! Doh! Been wondering/trying to do that for 12 months! Thanks 708347 :)

Share This Page

12 July 13, 2012