Mails are not sending, chilling in outbox, iPhone 4

Discussion in 'iPhone' started by iSlanderous, Jul 19, 2010.

  1. iSlanderous macrumors regular

    Jul 17, 2010
    Brooklyn, NY
    I have been sending mails but every time i think it went through it has actually just been placed in the outbox. I'm on wi-fi and 3G has full bars. What gives? Anyone else having this problem? I have gmail setup thorough exchange, never had this problem before thou. Could this be related to the exchange problems?
  2. frikfrak macrumors regular

    Sep 17, 2007
    I too have this problem, but it seems to be only emails sent from within apps other than mail. I switch to mail after sending them and they're setting in the outbox. Anyone know what's up with that?
  3. Andru1313 macrumors regular

    Mar 6, 2008
    Odd that you posted this.. I just noticed this today this is something that is new.. I have had the phone since launch day and this just starting happening today..
  4. bbydon macrumors 6502a

    May 18, 2005
    I had to redo all my passwords to get it to work again. Don't know if its the same issue.
  5. oakland6980 macrumors member


    Jun 21, 2010
    yea I had the issue too. Turning off my wifi and sending over 3G got it to send so maybe sending email through wifi is the problem?
  6. mike1123 macrumors 6502


    Sep 19, 2007
    That's happening because your outgoing email password was not set. There are two places in mail settings where you need to enter your password; the outgoing one is a bit trickier to find. Look in the outgoing server settings or something like that. I don't have my phone on me, so I can't check, but that is most likely what's causing your issue.
  7. oakland6980 macrumors member


    Jun 21, 2010
    Yea i've tried over different wifi networks and sending emails just get stuck. also when its trying to send the email its not getting emails pushed to me. i have to turn off wifi and then kill mail in the multitasking bar the reopen mail. it sends right away and i get an new email alert. i am using an exchange account.
  8. og1 macrumors regular

    Oct 6, 2008
    do you have the same gmail account setup as IMAP as well, only set to inactive? I did and had this exact problem. delete the imap account and all is well.
  9. Goldinboy17 macrumors 65816


    Jun 21, 2010
    San Francisco, Ca
    I've already entered all the information correctly. Not sure what's up. Since it's a Hover email, It's a little bit more complicated then ordinary GMail.
  10. yetanotherdave macrumors 68000


    Apr 27, 2007
    Bristol, England
    anyone find the solution to this? It's only from other apps for me (including emailing links from safari), it's a PITA to have to launch mail, go into outbox, go to each email and hit send!

    Wifi or 3g makes no difference. is fine, everything else is the problem.

    EDIT found the solution!
  11. asr10 user macrumors regular

    Jul 4, 2010
    Funny, I just noticed this today. To fix it I just had to manually set each specific outgoing mail folder.

    For some reason AOL had two different 'sent' folders, and the iphone by default was going into the one which wasnt working, once I switched to the second 'sent' folder it was fine.

    I tested my gmail and yahoo accounts and they were working fine also.
  12. macncheesy macrumors newbie

    Sep 8, 2010
    This is a WiFi related issue

    This is specifically a problem with mail through WiFi, if WiFi is turned off the outbox is cleared successfully through actively connected 3G network.
  13. biffarino macrumors member

    Feb 1, 2010
    i've never been able to send an email using a data signal when connected a wifi network. never been able to find a straight answer either.
  14. g35 macrumors 6502a

    Dec 13, 2007
    There's a bug, at least with Hotmail, where if you change your password only way to send mail is to delete and re-add the account on the iPhone, even if you update the password in the settnigs. Try that?
  15. jamii3e macrumors newbie

    Jun 3, 2013
    If your outgoing mail message was responding as a "failure" blah blah & if you have another email address as well, of course, I JUST found out that I fixed my own problem by switching the Primary Server ( off and switching ON Other SMTP servers in your Settings under AOL Account Information.

    I found AOL officially sucks LOL and won't help with anything, and it obviously isn't a "iPhone" technicality.

    Hope this was what you were looking for!!
    (Ps this worked for my iPhone, not MacBook iPad or others but wtf why not try?)

Share This Page