Main partition, disk0s2 won't mount after resizing Bootcamp partition

Discussion in 'Windows, Linux & Others on the Mac' started by mahgah, Oct 18, 2013.

  1. mahgah macrumors newbie

    Joined:
    Oct 18, 2013
    #1
    Help, I'm a fairly new Macbook Air owner and today I installed Windows 8 via Bootcamp. I allocated too little space on the Bootcamp partition so I resized it.

    I did this by first allocating free space from Mac OS with Disk Utility. I found that on the Windows end, the partition couldn't integrate the unallocated space so I downloaded a third party program, EaseUS and this easily integrated the unallocated space to the Bootcamp partition.

    But I tried to restart in the Mac OS and the partition wasn't listed so I started in Recovery HD. Booting up Disk Utility, the main partition, disk0s2 is grayed out. I tried Verifying and Repairing the harddrive but that just listed no problems.

    Can anyone help me? I've been searching for hours for a solution and I'm nervous about messing with the Terminal.
     
  2. Quackers, Oct 18, 2013
    Last edited: Oct 18, 2013

    Quackers macrumors 6502a

    Joined:
    Sep 18, 2013
    Location:
    Manchester, UK
    #2
    Wait for more knowledgable people than me but I think you broke it.
    Apple does not allow the Bootcamp partition to be resized once created. I was amazed when I found this out myself so I paid for Camptune which stated it could do it. (Others here have done it successfully).
    Sadly it did not go well for me and it broke everything. IIRC I had to re-install both OSX and Windows.

    Having changed partition sizes with a 3rd party tool I suspect you've damaged things.

    You could try booting from your OSX install disc/usb and resize the OSX partition so that it uses the whole disc again. You can then start again making Bootcamp partition and installing Windows.
    Obviously this will lose your Windows installation and its contents.

    You may even have to delete the Windows partition with Easeus before Disk Utility will do the above.

    I would wait for confirmation of these suggestions first though.
     
  3. mahgah thread starter macrumors newbie

    Joined:
    Oct 18, 2013
    #3
    At this point I'm completely OK with losing all the data in my Windows partition. So if I deleted my Windows partition, do you think that would allow Disk Utility in Recovery to mount my main partition?

    How did you restore your OS X?
     
  4. Quackers macrumors 6502a

    Joined:
    Sep 18, 2013
    Location:
    Manchester, UK
    #4
    I honestly don't know as I had to re-install everything.
    I re-installed OSX by making a Mountain Lion USB from the download when recovering OSX via the Internet Recovery option (as I'd deleted my Recovery HD).

    But I would urge you to wait for other advice first. I wouldn't want to cause you extra work.
     
  5. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #5
    It's probably beyond help and it's time like this that you start to appreciate the importance of backing up your disk partitions. Here is another example of trying to resize a Mac disk from the Windows side and not ending well. If you have no backup, just follow Quackers' advice to reinstall the OS X partition.
     
  6. Olaf.cc macrumors newbie

    Joined:
    Apr 25, 2010
    #6
    I did the same with my Macbook. I'm not a smart man. I'm also okay with being able to activate/mount disk0s2 within Windows so I can at least access the data. Any tips welcome. Story is identical to the one of mahgah, including the use of EaseUS.
     
  7. Mcmeowmers macrumors 6502

    Joined:
    Jun 1, 2015
    #7
    I did this once. What I did was boot into recovery. Then go to terminal...

    http://www.cnet.com/news/tackle-stubborn-disk-partitioning-in-os-x/

    You want to change the type of the messed up partition to Apple_HFS or something named similarly. Find it through the help flag. It's an easy fix if you know what you're doing but the easiest way is to just wipe it all
     

Share This Page