Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Major Airport Problem in Snow Leopard [problem solved]

JML42691

macrumors 68020
Original poster
Oct 24, 2007
2,082
2
I know that there is a thread that is compiling problems and issues with Snow Leopard, but I am having an issue that I feel needs a bit more attention then a post several hundred posts deep in a thread. I haven't been able to browse the forums lately and got nothing from a MRoogle search, so I apologize if this has been posted already.

I moved in to college on the 28th and installed Snow Leopard that night. My dorm has no wifi and you can only access the internet through an ethernet connection. The problem is that all of the academic buildings use wifi access to access the internet and network. Airport on my MacBook will not work at all, I cannot turn it off, I cannot connect to a secured or unsecured network, cannot create a network, nothing. When I click the link to turn Airport off nothing happens. When I attempt to connect to the University's wifi and enter my passcode I get a "Connection Failed" notice. I am unable to connect to any wifi network and essentially have no ability to use Airport to connect to the internet. This is a big problem in my classes and other buildings besides my dorm as I have no ability to access the internet. This has only happened since I upgraded to Snow Leopard, so I am attributing the problem to that along with the other little bugs I am having.

Has anybody else had this problem and found a way to solve it? Because this essentially keeps my computer locked down to my dorm room which can be a real pain. I am tempted to reinstall Snow Leopard tonight or something along those lines to see if there is anything I can do to repair it, but if there is a simpler fix then I would gladly like to hear of it.

My computer is a late-2007 MacBook (Santa-Rosa).
 

webgoat

macrumors 6502a
Sep 20, 2007
592
0
Austin, TX
you can try deleting com.apple.airport.preferences.plist, NetworkInterfaces.plist, and preferences.plist form /Library/Preferences/SystemConfiguration and restart to get the airport interface working again
 
Comment

JML42691

macrumors 68020
Original poster
Oct 24, 2007
2,082
2
you can try deleting com.apple.airport.preferences.plist, NetworkInterfaces.plist, and preferences.plist form /Library/Preferences/SystemConfiguration and restart to get the airport interface working again
Hmm, I can't seem to find those files. There wasn't even a folder labeled "SystemConfiguration" within the preferences folder, may this be part of the problem?
 
Comment

webgoat

macrumors 6502a
Sep 20, 2007
592
0
Austin, TX
you need to be in /Library/Preferences and not ~/Library/Preferences .. with finder active select the go menu and choose go to folder... type in /Library/Preferences/SystemConfiguration and you will see the files... it will require an administrator password to delete them and if you move them to somewhere besides trash it just going to copy them instead of moving them
 
Comment

JML42691

macrumors 68020
Original poster
Oct 24, 2007
2,082
2
you need to be in /Library/Preferences and not ~/Library/Preferences .. with finder active select the go menu and choose go to folder... type in /Library/Preferences/SystemConfiguration and you will see the files... it will require an administrator password to delete them and if you move them to somewhere besides trash it just going to copy them instead of moving them
Thank you so much, that appears to have fixed it. At least now I can turn Airport off. I am currently in my dorm so I cannot test to see if it will let me connect, but it appears that Airport is actually functioning again. Thanks!
 
Comment

Snow Leper

macrumors newbie
Sep 1, 2009
4
2
I had the EXACT same problem on my MBP, and this fixed it!

Thank you so much, I registered just to express my appreciation - Apple was useless when I called them regarding this. I thought my new computer was broken, but now I am happily posting this on WiFi again...


Thanks!!
 
Comment

mikeyz54

macrumors newbie
Jul 31, 2008
10
0
Thank you! This worked for me too.

I had the opposite problem, where when I tried to switch on airport, the spinning wheel would appear. This also happened when I tried to switch on airport from system preferences.

This fix solved my problem immediately!
 
Comment

bjmankoff

macrumors newbie
Aug 31, 2009
3
0
Didn't work for me...

Are there any other possible fixes? I've tried the boards on Apple.com and gdgt.com and have been offered various suggestions but none seem to work, including the one posted here. I followed the directions exactly but the problem persists. If this helps, here is what Console says when I try to connect the wifi:

9/4/09 12:42:35 PM airportd[2267] Apple80211Associate() failed -3902 (Unknown error)
9/4/09 12:42:35 PM Apple80211 framework[98] airportd MIG failed (Associate Event) = -3902 (Unknown error) (port = 40935)

All of that is Greek to me. Does it mean anything to any of you?

Thanks a lot.
 
Comment

Flyby1023

macrumors newbie
Aug 29, 2007
15
0
bjmankoff, you might try the New Location fix.

Sytem Preferences - Network - Location - <drop down box - edit locations> - "+" - <name it whatever you want> - Done - Advanced - TCP/IP - Renew DHCP lease

If your system is using DHCP you should see a bunch of numbers show up. This worked for me but I tried it before I saw the fix in this post, which I may also try.

I was at the Apple store today on this issue and the tech said as far as he and Apple know, this problem doesn't exist.
 
Comment

jasmurphy

macrumors newbie
Sep 5, 2009
1
0
Only been on Macbook Pro a year so still in the honeymoon period. I trusted Apple not to put a foot wrong so hitting this issue with SL was disappointing. I've spent most of tonight reviewing forums and trying the 2 solutions that seem to be touted as successful: -

1. Enter a new location - remember to go to the TCP/IP tab and Renew the DHCP Lease - seems to work for some.

2. Delete the contents of HD/Library/Preferences/SystemConfiguration, Empty Trash and Reboot.

I tried both in that order without luck. After deleting these settings, I still found traces for my Wireless network inside the keychain. I purged those too. Tried 2 again - no luck.

I tried 2 once more but on 'shutdown' then restarted manually. Don't know why but it worked!

Worth a shot if you don't get anywhere with 1 & 2.:D
 
Comment

IKEALICIOUS

macrumors newbie
Sep 10, 2009
1
0
Cannot turn off airport after installing Snow Leopard

This hurts my confidence in Mac a bit. This solution worked in less than 2 mins. Thanks a bunch. Keep up the good Mac world forums.

IKEALICIOUS
 
Comment

bjmankoff

macrumors newbie
Aug 31, 2009
3
0
I've tried everything suggested in 20 different forums. Nothing's working. Is there any way installing a new OS could have killed my airport card?
 
Comment

russcowles

macrumors newbie
Feb 12, 2007
1
0
Omaha, NE
It works

Thanks for pointing out this solution.

My problem was that my iMac (24" 2.16 Ghz Intel) would not communicate with AEBS, although my old iBook G4 would. This quick and easy solution worked well. Many thanks!
:apple:
 
Comment

blue-axolotl

macrumors newbie
Sep 22, 2009
1
0
Airport problems with Snow Leopard

It worked for me too. Thanks
It also shook my confidence in Apple
 
Comment

sophiesophia13

macrumors newbie
Sep 24, 2009
3
0
Oh My God!

you can try deleting com.apple.airport.preferences.plist, NetworkInterfaces.plist, and preferences.plist form /Library/Preferences/SystemConfiguration and restart to get the airport interface working again


Ok, so I've installed Leopard, and now my airport connection is gone. I followed your instructions, well i'm sure i did anyway. I deleted, com.apple.airport.prefrences,NetworkInterfaces.plist, and preferences.plist, and it's still not working. I'm afraid my airport wifi is gone for good. Please tell me i'm wrong. :confused:
 
Comment

polythene pam

macrumors member
Jun 23, 2005
84
0
Florida
I had the same problems

After installing SL last weekend I had no internet connection either. I am also on a college campus and my only access to internet at home is through the university's Wi-Fi.

I still have applecare so I called the 1 800 line. Granted, it did take over an hour of being sent to different people but finally they connected me with someone who knew his stuff.

I have to apologize that I don't remember exactly what he had me do, but more or less it was

1) delete your current internet accounts (in Network Configurations)
2) delete any stored passwords for your internet (in Keychain) (make sure you know your passwords, though!)
3) then he had me reboot my comp and log in in safe mode (holding down the shift button, I think, as the computer started)
4) then I had to delete my cache and system configurations folders (and here is where I don't remember exactly how I got to these folders)
5) reboot again
6) try to connect to the internet

In my case it worked beautifully and my internet has never been faster!!!!!

On a side note I haven't noticed any great changes or improvements with SL, I guess for light users like me it wasn't really a crucial update.
 
Comment

sophiesophia13

macrumors newbie
Sep 24, 2009
3
0
delete cache & system configurations folders

After installing SL last weekend I had no internet connection either. I am also on a college campus and my only access to internet at home is through the university's Wi-Fi.

I still have applecare so I called the 1 800 line. Granted, it did take over an hour of being sent to different people but finally they connected me with someone who knew his stuff.

I have to apologize that I don't remember exactly what he had me do, but more or less it was

1) delete your current internet accounts (in Network Configurations)
2) delete any stored passwords for your internet (in Keychain) (make sure you know your passwords, though!)
3) then he had me reboot my comp and log in in safe mode (holding down the shift button, I think, as the computer started)
4) then I had to delete my cache and system configurations folders (and here is where I don't remember exactly how I got to these folders)
5) reboot again
6) try to connect to the internet

In my case it worked beautifully and my internet has never been faster!!!!!

On a side note I haven't noticed any great changes or improvements with SL, I guess for light users like me it wasn't really a crucial update.


I was just wondering, might be a stupid question but I want to make sure I do EVERY thing perfect. So, I delete the ENTIRE Cache & System Configurations Folders? That wont get rid of them forever? Will Cache & System Configurations folders replace themselves somehow? I would delete them right away, but I'm nervous of getting rid of something valuable to the whole system.
 
Comment

sophiesophia13

macrumors newbie
Sep 24, 2009
3
0
Only been on Macbook Pro a year so still in the honeymoon period. I trusted Apple not to put a foot wrong so hitting this issue with SL was disappointing. I've spent most of tonight reviewing forums and trying the 2 solutions that seem to be touted as successful: -

1. Enter a new location - remember to go to the TCP/IP tab and Renew the DHCP Lease - seems to work for some.

2. Delete the contents of HD/Library/Preferences/SystemConfiguration, Empty Trash and Reboot.

I tried both in that order without luck. After deleting these settings, I still found traces for my Wireless network inside the keychain. I purged those too. Tried 2 again - no luck.

I tried 2 once more but on 'shutdown' then restarted manually. Don't know why but it worked!

Worth a shot if you don't get anywhere with 1 & 2.:D

OH MY GOD, AMAZING! I was just about to cry, I thought I lost my internet for good! I almost considered having it fixed somewhere for probably a crap load of money, thank God! I tried EVERY thing and this WORKED! THANK YOU SOOOOOOOOOOOOO MUCH!:D
 
Comment

polythene pam

macrumors member
Jun 23, 2005
84
0
Florida
The Apple employee had me delete the caches and drag the system configuration folder onto my desktop. When we fixed the problem he told me to delete that folder too.

I'm glad you fixed your problem!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.