MAJOR apple mail issue

Discussion in 'macOS' started by lindsayanng, Jan 8, 2011.

  1. lindsayanng macrumors 68000

    lindsayanng

    Joined:
    May 4, 2008
    Location:
    East Haven, CT
    #1
    So I was deleting some old email attachment files and saved sent email files because I was getting ready to transfer my imac computer contents to a mac mini and needed to make a few MB of room for it to fit.

    I accidentally left on the "show hidden files" command I ran when doing website design work and I deleted some apparently important file while moving and deleting.

    What happened after I deleted the file:
    I was not receiving any emails from my gmail account nor could I send emails. Sending emails would just have it spinning and spinning

    What I did to try to remedy: (always quitting and reopening Mail app)
    First I tried disabling all accounts and leaving only one active that I didn't mess with. This resulted in no change, still had the spinning "sending" email.

    Deleted accounts and recreated the accounts - same issue

    At this point I was so frustrated and did something without researching it first. I deleted the mail program from the applications folder. All of the library folders are still there, but the program file is not.

    I read up and read that the Pacifist program could help me install just the Maill app so I downloaded that program, installed the Mail App program, and then tried to open it and I get this error:

    "can not open Mail App. 4.0 is not compatible with this version of mac OSX" (version of mac OSX is 10.6.5)

    So then I conceded to completely reinstall the operating system disk. I own the Snow Leopard disk which I purchased as a "family pack"

    I reinstalled the OS which then showed the Apple Mail icon in the Applications folder and I had a brief moment of glee. I tried to open this new version of Apple Mail and I get the same error!!!!

    I need to know how to reinstall apple mail for the version of OSX that I have..
     
  2. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #2
    Weird.

    After Pacifist, that error made sense. Your main OS was 10.6.5, but the version of Mail it restored was for an earlier version of 10.6. I'd think that manually re-running the OS X 10.6.5 combo update (which you'd manually have to download from the Apple website) would patch Mail up to your current version.

    If it's still not working after reinstalling OS X from the scratch, one thing I'd try is to make another user account on your Mac, then logon as that user and see if Mail starts. If it does, then something specific to your other user account is hosed up, which reinstalling the OS won't fix. Maybe renaming the Mail folders in your home folder > Library so Mail creates them new?
     
  3. lindsayanng thread starter macrumors 68000

    lindsayanng

    Joined:
    May 4, 2008
    Location:
    East Haven, CT
    #3
    AWESOME!! Renaming the folders and letting Apple Mail rebuild them was it.. PERFECT - THANK YOU! All is well again.

    p.s. - it was definitely specific to the one account because the others were working just fine. I knew I had somehow deleted an important file inside of those saved mail folders. Renaming the folders and letting Apple Mail rebuild them allowed Apple Mail to also rebuild that file that I somehow deleted.

    I THOUGHT that reinstalling the OS would have done the same thing, but apparently not.. We are all good now, thank you!
     
  4. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #4
    I know I'm late to the party, but this information helped me as well, my mail tool just stopped sending mail from one of my accounts. I deleted the mail directories in the library directory and now it all works great.

    Thanks.
     
  5. BJG15 macrumors newbie

    Joined:
    Jan 10, 2012
    #5
    in a similar vein

    Having had a problem with mail i deleted and reinstalled it from the DVD but now when i try to open it i get this message" you can ’t use this version of Mail with this version of Mac OS, You have Mail version 4.3 (1081/1084). It can’t be used on Mac OS X Version 10.6.8 (Build 10K549). For more information, click the Help button." I have tried reinstalling it a number of times and still get the same result. I have also downloaded the 10.6.8 combo installer and repaired disk permissions to no effect. Does anyone have any suggestions. Thanks
     

Share This Page