Major iPhone MMS bug?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by philiporeilly, Jun 28, 2009.

  1. philiporeilly macrumors newbie

    Jun 28, 2008
    I recently sent a plain text message (101 characters) to my Dad and he called me back to say that he couldn't receive MMS messages as his handset is really old. This alarmed me as I couldnt understand why I would get charged for an MMS instead of plain text message.

    Apparently if you send a message to more than one contact, they are automatically sent as group MMS messages and it doesnt matter even if you use just plain text and under 160 charracters. I checked my account online and yes I am being charged for 11 MMS messages that should have been plain text messages. Thank god my Dad told me and I spotted this early.

    I have sent a message to O2 Ireland and logged the issue on Apples Developer bug reporter website but I am interested if this is effecting others when sending texts to more than one contact.

    For those of you worried about being overcharged you can disable MMS in SETTINGS > MESSAGES > MMS MESSAGING > OFF


    iPhone Os 3.0
    16Gb 3G
    O2 Ireland Carrier
  2. GoCubsGo macrumors Nehalem


    Feb 19, 2005
  3. philiporeilly thread starter macrumors newbie

    Jun 28, 2008
    I've had a few responses to say that it doesnt effect all users on iPhone 3.0 Os. i've disabled MMS by default to be careful but it always switches to MMS ater I select second contact.

    iPhone 16Gb 3G
    iPhone 3.0 Os
    O2 Ireland Network (Apple authorised)
    Non jailbroken phone
  4. stupidm4n macrumors member

    Sep 29, 2008
    mine only switches to mms if the second contact you add is email address not a phone number, you sure its not that as you can now email photos (and video mms that you receive from other people) using the messages app
  5. paul100 macrumors newbie

    Jun 24, 2009
    Well Philiporeilly your Service provider might have charged wrongly, but this might not be the case with all service providers right. Anyways thank you for cautioning me, hereafter I'll be on alert.
  6. philiporeilly thread starter macrumors newbie

    Jun 28, 2008
    Had a few responses from other O2 Ireland users and it doesnt effect everyone. One Apple staff member contacted me and said he had two iPhones and only one of them was causing problems with MMS. Hes investigating it and will post a solution if I am sent one.
  7. Jon-Luke macrumors 6502


    May 22, 2009
    Cape Town
    I'm experiencing the same problem on my 3G iPhone and the only way to disable it is to turn MMS off - Its quite a headache really because I use MMS to send contact details to people quite often. Lets hope apple send out a fix soon! :(

    Anyone else experiencing this problem should send a bug report to Apple to more reports they get, the more likely they are to do something about it. Here's a link:
  8. firstrest macrumors member

    Oct 12, 2006
    Another potentially expensive gotcha is sending an MMS message from abroad also turns data roaming on. The first you know of it is when you start getting e-mail alerts.

    I have been told of this by colleagues and I think it's also pretty poor.
  9. uberamd macrumors 68030


    May 26, 2009
    MMS is a data service after all.

    Update: I just tested mine, sends as a SMS

  10. philiporeilly thread starter macrumors newbie

    Jun 28, 2008
    Its not an ideal solution but I did a complete restore and then selected restore from backup and all is now working as it should be. Its still an issue for some but this should fix it.

Share This Page